FAQ
I tried to set up hadoop with cygwin according to the
paper:http://developer.amazonwebservices.com/connect/entry.jspa?externalID=873
But I had problems working with dyndns.I created a new host
there:prerna.dyndns.org
and gave the ip address of it in hadoop-ec2-env.sh as a value of MASTER_HOST.
But when I do bin/hadoop-ec2 start-hadoop the error comes:
ssh:connect to host prerna.dyndns.org,port 22:connection refused
ssh failed for root@prerna.dyndns.org
Also a warning comes that:id_rsa_gsg-keypair not accesible:No such
file or directory though there is this file.

Thanks
Prerna

Search Discussions

  • Edward J. Yoon at Apr 17, 2008 at 1:18 am
    I didn't try to run on cygwin, but you may need to install a ssh.

    http://pigtail.net/LRP/printsrv/cygwin-sshd.html

    On Tue, Apr 15, 2008 at 11:54 PM, Prerna Manaktala
    wrote:
    I tried to set up hadoop with cygwin according to the
    paper:http://developer.amazonwebservices.com/connect/entry.jspa?externalID=873
    But I had problems working with dyndns.I created a new host
    there:prerna.dyndns.org
    and gave the ip address of it in hadoop-ec2-env.sh as a value of MASTER_HOST.
    But when I do bin/hadoop-ec2 start-hadoop the error comes:
    ssh:connect to host prerna.dyndns.org,port 22:connection refused
    ssh failed for root@prerna.dyndns.org
    Also a warning comes that:id_rsa_gsg-keypair not accesible:No such
    file or directory though there is this file.

    Thanks
    Prerna


    --
    B. Regards,
    Edward J. Yoon
  • Prerna Manaktala at Apr 17, 2008 at 11:00 pm
    thanks
    Already installed.
    but still ssh to the newly created host in dyndns site is not working

    ssh -i path to id_rsa prerna.dyndns.org..
    it says connection to port 22 refused

    Prerna
    On Wed, Apr 16, 2008 at 9:17 PM, Edward J. Yoon wrote:
    I didn't try to run on cygwin, but you may need to install a ssh.

    http://pigtail.net/LRP/printsrv/cygwin-sshd.html

    On Tue, Apr 15, 2008 at 11:54 PM, Prerna Manaktala
    wrote:
    I tried to set up hadoop with cygwin according to the
    paper:http://developer.amazonwebservices.com/connect/entry.jspa?externalID=873
    But I had problems working with dyndns.I created a new host
    there:prerna.dyndns.org
    and gave the ip address of it in hadoop-ec2-env.sh as a value of MASTER_HOST.
    But when I do bin/hadoop-ec2 start-hadoop the error comes:
    ssh:connect to host prerna.dyndns.org,port 22:connection refused
    ssh failed for root@prerna.dyndns.org
    Also a warning comes that:id_rsa_gsg-keypair not accesible:No such
    file or directory though there is this file.

    Thanks
    Prerna


    --
    B. Regards,
    Edward J.
  • Edward J. Yoon at Apr 17, 2008 at 11:13 pm
    Administrator@xanadu ~
    $ ssh
    usage: ssh [-1246AaCfgKkMNnqsTtVvXxY] [-b bind_address] [-c cipher_spec]
    [-D [bind_address:]port] [-e escape_char] [-F configfile]
    [-i identity_file] [-L [bind_address:]port:host:hostport]
    [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
    [-R [bind_address:]port:host:hostport] [-S ctl_path]
    [-w local_tun[:remote_tun]] [user@]hostname [command]

    Administrator@xanadu ~
    $ ssh localhost
    ssh: connect to host localhost port 22: Connection refused

    $ ssh-host-config
    Generating /etc/ssh_host_key
    Generating /etc/ssh_host_rsa_key
    Generating /etc/ssh_host_dsa_key
    Generating /etc/ssh_config file
    Privilege separation is set to yes by default since OpenSSH 3.3.
    However, this requires a non-privileged account called 'sshd'.
    ...
    Host configuration finished. Have fun!

    Administrator@xanadu ~
    $ net start sshd
    The CYGWIN sshd service is starting.
    The CYGWIN sshd service was started successfully.

    Administrator@xanadu ~
    $ ssh localhost
    The authenticity of host 'localhost (127.0.0.1)' can't be established.
    RSA key fingerprint is a2:6f:31:ed:d1:d9:7c:53:d8:b3:9d:79:82:9f:55:92.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added 'localhost' (RSA) to the list of known hosts.

    On Fri, Apr 18, 2008 at 7:59 AM, Prerna Manaktala
    wrote:
    thanks
    Already installed.
    but still ssh to the newly created host in dyndns site is not working

    ssh -i path to id_rsa prerna.dyndns.org..
    it says connection to port 22 refused

    Prerna

    On Wed, Apr 16, 2008 at 9:17 PM, Edward J. Yoon wrote:
    I didn't try to run on cygwin, but you may need to install a ssh.

    http://pigtail.net/LRP/printsrv/cygwin-sshd.html

    On Tue, Apr 15, 2008 at 11:54 PM, Prerna Manaktala
    wrote:
    I tried to set up hadoop with cygwin according to the
    paper:http://developer.amazonwebservices.com/connect/entry.jspa?externalID=873
    But I had problems working with dyndns.I created a new host
    there:prerna.dyndns.org
    and gave the ip address of it in hadoop-ec2-env.sh as a value of MASTER_HOST.
    But when I do bin/hadoop-ec2 start-hadoop the error comes:
    ssh:connect to host prerna.dyndns.org,port 22:connection refused
    ssh failed for root@prerna.dyndns.org
    Also a warning comes that:id_rsa_gsg-keypair not accesible:No such
    file or directory though there is this file.

    Thanks
    Prerna


    --
    B. Regards,
    Edward J.


    --
    B. Regards,
    Edward J. Yoon
  • Prerna Manaktala at Apr 17, 2008 at 11:27 pm
    yes this thing I already tried and in working fine but as I told u I
    am not able to ssh to any host I created at the site dyndns
    On Thu, Apr 17, 2008 at 7:13 PM, Edward J. Yoon wrote:
    Administrator@xanadu ~
    $ ssh
    usage: ssh [-1246AaCfgKkMNnqsTtVvXxY] [-b bind_address] [-c cipher_spec]
    [-D [bind_address:]port] [-e escape_char] [-F configfile]
    [-i identity_file] [-L [bind_address:]port:host:hostport]
    [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
    [-R [bind_address:]port:host:hostport] [-S ctl_path]
    [-w local_tun[:remote_tun]] [user@]hostname [command]

    Administrator@xanadu ~
    $ ssh localhost
    ssh: connect to host localhost port 22: Connection refused

    $ ssh-host-config
    Generating /etc/ssh_host_key
    Generating /etc/ssh_host_rsa_key
    Generating /etc/ssh_host_dsa_key
    Generating /etc/ssh_config file
    Privilege separation is set to yes by default since OpenSSH 3.3.
    However, this requires a non-privileged account called 'sshd'.
    ...
    Host configuration finished. Have fun!

    Administrator@xanadu ~
    $ net start sshd
    The CYGWIN sshd service is starting.
    The CYGWIN sshd service was started successfully.

    Administrator@xanadu ~
    $ ssh localhost
    The authenticity of host 'localhost (127.0.0.1)' can't be established.
    RSA key fingerprint is a2:6f:31:ed:d1:d9:7c:53:d8:b3:9d:79:82:9f:55:92.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added 'localhost' (RSA) to the list of known hosts.

    On Fri, Apr 18, 2008 at 7:59 AM, Prerna Manaktala


    wrote:
    thanks
    Already installed.
    but still ssh to the newly created host in dyndns site is not working

    ssh -i path to id_rsa prerna.dyndns.org..
    it says connection to port 22 refused

    Prerna

    On Wed, Apr 16, 2008 at 9:17 PM, Edward J. Yoon wrote:
    I didn't try to run on cygwin, but you may need to install a ssh.

    http://pigtail.net/LRP/printsrv/cygwin-sshd.html

    On Tue, Apr 15, 2008 at 11:54 PM, Prerna Manaktala
    wrote:
    I tried to set up hadoop with cygwin according to the
    paper:http://developer.amazonwebservices.com/connect/entry.jspa?externalID=873
    But I had problems working with dyndns.I created a new host
    there:prerna.dyndns.org
    and gave the ip address of it in hadoop-ec2-env.sh as a value of MASTER_HOST.
    But when I do bin/hadoop-ec2 start-hadoop the error comes:
    ssh:connect to host prerna.dyndns.org,port 22:connection refused
    ssh failed for root@prerna.dyndns.org
    Also a warning comes that:id_rsa_gsg-keypair not accesible:No such
    file or directory though there is this file.

    Thanks
    Prerna


    --
    B. Regards,
    Edward J.




    --
    B. Regards,
    Edward J. Yoon
  • Edward J. Yoon at Apr 17, 2008 at 11:35 pm
    Your ISP may be blocking access to critical ports behind their
    routers. Can you access any ports on your router? You may want to try
    setting up your router to forward some other port (80?) to your
    server's port 22.

    Thanks,
    Edward.

    On Fri, Apr 18, 2008 at 8:26 AM, Prerna Manaktala
    wrote:
    yes this thing I already tried and in working fine but as I told u I
    am not able to ssh to any host I created at the site dyndns

    On Thu, Apr 17, 2008 at 7:13 PM, Edward J. Yoon wrote:
    Administrator@xanadu ~
    $ ssh
    usage: ssh [-1246AaCfgKkMNnqsTtVvXxY] [-b bind_address] [-c cipher_spec]
    [-D [bind_address:]port] [-e escape_char] [-F configfile]
    [-i identity_file] [-L [bind_address:]port:host:hostport]
    [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
    [-R [bind_address:]port:host:hostport] [-S ctl_path]
    [-w local_tun[:remote_tun]] [user@]hostname [command]

    Administrator@xanadu ~
    $ ssh localhost
    ssh: connect to host localhost port 22: Connection refused

    $ ssh-host-config
    Generating /etc/ssh_host_key
    Generating /etc/ssh_host_rsa_key
    Generating /etc/ssh_host_dsa_key
    Generating /etc/ssh_config file
    Privilege separation is set to yes by default since OpenSSH 3.3.
    However, this requires a non-privileged account called 'sshd'.
    ...
    Host configuration finished. Have fun!

    Administrator@xanadu ~
    $ net start sshd
    The CYGWIN sshd service is starting.
    The CYGWIN sshd service was started successfully.

    Administrator@xanadu ~
    $ ssh localhost
    The authenticity of host 'localhost (127.0.0.1)' can't be established.
    RSA key fingerprint is a2:6f:31:ed:d1:d9:7c:53:d8:b3:9d:79:82:9f:55:92.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added 'localhost' (RSA) to the list of known hosts.

    On Fri, Apr 18, 2008 at 7:59 AM, Prerna Manaktala


    wrote:
    thanks
    Already installed.
    but still ssh to the newly created host in dyndns site is not working

    ssh -i path to id_rsa prerna.dyndns.org..
    it says connection to port 22 refused

    Prerna

    On Wed, Apr 16, 2008 at 9:17 PM, Edward J. Yoon wrote:
    I didn't try to run on cygwin, but you may need to install a ssh.

    http://pigtail.net/LRP/printsrv/cygwin-sshd.html

    On Tue, Apr 15, 2008 at 11:54 PM, Prerna Manaktala
    wrote:
    I tried to set up hadoop with cygwin according to the
    paper:http://developer.amazonwebservices.com/connect/entry.jspa?externalID=873
    But I had problems working with dyndns.I created a new host
    there:prerna.dyndns.org
    and gave the ip address of it in hadoop-ec2-env.sh as a value of MASTER_HOST.
    But when I do bin/hadoop-ec2 start-hadoop the error comes:
    ssh:connect to host prerna.dyndns.org,port 22:connection refused
    ssh failed for root@prerna.dyndns.org
    Also a warning comes that:id_rsa_gsg-keypair not accesible:No such
    file or directory though there is this file.

    Thanks
    Prerna


    --
    B. Regards,
    Edward J.




    --
    B. Regards,
    Edward J. Yoon


    --
    B. Regards,
    Edward J. Yoon
  • Prerna Manaktala at Apr 17, 2008 at 11:44 pm
    how to do that?
    On Thu, Apr 17, 2008 at 7:35 PM, Edward J. Yoon wrote:
    Your ISP may be blocking access to critical ports behind their
    routers. Can you access any ports on your router? You may want to try
    setting up your router to forward some other port (80?) to your
    server's port 22.

    Thanks,
    Edward.

    On Fri, Apr 18, 2008 at 8:26 AM, Prerna Manaktala


    wrote:
    yes this thing I already tried and in working fine but as I told u I
    am not able to ssh to any host I created at the site dyndns

    On Thu, Apr 17, 2008 at 7:13 PM, Edward J. Yoon wrote:
    Administrator@xanadu ~
    $ ssh
    usage: ssh [-1246AaCfgKkMNnqsTtVvXxY] [-b bind_address] [-c cipher_spec]
    [-D [bind_address:]port] [-e escape_char] [-F configfile]
    [-i identity_file] [-L [bind_address:]port:host:hostport]
    [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
    [-R [bind_address:]port:host:hostport] [-S ctl_path]
    [-w local_tun[:remote_tun]] [user@]hostname [command]

    Administrator@xanadu ~
    $ ssh localhost
    ssh: connect to host localhost port 22: Connection refused

    $ ssh-host-config
    Generating /etc/ssh_host_key
    Generating /etc/ssh_host_rsa_key
    Generating /etc/ssh_host_dsa_key
    Generating /etc/ssh_config file
    Privilege separation is set to yes by default since OpenSSH 3.3.
    However, this requires a non-privileged account called 'sshd'.
    ...
    Host configuration finished. Have fun!

    Administrator@xanadu ~
    $ net start sshd
    The CYGWIN sshd service is starting.
    The CYGWIN sshd service was started successfully.

    Administrator@xanadu ~
    $ ssh localhost
    The authenticity of host 'localhost (127.0.0.1)' can't be established.
    RSA key fingerprint is a2:6f:31:ed:d1:d9:7c:53:d8:b3:9d:79:82:9f:55:92.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added 'localhost' (RSA) to the list of known hosts.

    On Fri, Apr 18, 2008 at 7:59 AM, Prerna Manaktala


    wrote:
    thanks
    Already installed.
    but still ssh to the newly created host in dyndns site is not working

    ssh -i path to id_rsa prerna.dyndns.org..
    it says connection to port 22 refused

    Prerna

    On Wed, Apr 16, 2008 at 9:17 PM, Edward J. Yoon wrote:
    I didn't try to run on cygwin, but you may need to install a ssh.

    http://pigtail.net/LRP/printsrv/cygwin-sshd.html

    On Tue, Apr 15, 2008 at 11:54 PM, Prerna Manaktala
    wrote:
    I tried to set up hadoop with cygwin according to the
    paper:http://developer.amazonwebservices.com/connect/entry.jspa?externalID=873
    But I had problems working with dyndns.I created a new host
    there:prerna.dyndns.org
    and gave the ip address of it in hadoop-ec2-env.sh as a value of MASTER_HOST.
    But when I do bin/hadoop-ec2 start-hadoop the error comes:
    ssh:connect to host prerna.dyndns.org,port 22:connection refused
    ssh failed for root@prerna.dyndns.org
    Also a warning comes that:id_rsa_gsg-keypair not accesible:No such
    file or directory though there is this file.

    Thanks
    Prerna


    --
    B. Regards,
    Edward J.




    --
    B. Regards,
    Edward J. Yoon


    --


    B. Regards,
    Edward J. Yoon
  • Edward J. Yoon at Apr 18, 2008 at 12:08 am
    It wasn't too difficult though I do not remember the details.
    Maybe searching the WWW does reveal the details

    http://www.google.com/search?q=dyndns+and+ssh

    -Edward

    On Fri, Apr 18, 2008 at 8:43 AM, Prerna Manaktala
    wrote:
    how to do that?

    On Thu, Apr 17, 2008 at 7:35 PM, Edward J. Yoon wrote:
    Your ISP may be blocking access to critical ports behind their
    routers. Can you access any ports on your router? You may want to try
    setting up your router to forward some other port (80?) to your
    server's port 22.

    Thanks,
    Edward.

    On Fri, Apr 18, 2008 at 8:26 AM, Prerna Manaktala


    wrote:
    yes this thing I already tried and in working fine but as I told u I
    am not able to ssh to any host I created at the site dyndns

    On Thu, Apr 17, 2008 at 7:13 PM, Edward J. Yoon wrote:
    Administrator@xanadu ~
    $ ssh
    usage: ssh [-1246AaCfgKkMNnqsTtVvXxY] [-b bind_address] [-c cipher_spec]
    [-D [bind_address:]port] [-e escape_char] [-F configfile]
    [-i identity_file] [-L [bind_address:]port:host:hostport]
    [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
    [-R [bind_address:]port:host:hostport] [-S ctl_path]
    [-w local_tun[:remote_tun]] [user@]hostname [command]

    Administrator@xanadu ~
    $ ssh localhost
    ssh: connect to host localhost port 22: Connection refused

    $ ssh-host-config
    Generating /etc/ssh_host_key
    Generating /etc/ssh_host_rsa_key
    Generating /etc/ssh_host_dsa_key
    Generating /etc/ssh_config file
    Privilege separation is set to yes by default since OpenSSH 3.3.
    However, this requires a non-privileged account called 'sshd'.
    ...
    Host configuration finished. Have fun!

    Administrator@xanadu ~
    $ net start sshd
    The CYGWIN sshd service is starting.
    The CYGWIN sshd service was started successfully.

    Administrator@xanadu ~
    $ ssh localhost
    The authenticity of host 'localhost (127.0.0.1)' can't be established.
    RSA key fingerprint is a2:6f:31:ed:d1:d9:7c:53:d8:b3:9d:79:82:9f:55:92.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added 'localhost' (RSA) to the list of known hosts.

    On Fri, Apr 18, 2008 at 7:59 AM, Prerna Manaktala


    wrote:
    thanks
    Already installed.
    but still ssh to the newly created host in dyndns site is not working

    ssh -i path to id_rsa prerna.dyndns.org..
    it says connection to port 22 refused

    Prerna

    On Wed, Apr 16, 2008 at 9:17 PM, Edward J. Yoon wrote:
    I didn't try to run on cygwin, but you may need to install a ssh.

    http://pigtail.net/LRP/printsrv/cygwin-sshd.html

    On Tue, Apr 15, 2008 at 11:54 PM, Prerna Manaktala
    wrote:
    I tried to set up hadoop with cygwin according to the
    paper:http://developer.amazonwebservices.com/connect/entry.jspa?externalID=873
    But I had problems working with dyndns.I created a new host
    there:prerna.dyndns.org
    and gave the ip address of it in hadoop-ec2-env.sh as a value of MASTER_HOST.
    But when I do bin/hadoop-ec2 start-hadoop the error comes:
    ssh:connect to host prerna.dyndns.org,port 22:connection refused
    ssh failed for root@prerna.dyndns.org
    Also a warning comes that:id_rsa_gsg-keypair not accesible:No such
    file or directory though there is this file.

    Thanks
    Prerna


    --
    B. Regards,
    Edward J.




    --
    B. Regards,
    Edward J. Yoon


    --


    B. Regards,
    Edward J. Yoon


    --
    B. Regards,
    Edward J. Yoon
  • Prerna Manaktala at Apr 18, 2008 at 2:05 am
    hey
    thanks but I am still not able to figure out.
    Please help
    On Thu, Apr 17, 2008 at 8:00 PM, Edward J. Yoon wrote:
    It wasn't too difficult though I do not remember the details.
    Maybe searching the WWW does reveal the details

    http://www.google.com/search?q=dyndns+and+ssh

    -Edward

    On Fri, Apr 18, 2008 at 8:43 AM, Prerna Manaktala


    wrote:
    how to do that?

    On Thu, Apr 17, 2008 at 7:35 PM, Edward J. Yoon wrote:
    Your ISP may be blocking access to critical ports behind their
    routers. Can you access any ports on your router? You may want to try
    setting up your router to forward some other port (80?) to your
    server's port 22.

    Thanks,
    Edward.

    On Fri, Apr 18, 2008 at 8:26 AM, Prerna Manaktala


    wrote:
    yes this thing I already tried and in working fine but as I told u I
    am not able to ssh to any host I created at the site dyndns

    On Thu, Apr 17, 2008 at 7:13 PM, Edward J. Yoon wrote:
    Administrator@xanadu ~
    $ ssh
    usage: ssh [-1246AaCfgKkMNnqsTtVvXxY] [-b bind_address] [-c cipher_spec]
    [-D [bind_address:]port] [-e escape_char] [-F configfile]
    [-i identity_file] [-L [bind_address:]port:host:hostport]
    [-l login_name] [-m mac_spec] [-O ctl_cmd] [-o option] [-p port]
    [-R [bind_address:]port:host:hostport] [-S ctl_path]
    [-w local_tun[:remote_tun]] [user@]hostname [command]

    Administrator@xanadu ~
    $ ssh localhost
    ssh: connect to host localhost port 22: Connection refused

    $ ssh-host-config
    Generating /etc/ssh_host_key
    Generating /etc/ssh_host_rsa_key
    Generating /etc/ssh_host_dsa_key
    Generating /etc/ssh_config file
    Privilege separation is set to yes by default since OpenSSH 3.3.
    However, this requires a non-privileged account called 'sshd'.
    ...
    Host configuration finished. Have fun!

    Administrator@xanadu ~
    $ net start sshd
    The CYGWIN sshd service is starting.
    The CYGWIN sshd service was started successfully.

    Administrator@xanadu ~
    $ ssh localhost
    The authenticity of host 'localhost (127.0.0.1)' can't be established.
    RSA key fingerprint is a2:6f:31:ed:d1:d9:7c:53:d8:b3:9d:79:82:9f:55:92.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added 'localhost' (RSA) to the list of known hosts.

    On Fri, Apr 18, 2008 at 7:59 AM, Prerna Manaktala


    wrote:
    thanks
    Already installed.
    but still ssh to the newly created host in dyndns site is not working

    ssh -i path to id_rsa prerna.dyndns.org..
    it says connection to port 22 refused

    Prerna

    On Wed, Apr 16, 2008 at 9:17 PM, Edward J. Yoon wrote:
    I didn't try to run on cygwin, but you may need to install a ssh.

    http://pigtail.net/LRP/printsrv/cygwin-sshd.html

    On Tue, Apr 15, 2008 at 11:54 PM, Prerna Manaktala
    wrote:
    I tried to set up hadoop with cygwin according to the
    paper:http://developer.amazonwebservices.com/connect/entry.jspa?externalID=873
    But I had problems working with dyndns.I created a new host
    there:prerna.dyndns.org
    and gave the ip address of it in hadoop-ec2-env.sh as a value of MASTER_HOST.
    But when I do bin/hadoop-ec2 start-hadoop the error comes:
    ssh:connect to host prerna.dyndns.org,port 22:connection refused
    ssh failed for root@prerna.dyndns.org
    Also a warning comes that:id_rsa_gsg-keypair not accesible:No such
    file or directory though there is this file.

    Thanks
    Prerna


    --
    B. Regards,
    Edward J.




    --
    B. Regards,
    Edward J. Yoon


    --


    B. Regards,
    Edward J. Yoon


    --


    B. Regards,
    Edward J. Yoon

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcommon-user @
categorieshadoop
postedApr 15, '08 at 2:55p
activeApr 18, '08 at 2:05a
posts9
users2
websitehadoop.apache.org...
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase