FAQ
Hello all,

I wanted to share my experience with you who wanted to upgrade Hadoop from
0.12 or previous versions to more recent versions like 0.16

After installing 0.16 and tried start-dfs.sh, Namenode gave me an exception
saying I had to use "-upgrade" option.
I gave "-upgrade" option and Namenode and Datanodes came up alright.
But when I tried finalizing the upgrade, but it didn't work, nor did
"-rollback" option work.
From there on, the only way I could have the cluster up and running was to
give "-upgrade" option.

So here is my advice : Move to 0.13 first and then do the upgrade from
there.

However, following the steps found in the wiki, I was able to upgrade from
0.12 to 0.13 alright.
I hope it's not going to be too painful upgrading from 0.13 to 0.14 or
upwards, using "-upgrade / -rollback / -finalize" options :-)

Also, if anybody wanted to share any good or painful experience with me, I
would really appreciate it!

/Taeho

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcommon-user @
categorieshadoop
postedMar 6, '08 at 10:19a
activeMar 6, '08 at 10:19a
posts1
users1
websitehadoop.apache.org...
irc#hadoop

1 user in discussion

Taeho Kang: 1 post

People

Translate

site design / logo © 2022 Grokbase