FAQ
Hi all,

I have copied my files using hadoop in the following path
"/user/hadoop/input" path. Now i need to open the "index.php" file which
located in the above path, so i configure that path in apache. Then i tried
in Ubuntu using vim 000-default and edit the below two lines.

DocumentRoot /user/hadoop/input
<Directory /user/hadoop/input>

But my "index.php" not working because file(index.php) not viewed, Just
throw an following error.

The requested URL /input/index.php was not found on this server.

Kindly check and advise me how to solve this issue.


Thanks,
Mariaprabudass

--
View this message in context: http://old.nabble.com/How-to-view-the-php-file-which-is-located-in-hadoop-path--tp32503739p32503739.html
Sent from the Hadoop core-dev mailing list archive at Nabble.com.

Search Discussions

  • Kihwal Lee at Sep 21, 2011 at 6:30 pm
    Maria,

    In general, when you try to serve contents off a data storage, the storage
    needs to be mounted so that the apache web server itself or the module in
    charge (in your case probably the php module) can find it using standard
    system libraries and system calls.

    HDFS itself is not a POSIX file system that can be directly mounted. There
    is a fuse implementation that sort of bridges the gap, but it is provided
    only for convenience, not as a something that turns HDFS into a general
    purpose clustered file system.

    The focus of HDFS design and development has not been on online serving, so
    what you are trying probably is not the right direction. If you explain why
    you are using hadoop/hdfs and what you what to achieve, I am sure you will
    get good advices from the community.

    To reach the relevant audience, please post your usage questions to one of
    the *-user maling lists.

    Kihwal

    On 9/21/11 6:30 AM, "mariaprabudass" wrote:



    Hi all,

    I have copied my files using hadoop in the following path
    "/user/hadoop/input" path. Now i need to open the "index.php" file which
    located in the above path, so i configure that path in apache. Then i tried
    in Ubuntu using vim 000-default and edit the below two lines.

    DocumentRoot /user/hadoop/input
    <Directory /user/hadoop/input>

    But my "index.php" not working because file(index.php) not viewed, Just
    throw an following error.

    The requested URL /input/index.php was not found on this server.

    Kindly check and advise me how to solve this issue.


    Thanks,
    Mariaprabudass

    --
    View this message in context:
    http://old.nabble.com/How-to-view-the-php-file-which-is-located-in-hadoop-path
    --tp32503739p32503739.html
    Sent from the Hadoop core-dev mailing list archive at Nabble.com.
  • Maria Prabudass at Sep 26, 2011 at 4:59 pm
    Hi,

    I have copied my "php" files using hadoop command in the following path "*
    /user/hadoop/input*" path. Now i need to open that "index.php" file which
    located in the above path using apache, so i configure that path in apache.
    I have tried in Ubuntu, and edit the below two lines in the *
    /etc/apache2/sites-enabled/**000-default* file.

    *DocumentRoot /user/hadoop/input
    <Directory /user/hadoop/input>*

    But my "index.php" not viewed, Just throw an following *error*.

    *The requested URL /input/index.php was not found on this server.*

    *Kindly* check and *advise* me is there any way to configure that "php"
    path..


    Thanks for looking into this,
    Mariaprabudass

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcommon-dev @
categorieshadoop
postedSep 21, '11 at 11:30a
activeSep 26, '11 at 4:59p
posts3
users2
websitehadoop.apache.org...
irc#hadoop

2 users in discussion

Maria Prabudass: 2 posts Kihwal Lee: 1 post

People

Translate

site design / logo © 2022 Grokbase