FAQ
smart-apply-patch.sh does not work on some older versions of BASH
-----------------------------------------------------------------

Key: HADOOP-7598
URL: https://issues.apache.org/jira/browse/HADOOP-7598
Project: Hadoop Common
Issue Type: Bug
Components: build
Affects Versions: 0.23.0, 0.24.0
Reporter: Robert Joseph Evans
Assignee: Robert Joseph Evans
Fix For: 0.23.0, 0.24.0


I don't really know why, but on some versions of bash (including the one I use, and is on the build servers)
bash --version
GNU bash, version 3.2.25(1)-release (x86_64-redhat-linux-gnu)
Copyright (C) 2005 Free Software Foundation, Inc.

The line
{code}
elif [[ "$PREFIX_DIRS" =~ ^(hadoop-common-project|hadoop-hdfs-project|hadoop-mapreduce-project)$ ]]; then
{code}

evaluates to false but if the test is moved out of the elif statement then it works correctly.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcommon-dev @
categorieshadoop
postedAug 31, '11 at 9:54p
activeAug 31, '11 at 9:54p
posts1
users1
websitehadoop.apache.org...
irc#hadoop

1 user in discussion

Robert Joseph Evans (JIRA): 1 post

People

Translate

site design / logo © 2022 Grokbase