FAQ
Hi All,
I have been trying to setup eclipse project with trunk code, but I have
been getting following error.

[ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] :: UNRESOLVED DEPENDENCIES ::
[ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] :: commons-logging#commons-logging;1.1.1: not found
[ivy:resolve] :: log4j#log4j;1.2.15: not found
[ivy:resolve] :: commons-codec#commons-codec;1.4: not found
[ivy:resolve] :: commons-cli#commons-cli;1.2: not found
[ivy:resolve] :: org.mortbay.jetty#servlet-api-2.5;6.1.14: not found
[ivy:resolve] :: org.mortbay.jetty#jetty;6.1.14: not found
[ivy:resolve] :: org.mortbay.jetty#jetty-util;6.1.14: not found
[ivy:resolve] :: org.mortbay.jetty#jsp-api-2.1;6.1.14: not found
[ivy:resolve] :: org.mortbay.jetty#jsp-2.1;6.1.14: not found
[ivy:resolve] :: oro#oro;2.0.8: not found
[ivy:resolve] :: commons-lang#commons-lang;2.5: not found
[ivy:resolve] :: commons-collections#commons-collections;3.2.1: not
found
[ivy:resolve] :: commons-beanutils#commons-beanutils-core;1.8.0: not
found
[ivy:resolve] :: org.apache.commons#commons-math;2.1: not found
[ivy:resolve] :: com.google.guava#guava;r09: not found
[ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::

Please help me out in setting up eclipse project.

Thanks in advance

--
Thanks & Regards
Bh.V.S.Kamesh

Search Discussions

  • Prashant at Jul 6, 2011 at 9:22 am
    Hi all,
    Even I am getting similar problem with ant building hadoop trunk code.
    invalid sha1 for a few dependencies.

    Please see the dump : http://pastebin.com/HXsnkaW6

    Thanks,
    prashant
    On 07/06/2011 11:08 AM, Venkata siva kamesh Bhallamudi wrote:
    Hi All,
    I have been trying to setup eclipse project with trunk code, but I have
    been getting following error.

    [ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:resolve] :: UNRESOLVED DEPENDENCIES ::
    [ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
    [ivy:resolve] :: commons-logging#commons-logging;1.1.1: not found
    [ivy:resolve] :: log4j#log4j;1.2.15: not found
    [ivy:resolve] :: commons-codec#commons-codec;1.4: not found
    [ivy:resolve] :: commons-cli#commons-cli;1.2: not found
    [ivy:resolve] :: org.mortbay.jetty#servlet-api-2.5;6.1.14: not found
    [ivy:resolve] :: org.mortbay.jetty#jetty;6.1.14: not found
    [ivy:resolve] :: org.mortbay.jetty#jetty-util;6.1.14: not found
    [ivy:resolve] :: org.mortbay.jetty#jsp-api-2.1;6.1.14: not found
    [ivy:resolve] :: org.mortbay.jetty#jsp-2.1;6.1.14: not found
    [ivy:resolve] :: oro#oro;2.0.8: not found
    [ivy:resolve] :: commons-lang#commons-lang;2.5: not found
    [ivy:resolve] :: commons-collections#commons-collections;3.2.1: not
    found
    [ivy:resolve] :: commons-beanutils#commons-beanutils-core;1.8.0: not
    found
    [ivy:resolve] :: org.apache.commons#commons-math;2.1: not found
    [ivy:resolve] :: com.google.guava#guava;r09: not found
    [ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::

    Please help me out in setting up eclipse project.

    Thanks in advance
  • Steve Loughran at Jul 6, 2011 at 11:11 am

    On 06/07/11 10:20, Prashant wrote:
    Hi all,
    Even I am getting similar problem with ant building hadoop trunk code.
    invalid sha1 for a few dependencies.

    Please see the dump : http://pastebin.com/HXsnkaW6
    I have downloaded a lot of these files on my own machine and don't get
    the invalid SHA1s, which implies that there is a problem with the files
    downloaded onto your system. The the wierdness of the "expected" strings
    looks like either some encoding problem, a proxy getting in the way, or
    something else. Whatever it is, nobody else has it, so you are going to
    have to diagnose and fix it yourself, or at least identify which tool is
    playing up and try to get the latest version/a fix in there.

    Fetch one of the files (e.g. with the GET command on linux, or in ant
    with <get> -not the browser, it may do something- then sha1sum it to see
    what you have.

    What may be the cause is
    https://issues.apache.org/jira/browse/IVY-1061

    -this stops ivy working properly on z/OS. Is this your environment?

    if so, try switching to the latest release of Ivy, which may have fixed it.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcommon-dev @
categorieshadoop
postedJul 6, '11 at 6:13a
activeJul 6, '11 at 11:11a
posts3
users3
websitehadoop.apache.org...
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase