[
https://issues.apache.org/jira/browse/HADOOP-4885?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12669836#action_12669836 ]
Konstantin Shvachko commented on HADOOP-4885:
---------------------------------------------
# {{storageList()}} should be called {{listStorageDirectories()}}, it should be a member of the {{Storage}} class, and then you can use simple loop like
{code}
for (StorageDirectory sd : storageDirs) {
{code}
Also it would be better to use {{sd}} instead of {{st}}.
# There are some trivial changes like empty line and adding { } in a one line if statement. It would be better to remove those.
# Long lines in {{tryToRestoreRemovedStorage()}} should be split.
# In line
{code}
if(root.exists() && root.canWrite() && FileUtil.fullyDelete(root) && root.mkdir()) {
format(sd);
{code}
You do all operations twice because {{format()}} does {{fullyDelete}} and {{mkDirs}} inside.
# In {{FSEditLog.logEdit()}} you should use {{warn(Object arg, Throwable arg);}} rather than printing {{ie.getLocalizedMessage()}}
# If possible please keep line length within the 80 margin acording to hadoop coding style.
# "failed" vs "faild" in {{getEditLogSize()}}
# In {{rollEditLog()}}
## {{// check if any of failed storage is now *available*}} and put it back
## You replaced {{processIOError(sd);}} by simply removing edit streams from the list of streams. That does not seem to be right. The name-node should fail if the last stream is being removed.
Try to restore failed replicas of Name Node storage (at checkpoint time)
------------------------------------------------------------------------
Key: HADOOP-4885
URL:
https://issues.apache.org/jira/browse/HADOOP-4885Project: Hadoop Core
Issue Type: Improvement
Components: dfs
Reporter: Boris Shkolnik
Assignee: Boris Shkolnik
Attachments: HADOOP-4885.patch, HADOOP-4885.patch
--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.