FAQ
I have the latest Cygwin on Windows. I updated my hadoop/conf folder so that
hadoop-default.xml, hadoop-env.sh, and hadoop-site.xml were modified. Then
I tried to do an ant build but it says

Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/tools/ant/launch/Launcher

What is wrong? ANT_HOME is set and I use ant on the same machine for
building my other Java programs using the command-line, but haven't used
Cygwin to ant build. Any ideas?
--
View this message in context: http://www.nabble.com/Cygwin-problems-tf3146550.html#a8722852
Sent from the Hadoop Dev mailing list archive at Nabble.com.

Search Discussions

  • Nigel Daley at Jan 31, 2007 at 4:06 am
    What version of Ant are you using? I think you need 1.6.5.

    Cheers,
    Nige
    On Jan 30, 2007, at 7:50 PM, rainsill wrote:


    I have the latest Cygwin on Windows. I updated my hadoop/conf
    folder so that
    hadoop-default.xml, hadoop-env.sh, and hadoop-site.xml were
    modified. Then
    I tried to do an ant build but it says

    Exception in thread "main" java.lang.NoClassDefFoundError:
    org/apache/tools/ant/launch/Launcher

    What is wrong? ANT_HOME is set and I use ant on the same machine for
    building my other Java programs using the command-line, but haven't
    used
    Cygwin to ant build. Any ideas?
    --
    View this message in context: http://www.nabble.com/Cygwin-problems-
    tf3146550.html#a8722852
    Sent from the Hadoop Dev mailing list archive at Nabble.com.
  • Rainsill at Jan 31, 2007 at 4:14 am
    I am using the following versions:
    Hadoop 0.10.1
    Ant 1.6.5
    Cygwin 1.5.23-2
    Windows XP Professional (with service packs installed)


    Nigel Daley-2 wrote:
    What version of Ant are you using? I think you need 1.6.5.

    Cheers,
    Nige
    On Jan 30, 2007, at 7:50 PM, rainsill wrote:


    I have the latest Cygwin on Windows. I updated my hadoop/conf
    folder so that
    hadoop-default.xml, hadoop-env.sh, and hadoop-site.xml were
    modified. Then
    I tried to do an ant build but it says

    Exception in thread "main" java.lang.NoClassDefFoundError:
    org/apache/tools/ant/launch/Launcher

    What is wrong? ANT_HOME is set and I use ant on the same machine for
    building my other Java programs using the command-line, but haven't
    used
    Cygwin to ant build. Any ideas?
    --
    View this message in context: http://www.nabble.com/Cygwin-problems-
    tf3146550.html#a8722852
    Sent from the Hadoop Dev mailing list archive at Nabble.com.
    --
    View this message in context: http://www.nabble.com/Cygwin-problems-tf3146550.html#a8723010
    Sent from the Hadoop Dev mailing list archive at Nabble.com.
  • Youlq at Jan 31, 2007 at 5:27 am
    hello rainsill,

    I think you could try this:

    assume cygwin was installed in : E:\cygwin
    JAVA_HOME is C:\Program Files\Java\jdk1.5.0_04
    ANT_HOME is E:\_java_frameworks\Ant\apache-ant-1.6.5

    then,go E:\cygwin , edit cygwin.bat, add below after first line "@echo off" , It works in my winXP Pro .
    ----------------------
    SET JAVA_HOME=C:\Program Files\Java\jdk1.5.0_04
    SET ANT_HOME=E:\_java_frameworks\Ant\apache-ant-1.6.5

    SET path="%JAVA_HOME%\bin";%ANT_HOME%\bin;%path%
    SET CLASSPATH=.;%JAVA_HOME%\jre\lib\rt.jar;%CLASSPATH%
    ---------------------------

    -----Original Message Begin-----

    I have the latest Cygwin on Windows. I updated my hadoop/conf folder so that
    hadoop-default.xml, hadoop-env.sh, and hadoop-site.xml were modified. Then
    I tried to do an ant build but it says

    Exception in thread "main" java.lang.NoClassDefFoundError:
    org/apache/tools/ant/launch/Launcher

    What is wrong? ANT_HOME is set and I use ant on the same machine for
    building my other Java programs using the command-line, but haven't used
    Cygwin to ant build. Any ideas?
    --
    View this message in context: http://www.nabble.com/Cygwin-problems-tf3146550.html#a8722852
    Sent from the Hadoop Dev mailing list archive at Nabble.com.
    -----Original Message End-----



    youlq
    you.leiqing@gmail.com
    2007-01-31
  • Rainsill at Jan 31, 2007 at 5:44 am
    Thank-you, that solved the problem. I had ANT_HOME and JAVA_HOME set, but I
    had ANT_HOME set to e:\ant\bin instead of e:\ant, and then in the path it
    was set to ANT_HOME\bin, which made it ANT_HOME\bin\bin... Corrected now.
    Thanks again.


    youlq wrote:
    hello rainsill,

    I think you could try this:

    assume cygwin was installed in : E:\cygwin
    JAVA_HOME is C:\Program Files\Java\jdk1.5.0_04
    ANT_HOME is E:\_java_frameworks\Ant\apache-ant-1.6.5

    then,go E:\cygwin , edit cygwin.bat, add below after first line "@echo
    off" , It works in my winXP Pro .
    ----------------------
    SET JAVA_HOME=C:\Program Files\Java\jdk1.5.0_04
    SET ANT_HOME=E:\_java_frameworks\Ant\apache-ant-1.6.5

    SET path="%JAVA_HOME%\bin";%ANT_HOME%\bin;%path%
    SET CLASSPATH=.;%JAVA_HOME%\jre\lib\rt.jar;%CLASSPATH%
    ---------------------------

    -----Original Message Begin-----

    I have the latest Cygwin on Windows. I updated my hadoop/conf folder so
    that
    hadoop-default.xml, hadoop-env.sh, and hadoop-site.xml were modified.
    Then
    I tried to do an ant build but it says

    Exception in thread "main" java.lang.NoClassDefFoundError:
    org/apache/tools/ant/launch/Launcher

    What is wrong? ANT_HOME is set and I use ant on the same machine for
    building my other Java programs using the command-line, but haven't used
    Cygwin to ant build. Any ideas?
    --
    View this message in context:
    http://www.nabble.com/Cygwin-problems-tf3146550.html#a8722852
    Sent from the Hadoop Dev mailing list archive at Nabble.com.
    -----Original Message End-----



    youlq
    you.leiqing@gmail.com
    2007-01-31

    --
    View this message in context: http://www.nabble.com/Cygwin-problems-tf3146550.html#a8723637
    Sent from the Hadoop Dev mailing list archive at Nabble.com.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupcommon-dev @
categorieshadoop
postedJan 31, '07 at 3:51a
activeJan 31, '07 at 5:44a
posts5
users3
websitehadoop.apache.org...
irc#hadoop

3 users in discussion

Rainsill: 3 posts Youlq: 1 post Nigel Daley: 1 post

People

Translate

site design / logo © 2022 Grokbase