Raju,

For spree_essentials and spree_essentials_cms you could find my 2.0.X
compatible fork
https://github.com/sbounmy/spree_essentials
https://github.com/sbounmy/spree_essential_cms

I believe upgrading these extensions from 2.0.5 to 2.1 should be easy!

Stephane.
On Monday, September 30, 2013 11:18:06 AM UTC+2, Raju A wrote:


Hi All,

Can you any one tell me the best approach to upgrade the spree 1.1 to 2.1
version If any one have idea?

Actually I am looking to upgrade spree version from 1 to 2 where I am
getting the more dependency errors why because I have more extentions which
are supportable to
spree 1.1.

I don't find any below extentions compatible versions with Spree 2.1.
- spree_essentials
- spree_essentials_blog
- spree_essentials_cms
- spree_social
- spree_address_book

Please any one share me your idea If you thought/find any compatible
version of above extensions with spree 2.1.

Thanks In Advance.

Search Discussions

  • Raju A at Oct 18, 2013 at 11:25 am
    Hi All,

       I am looking for below extensions for the spree-2.0,

        spree_essentials,
        spree_essential_cms
        spree_essential_blog

        Shall expect your fork repo's - 1.2 will work with spree-2.0 ? I don't
    think those won't work with spree-2.0

        Can you suggest me, any extensions that are available and best fit
    similar to essential_blog, cms ?


         Thanks,
          Raju
  • Raju A at Oct 18, 2013 at 11:25 am
    Hi All,

       I am looking for below extensions for the spree-2.0,

        spree_essentials,
        spree_essential_cms
        spree_essential_blog

        Shall expect your fork repo's - 1.2 will work with spree-2.0 ? I don't
    think those won't work with spree-2.0

        Can you suggest me, any extensions that are available and best fit
    similar to essential_blog, cms ?


         Thanks,
          Raju
  • Nate Lowrie at Oct 18, 2013 at 12:25 pm
    See my answer in the other thread.
    On Friday, October 18, 2013 7:25:41 AM UTC-4, Raju A wrote:

    Hi All,

    I am looking for below extensions for the spree-2.0,

    spree_essentials,
    spree_essential_cms
    spree_essential_blog

    Shall expect your fork repo's - 1.2 will work with spree-2.0 ? I don't
    think those won't work with spree-2.0

    Can you suggest me, any extensions that are available and best fit
    similar to essential_blog, cms ?


    Thanks,
    Raju
  • Raju A at Nov 11, 2013 at 11:32 am
    Hi Nate and all,

        Any one have experience with upgradation from spree2.0 to spree2.1.

        I am upgrading the spree2.0 + rails 3.2.14 application to spree-2.1 +
    Rails -4 where I am getting the issues with my customization code like
    attr_acceble.

       I believed that for existed projects, we can go with protected_attributes
    gem for this old fun.

       But still I am getting issues with protected_attribute gem as in check
    out process its giving the

    *can't blank error. *I am going this upgradation as created new rails4 app
    with spree and placing my old customization code. Is this process correct?

       Please let me know your ideas on it.
  • Raju A at Nov 11, 2013 at 1:05 pm
    How to add new fields for spree::user in Spree-2.1 + Rails4 ?

       Like my old customization:

      Spree::User.class_eval do
       attr_accessible :f_name, :l_name :gender
       validates :f_name, :presence => true, :length => {:maximum => 25}
       validates :l_name, :presence => true, :length => {:maximum => 20}
      end

       please let me know your comments.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedOct 6, '13 at 7:44a
activeNov 11, '13 at 1:05p
posts6
users3
websitespreecommerce.com
irc#RubyOnRails

3 users in discussion

Raju A: 4 posts Stephane: 1 post Nate Lowrie: 1 post

People

Translate

site design / logo © 2022 Grokbase