Hi All,

I'm not sure how to configure a Versionfile for an extension, or if this is
even needed any more.

This documentation link
- http://spreecommerce.com/documentation/extensions.html#versionfile -
which is specified in a Spree message just gives me a 404.

Can someone provide some guidance here?

Thanks.

Best,

Peter

Search Discussions

  • Enrique Álvarez at Aug 23, 2013 at 12:44 pm
    Hi Peter,

    I am not quite sure if the Versionfile is still used but you can check the
    new documentation for extensions in this link:
    http://guides.spreecommerce.com/developer/extensions_tutorial.html . All
    the documentation with the last realease has been moved.

    Regards,
    Enrique

    El jueves, 22 de agosto de 2013 23:05:40 UTC+2, Peter Goldstein escribió:

    Hi All,

    I'm not sure how to configure a Versionfile for an extension, or if this
    is even needed any more.

    This documentation link -
    http://spreecommerce.com/documentation/extensions.html#versionfile -
    which is specified in a Spree message just gives me a 404.

    Can someone provide some guidance here?

    Thanks.

    Best,

    Peter
  • Washington Luiz at Aug 23, 2013 at 2:44 pm
    Yeah last time I heard Versionfile were removed in favor of branches. So if
    you're using Spree 1.3.x for example and you want to make an extension
    compatible with that release series you should create a 1-3-stable branch
    on your extension repo.

    On Fri, Aug 23, 2013 at 9:37 AM, Enrique Álvarez wrote:

    Hi Peter,

    I am not quite sure if the Versionfile is still used but you can check the
    new documentation for extensions in this link:
    http://guides.spreecommerce.com/developer/extensions_tutorial.html . All
    the documentation with the last realease has been moved.

    Regards,
    Enrique

    El jueves, 22 de agosto de 2013 23:05:40 UTC+2, Peter Goldstein escribió:
    Hi All,

    I'm not sure how to configure a Versionfile for an extension, or if this
    is even needed any more.

    This documentation link - http://spreecommerce.com/**
    documentation/extensions.html#**versionfile<http://spreecommerce.com/documentation/extensions.html#versionfile>- which is specified in a Spree message just gives me a 404.

    Can someone provide some guidance here?

    Thanks.

    Best,

    Peter

    --
    Washington L Braga Jr

    Developer
    Spree Commerce, Inc.
  • Alessandro Lepore at Aug 23, 2013 at 4:51 pm

    On Friday, 23 August 2013 16:44:48 UTC+2, Washington Luiz wrote:

    Yeah last time I heard Versionfile were removed in favor of branches. So
    if you're using Spree 1.3.x for example and you want to make an extension
    compatible with that release series you should create a 1-3-stable branch
    on your extension repo.
    Isn't Versionfile still used by http://spreecommerce.com/extensions ?
  • Ryan Bigg at Aug 25, 2013 at 11:55 pm
    Versionfiles are being fazed out in favour of branches. While they are still used by the extensions part of the spree store, their life is limited.
    On Sat, Aug 24, 2013 at 2:51 AM, Alessandro Lepore wrote:
    On Friday, 23 August 2013 16:44:48 UTC+2, Washington Luiz wrote:
    Yeah last time I heard Versionfile were removed in favor of branches. So
    if you're using Spree 1.3.x for example and you want to make an extension
    compatible with that release series you should create a 1-3-stable branch
    on your extension repo.
    Isn't Versionfile still used by http://spreecommerce.com/extensions ?

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedAug 22, '13 at 9:10p
activeAug 25, '13 at 11:55p
posts5
users5
websitespreecommerce.com
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase