FAQ
I am newbie to rails and heroku. I am following this blog<http://creatingstore.blogspot.in/2012/04/deploying-spree-11-in-heroku.html?view=classic> for
spree installation and deploying to heroku.

I saw previous question on this error but the solution they gave are not
working for me .

Like running below command

heroku run rake db:migrate

Running rake db:migrate attached to terminal... up, run.8855 DEPRECATION
WARNING: You have Rails 2.3-style plugins in vendor/plugins! Support for
these plugins will be removed in Rails 4.0. Move them out and bundle them
in your Gemfile, or fold them in to your app as lib/myplugin/* and
config/initializers/myplugin.rb. See the release notes for more on this:
http://weblog.rubyonrails.org/2012/1/4/rails-3-2-0-rc2-has-been-released.
(called from at /app/Rakefile:7) DEPRECATION WARNING: You have Rails
2.3-style plugins in vendor/plugins! Support for these plugins will be
removed in Rails 4.0. Move them out and bundle them in your Gemfile, or
fold them in to your app as lib/myplugin/* and
config/initializers/myplugin.rb. See the release notes for more on this:
weblog.rubyonrails.org/2012/1/4/rails-3-2-0-rc2-has-been-released. (called
from at /app/Rakefile:7) DEPRECATION WARNING: You have Rails 2.3-style
plugins in vendor/plugins! Support for these plugins will be removed in
Rails 4.0. Move them out and bundle them in your Gemfile, or fold them in
to your app as lib/myplugin/* and config/initializers/myplugin.rb. See the
release notes for more on this:
weblog.rubyonrails.org/2012/1/4/rails-3-2-0-rc2-has-been-released. (called
from at /app/Rakefile:7)

*my Gem file *
source 'https//rubygems.org'

gem 'rails', '3.2.13'

gem 'pg'

group :assets do gem 'sass-rails', '~> 3.2.3' gem 'coffee-rails', '~> 3.2.1'

gem 'uglifier', '>= 1.0.3' end

gem 'jquery-rails', '=2.2.1'

gem 'spree', '2.0.3' gem 'spree_gateway', :git =>
'github.com/spree/spree_gateway.git', :branch => '2-0-stable' gem
'spree_auth_devise', :git => 'github.com/spree/spree_auth_devise.git',
:branch => '2-0-stable'

gem 'spree_fancy', :github => 'spree/spree_fancy', :branch => '2-0-stable'

gem 'spree_heroku', :git => 'git://github.com/joneslee85/spree-heroku.git'

ruby '1.9.3'


I am unable to run migrations on heroku ...
How to fix this problem manually

Search Discussions

  • Steve Root at Jun 30, 2013 at 8:08 am
    The error may not be related to the migrations. Try typing
    Heroku log
    which if I remember correctly will show you the last lines of the
    production log, which will hopefully start you in the right direction to
    finding the cause.


    On Sunday, 30 June 2013 01:37:23 UTC+1, Saurabh Saxena wrote:


    I am newbie to rails and heroku. I am following this blog<http://creatingstore.blogspot.in/2012/04/deploying-spree-11-in-heroku.html?view=classic>for spree installation and deploying to
    heroku.

    I saw previous question on this error but the solution they gave are not
    working for me .

    Like running below command

    heroku run rake db:migrate

    Running rake db:migrate attached to terminal... up, run.8855 DEPRECATION
    WARNING: You have Rails 2.3-style plugins in vendor/plugins! Support for
    these plugins will be removed in Rails 4.0. Move them out and bundle them
    in your Gemfile, or fold them in to your app as lib/myplugin/* and
    config/initializers/myplugin.rb. See the release notes for more on this:
    http://weblog.rubyonrails.org/2012/1/4/rails-3-2-0-rc2-has-been-released.
    (called from at /app/Rakefile:7) DEPRECATION WARNING: You have Rails
    2.3-style plugins in vendor/plugins! Support for these plugins will be
    removed in Rails 4.0. Move them out and bundle them in your Gemfile, or
    fold them in to your app as lib/myplugin/* and
    config/initializers/myplugin.rb. See the release notes for more on this:
    weblog.rubyonrails.org/2012/1/4/rails-3-2-0-rc2-has-been-released.
    (called from at /app/Rakefile:7) DEPRECATION WARNING: You have Rails
    2.3-style plugins in vendor/plugins! Support for these plugins will be
    removed in Rails 4.0. Move them out and bundle them in your Gemfile, or
    fold them in to your app as lib/myplugin/* and
    config/initializers/myplugin.rb. See the release notes for more on this:
    weblog.rubyonrails.org/2012/1/4/rails-3-2-0-rc2-has-been-released.
    (called from at /app/Rakefile:7)

    *my Gem file *
    source 'https//rubygems.org'

    gem 'rails', '3.2.13'

    gem 'pg'

    group :assets do gem 'sass-rails', '~> 3.2.3' gem 'coffee-rails', '~>
    3.2.1'

    gem 'uglifier', '>= 1.0.3' end

    gem 'jquery-rails', '=2.2.1'

    gem 'spree', '2.0.3' gem 'spree_gateway', :git => '
    github.com/spree/spree_gateway.git', :branch => '2-0-stable' gem
    'spree_auth_devise', :git => 'github.com/spree/spree_auth_devise.git',
    :branch => '2-0-stable'

    gem 'spree_fancy', :github => 'spree/spree_fancy', :branch => '2-0-stable'

    gem 'spree_heroku', :git => 'git://github.com/joneslee85/spree-heroku.git'

    ruby '1.9.3'


    I am unable to run migrations on heroku ...
    How to fix this problem manually

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedJun 30, '13 at 8:04a
activeJun 30, '13 at 8:08a
posts2
users2
websitespreecommerce.com
irc#RubyOnRails

2 users in discussion

Saurabh Saxena: 1 post Steve Root: 1 post

People

Translate

site design / logo © 2022 Grokbase