FAQ
Mark,

I know I'm close to a year late on this post but I was wondering if you
could post your spree installation steps or point me to a blog post if you
ever got around to writing it.
I'm also curious if unicorn is absolutely necessary as I am using passenger
on a linode server with nginx.

Any help would be greatly appreciated.
Thanks.

On Friday, September 28, 2012 9:44:32 PM UTC-4, Mark Lybrand wrote:

apt-get install those two packages did the trick. I tried to do
bundle and ruby but for some reason my server wasn't understanding me
(maybe I have to rbenv something back in). I will blow the whole
thing out and do it again just to make sure I have this cold. Then I
will try with the deployment services.

Thanks for all your help.

Let me know if anyone wants me to repost all my steps (with
corrections). Could be useful for other little lost lambs... Maybe I
should make it a blog post and get a little lovin' for myself :)

Mark

On Fri, Sep 28, 2012 at 2:54 PM, technorcal <weme...@mcn.org <javascript:>>
wrote:
Hi Mark,
It looks like libxml2 is missing. From the link in the output,
http://nokogiri.org/tutorials/installing_nokogiri.html

I would ssh into server and try this:

sudo apt-get install libxslt-dev libxml2-dev

and then from
/home/deployer/apps/mayorio/shared


bundle exec gem install nokogiri

You should see any errors there. The gem should get installed into the
bundle. Then go back to your dev machine and run cap deploy:cold again. It
should show nokogiri as installed and keep going.

Good luck and report back on any errors.


--
You received this message because you are subscribed to the Google Groups
"Spree" group.
To view this discussion on the web visit
https://groups.google.com/d/msg/spree-user/-/MNXIFJpm0rgJ.
To post to this group, send email to spree...@googlegroups.com<javascript:>.
To unsubscribe from this group, send email to
spree-user+...@googlegroups.com <javascript:>.

For more options, visit this group at
http://groups.google.com/group/spree-user?hl=en.


--
Mark :)

Search Discussions

  • Ryan Bigg at May 31, 2013 at 4:21 pm
    Hey Joe,

    Unicorn is not mandatory, but it is recommended. We do recommend using it
    in our new Ubuntu deployment guide on our guides site:
    http://guides.spreecommerce.com/developer/ubuntu.html. I think that guide
    would help you.

    On Tue, May 28, 2013 at 5:14 PM, Joe Crocetta wrote:

    Mark,

    I know I'm close to a year late on this post but I was wondering if you
    could post your spree installation steps or point me to a blog post if you
    ever got around to writing it.
    I'm also curious if unicorn is absolutely necessary as I am using
    passenger on a linode server with nginx.

    Any help would be greatly appreciated.
    Thanks.

    On Friday, September 28, 2012 9:44:32 PM UTC-4, Mark Lybrand wrote:

    apt-get install those two packages did the trick. I tried to do
    bundle and ruby but for some reason my server wasn't understanding me
    (maybe I have to rbenv something back in). I will blow the whole
    thing out and do it again just to make sure I have this cold. Then I
    will try with the deployment services.

    Thanks for all your help.

    Let me know if anyone wants me to repost all my steps (with
    corrections). Could be useful for other little lost lambs... Maybe I
    should make it a blog post and get a little lovin' for myself :)

    Mark
    On Fri, Sep 28, 2012 at 2:54 PM, technorcal wrote:
    Hi Mark,
    It looks like libxml2 is missing. From the link in the output,
    http://nokogiri.org/tutorials/**installing_nokogiri.html<http://nokogiri.org/tutorials/installing_nokogiri.html>

    I would ssh into server and try this:

    sudo apt-get install libxslt-dev libxml2-dev

    and then from
    /home/deployer/apps/mayorio/**shared


    bundle exec gem install nokogiri

    You should see any errors there. The gem should get installed into the
    bundle. Then go back to your dev machine and run cap deploy:cold again. It
    should show nokogiri as installed and keep going.

    Good luck and report back on any errors.


    --
    You received this message because you are subscribed to the Google Groups
    "Spree" group.
    To view this discussion on the web visit
    https://groups.google.com/d/**msg/spree-user/-/MNXIFJpm0rgJ<https://groups.google.com/d/msg/spree-user/-/MNXIFJpm0rgJ>.
    To post to this group, send email to spree...@googlegroups.com.
    To unsubscribe from this group, send email to
    spree-user+...@**googlegroups.com.

    For more options, visit this group at
    http://groups.google.com/**group/spree-user?hl=en<http://groups.google.com/group/spree-user?hl=en>.



    --
    Mark :)

    --

    Ryan Bigg
    Community Manager
    Spree Commerce, Inc.
  • Ryan Bigg at Apr 16, 2014 at 4:56 am
    Thank you Ashley!

    On Sat, Apr 12, 2014 at 7:09 AM, ashley e wrote:

    Just in case someone comes late to this thread as they're learning about
    installing Spree on Ubuntu (as I did), the link that Ryan posted should be
    updated to: http://guides.spreecommerce.com/developer/manual-ubuntu.html

    Or to get to the page via the page content (in case the link changes again
    in the future):
    Go to the Spree Developer Guide<http://guides.spreecommerce.com/developer/>,
    then under the Deployment section, choose the Manual Ubuntu Deployment<http://guides.spreecommerce.com/developer/manual-ubuntu.html>link.


    On Friday, May 31, 2013 9:21:41 AM UTC-7, Ryan Bigg wrote:

    Hey Joe,

    Unicorn is not mandatory, but it is recommended. We do recommend using it
    in our new Ubuntu deployment guide on our guides site: http://guides.
    spreecommerce.com/developer/ubuntu.html. I think that guide would help
    you.

    On Tue, May 28, 2013 at 5:14 PM, Joe Crocetta wrote:

    *[snip]*

    --

    Ryan Bigg
    Community Manager
    Spree Commerce, Inc.

    --
    Ryan Bigg
    Community Manager
    Spree Commerce, Inc.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedMay 29, '13 at 10:01a
activeApr 16, '14 at 4:56a
posts3
users2
websitespreecommerce.com
irc#RubyOnRails

2 users in discussion

Ryan Bigg: 2 posts Joe Crocetta: 1 post

People

Translate

site design / logo © 2022 Grokbase