FAQ
Hi,

Newbie to Spree, When trying to install this error is given back:

Could not find gem 'spree_frontend (~> 2.1.0.beta) ruby' in the gems
available on this machine.
git://github.com/spree/spree_gateway.git (at 2-0-stable) is not checked
out. Please run `bundle install`


  Rails 3.2.13
ruby 1.9.3p125

Any problems with the new version?

Cheers,

Ron

Search Discussions

  • Arvore at May 28, 2013 at 7:53 am
    Ron,

    I was also facing the same issue. Your gemfile related to spree should be
    like this.

    gem 'spree', '2.0.0'
    gem 'spree_gateway', :git =>
    'https://github.com/spree/spree_gateway.git',:branch => "2-0-stable"
    gem 'spree_auth_devise', :git =>
    'https://github.com/spree/spree_auth_devise.git',:branch => "2-0-stable"

    If you not pointing to stable branch, it's not gonna work.

    Cheers,
    Arv
    On Monday, May 27, 2013 9:01:19 PM UTC+5:30, Washington Luiz wrote:

    Hi Ron, could you please try that again? I've update spree_gateway to use
    spree 2.0.0. You should be able to bundle just fine now.
    On Monday, May 27, 2013 7:37:52 AM UTC-3, Ron Belson wrote:

    Hi,

    Newbie to Spree, When trying to install this error is given back:

    Could not find gem 'spree_frontend (~> 2.1.0.beta) ruby' in the gems
    available on this machine.
    git://github.com/spree/spree_gateway.git (at 2-0-stable) is not checked
    out. Please run `bundle install`


    Rails 3.2.13
    ruby 1.9.3p125

    Any problems with the new version?

    Cheers,

    Ron
  • Bruce Bicknell at May 28, 2013 at 3:07 pm
    On running through the tutorial, I got a similar errors.

    First

    $ spree install --autoaccept

    Ran through some things and halted with:

    https://github.com/spree/spree_gateway.git (at master) is not checked out.
    Please run `bundle install`

    Then

    $ bundle install


    ended with

    Bundler could not find compatible versions for gem "spree_backend":
       In Gemfile:
         spree_auth_devise (>= 0) ruby depends on
           spree_backend (~> 2.1.0.beta) ruby

         spree (= 2.0.0) ruby depends on
           spree_backend (2.0.0)


    Updating the gemfile :branch => '2-0-stable' as Arvore suggests allowed the
    installation to complete
  • Ryan Bigg at May 30, 2013 at 3:06 pm
    Sorry about this, Bruce. We'll get a fix out in 2.0.1 soonish that'll solve
    this and other little bugs with Spree 2.0.
  • Jörg at May 30, 2013 at 10:25 pm
    Nice, I would love to test 2-0-stable!
  • Jordi figs at May 31, 2013 at 7:16 am
    it is there any way to solve it writting the brunch in the gemfile?

    On Thursday, May 30, 2013 10:06:47 AM UTC-5, Ryan Bigg wrote:

    Sorry about this, Bruce. We'll get a fix out in 2.0.1 soonish that'll
    solve this and other little bugs with Spree 2.0.
  • Ryan Bigg at May 31, 2013 at 5:08 pm
    jordi, what do you mean? Please elaborate.

    On Thu, May 30, 2013 at 10:27 PM, jordi figs wrote:

    it is there any way to solve it writting the brunch in the gemfile?


    On Thursday, May 30, 2013 10:06:47 AM UTC-5, Ryan Bigg wrote:

    Sorry about this, Bruce. We'll get a fix out in 2.0.1 soonish that'll
    solve this and other little bugs with Spree 2.0.

    --

    Ryan Bigg
    Community Manager
    Spree Commerce, Inc.
  • Washington Luiz at May 31, 2013 at 9:23 pm
    I don't undestand the issue here either. Are you guys saying you're not
    able to bundle spree_gateway?

    On Fri, May 31, 2013 at 2:08 PM, Ryan Bigg wrote:

    jordi, what do you mean? Please elaborate.

    On Thu, May 30, 2013 at 10:27 PM, jordi figs wrote:

    it is there any way to solve it writting the brunch in the gemfile?


    On Thursday, May 30, 2013 10:06:47 AM UTC-5, Ryan Bigg wrote:

    Sorry about this, Bruce. We'll get a fix out in 2.0.1 soonish that'll
    solve this and other little bugs with Spree 2.0.

    --

    Ryan Bigg
    Community Manager
    Spree Commerce, Inc.


    --
    Washington L Braga Jr
    web developer
  • Abhishek srivastava at Sep 22, 2013 at 1:38 pm
    Hi guys,

    I am trying to do a fresh install of Spree as per github readme. I am
    getting this error even after pointing gems to stable branches.

    gem 'spree_gateway', :git => 'https://github.com/spree/spree_gateway.git',:branch
    => "2-0-stable"
    gem 'spree_auth_devise', :git => '
    https://github.com/spree/spree_auth_devise.git',:branch => "2-0-stable"


    Bundler could not find compatible versions for gem "spree_frontend":
       In Gemfile:
         spree_auth_devise (>= 0) ruby depends on
           spree_frontend (~> 2.0.0) ruby

         spree (= 2.1.0) ruby depends on
           spree_frontend (2.1.0)
    On Saturday, 1 June 2013 02:53:40 UTC+5:30, Washington Luiz wrote:

    I don't undestand the issue here either. Are you guys saying you're not
    able to bundle spree_gateway?


    On Fri, May 31, 2013 at 2:08 PM, Ryan Bigg <ry...@spreecommerce.com<javascript:>
    wrote:
    jordi, what do you mean? Please elaborate.


    On Thu, May 30, 2013 at 10:27 PM, jordi figs <figs....@gmail.com<javascript:>
    wrote:
    it is there any way to solve it writting the brunch in the gemfile?


    On Thursday, May 30, 2013 10:06:47 AM UTC-5, Ryan Bigg wrote:

    Sorry about this, Bruce. We'll get a fix out in 2.0.1 soonish that'll
    solve this and other little bugs with Spree 2.0.

    --

    Ryan Bigg
    Community Manager
    Spree Commerce, Inc.


    --
    Washington L Braga Jr
    web developer
  • Abhishek srivastava at Sep 22, 2013 at 1:45 pm
    I was able to resolve the problem by pointing out branches to current Spree
    version, like so -

    gem 'spree', '2.1.0'
    gem 'spree_gateway', :git => 'https://github.com/spree/spree_gateway.git',
    :branch => "2-1-stable"
    gem 'spree_auth_devise', :git => '
    https://github.com/spree/spree_auth_devise.git', :branch => "2-1-stable"

    I think its generators leaving this on me to resolve it.
    On Sun, Sep 22, 2013 at 5:44 PM, abhishek srivastava wrote:

    Hi guys,

    I am trying to do a fresh install of Spree as per github readme. I am
    getting this error even after pointing gems to stable branches.

    gem 'spree_gateway', :git => 'https://github.com/spree/**spree_gateway.git<https://github.com/spree/spree_gateway.git>',:branch
    => "2-0-stable"
    gem 'spree_auth_devise', :git => 'https://github.com/spree/**
    spree_auth_devise.git <https://github.com/spree/spree_auth_devise.git>',:branch
    => "2-0-stable"


    Bundler could not find compatible versions for gem "spree_frontend":
    In Gemfile:
    spree_auth_devise (>= 0) ruby depends on
    spree_frontend (~> 2.0.0) ruby

    spree (= 2.1.0) ruby depends on
    spree_frontend (2.1.0)
    On Saturday, 1 June 2013 02:53:40 UTC+5:30, Washington Luiz wrote:

    I don't undestand the issue here either. Are you guys saying you're not
    able to bundle spree_gateway?

    On Fri, May 31, 2013 at 2:08 PM, Ryan Bigg wrote:

    jordi, what do you mean? Please elaborate.

    On Thu, May 30, 2013 at 10:27 PM, jordi figs wrote:

    it is there any way to solve it writting the brunch in the gemfile?


    On Thursday, May 30, 2013 10:06:47 AM UTC-5, Ryan Bigg wrote:

    Sorry about this, Bruce. We'll get a fix out in 2.0.1 soonish that'll
    solve this and other little bugs with Spree 2.0.

    --

    Ryan Bigg
    Community Manager
    Spree Commerce, Inc.


    --
    Washington L Braga Jr
    web developer

    --
    regards,
    Abhishek Srivastava
  • Ryan Bigg at Sep 22, 2013 at 9:43 pm
    Abhishek: Rather than ressurrecting old threads, please post a new thread
    for your issues, as they may be unrelated to the original threads. In this
    case, that is true.

    If you're using a 2.0.x version of Spree, then use 2-0-stable branches. If
    you're using a 2.1.x version, then use 2-1-stable.

    On Sun, Sep 22, 2013 at 11:45 PM, abhishek srivastava wrote:

    I was able to resolve the problem by pointing out branches to current
    Spree version, like so -

    gem 'spree', '2.1.0'
    gem 'spree_gateway', :git => 'https://github.com/spree/spree_gateway.git',
    :branch => "2-1-stable"
    gem 'spree_auth_devise', :git => '
    https://github.com/spree/spree_auth_devise.git', :branch => "2-1-stable"

    I think its generators leaving this on me to resolve it.


    On Sun, Sep 22, 2013 at 5:44 PM, abhishek srivastava <
    abhishek77in@gmail.com> wrote:
    Hi guys,

    I am trying to do a fresh install of Spree as per github readme. I am
    getting this error even after pointing gems to stable branches.

    gem 'spree_gateway', :git => 'https://github.com/spree/**
    spree_gateway.git <https://github.com/spree/spree_gateway.git>',:branch
    => "2-0-stable"
    gem 'spree_auth_devise', :git => 'https://github.com/spree/**
    spree_auth_devise.git <https://github.com/spree/spree_auth_devise.git>',:branch
    => "2-0-stable"


    Bundler could not find compatible versions for gem "spree_frontend":
    In Gemfile:
    spree_auth_devise (>= 0) ruby depends on
    spree_frontend (~> 2.0.0) ruby

    spree (= 2.1.0) ruby depends on
    spree_frontend (2.1.0)
    On Saturday, 1 June 2013 02:53:40 UTC+5:30, Washington Luiz wrote:

    I don't undestand the issue here either. Are you guys saying you're not
    able to bundle spree_gateway?

    On Fri, May 31, 2013 at 2:08 PM, Ryan Bigg wrote:

    jordi, what do you mean? Please elaborate.

    On Thu, May 30, 2013 at 10:27 PM, jordi figs wrote:

    it is there any way to solve it writting the brunch in the gemfile?


    On Thursday, May 30, 2013 10:06:47 AM UTC-5, Ryan Bigg wrote:

    Sorry about this, Bruce. We'll get a fix out in 2.0.1 soonish that'll
    solve this and other little bugs with Spree 2.0.

    --

    Ryan Bigg
    Community Manager
    Spree Commerce, Inc.


    --
    Washington L Braga Jr
    web developer

    --
    regards,
    Abhishek Srivastava


    --

    Ryan Bigg
    Community Manager
    Spree Commerce, Inc.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedMay 27, '13 at 2:44p
activeSep 22, '13 at 9:43p
posts11
users8
websitespreecommerce.com
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase