FAQ
Hi Guys,

i'm trying to upgrade t0 spree2.0.0 along with extension that i used in my
spree app that all depends upon spree_core1.3.x .

I have following in my Gemfile

Gemfile:
-----------

gem 'spree', '2.0.0'
gem 'spree_auth_devise', github: 'spree/spree_auth_devise', *branch:
'2-0-stable'*
gem 'spree_gateway', :github => 'spree/spree_gateway'
gem "spree_social", :git => "git://github.com/spree/spree_social.git",*branch: '1-3-stable'
*
gem 'spree_active_sale' , :git =>
'git://github.com/suryart/spree_active_sale.git', :branch => '1-3-stable'
------------

When i do "gem install spree" it successfully install spree 2.0.0(Core).
But the extension which depends upon spree1.3.X and have their
stable releases for(spree_core 1.3.x) conflicts with the newer version of
Spree_core(2.0.0).

*Sample Error look like:*
Bundler could not find compatible versions for gem "spree_core":
    In Gemfile:
     spree_social (>= 0) ruby depends on
       spree_core (~> 1.3.0) ruby

     spree_auth_devise (>= 0) ruby depends on
       spree_core (2.0.0)

----------------------------------------------------------------------

Further more, please tell me should i wait for the newer versions of these
extensions(spree-social etc.. mentioned above) to pull them from git hub
that will depend upon "spree_core 2.0.0" ? or Alternatively should i make
my on custom extension to achieve the functionalists provided by above
spree extensions? Help me?

Search Discussions

  • Alexey Topolyanskiy at May 23, 2013 at 12:36 pm
    I saw same problem when generating sandbox from 2-0-stable branch

    23 мая 2013, в 15:29, "Ryan Bigg" <ryan@spreecommerce.com> написал(а):
    You should be using the master or 2-0-stable branch from spree_social if it is available. Attempting to use the 1-3-stable branch will not work.


    On Thu, May 23, 2013 at 6:20 AM, Ateq Ejaz wrote:

    Hi Guys,


    i'm trying to upgrade t0 spree2.0.0 along with extension that i used in my spree app that all depends upon spree_core1.3.x .

    I have following in my Gemfile

    Gemfile:
    -----------

    gem 'spree', '2.0.0'
    gem 'spree_auth_devise', github: 'spree/spree_auth_devise', branch: '2-0-stable'
    gem 'spree_gateway', :github => 'spree/spree_gateway'
    gem "spree_social", :git => "git://github.com/spree/spree_social.git", branch: '1-3-stable'
    gem 'spree_active_sale' , :git => 'git://github.com/suryart/spree_active_sale.git', :branch => '1-3-stable'
    ------------

    When i do "gem install spree" it successfully install spree 2.0.0(Core). But the extension which depends upon spree1.3.X and have their stable releases for(spree_core 1.3.x) conflicts with the newer version of Spree_core(2.0.0).

    Sample Error look like:
    Bundler could not find compatible versions for gem "spree_core":
    In Gemfile:
    spree_social (>= 0) ruby depends on
    spree_core (~> 1.3.0) ruby

    spree_auth_devise (>= 0) ruby depends on
    spree_core (2.0.0)

    ----------------------------------------------------------------------

    Further more, please tell me should i wait for the newer versions of these extensions(spree-social etc.. mentioned above) to pull them from git hub that will depend upon "spree_core 2.0.0" ? or Alternatively should i make my on custom extension to achieve the functionalists provided by above spree extensions? Help me?
  • Ateq Ejaz at May 23, 2013 at 1:10 pm
    Hi Ryan,

    Thanks but what about the gems that are in master and don't have any stable
    release for spree 2.0.0 like
    *spree-multi-currency <https://github.com/pronix/spree-multi-currency>*
    Can i clone its repo. and may use it as a standalone extension?
    Thanks,


    On Thu, May 23, 2013 at 9:30 AM, Alexey Topolyanskiy
    wrote:
    I saw same problem when generating sandbox from 2-0-stable branch

    23 мая 2013, в 15:29, "Ryan Bigg" <ryan@spreecommerce.com> написал(а):

    You should be using the master or 2-0-stable branch from spree_social if
    it is available. Attempting to use the 1-3-stable branch will not work.

    On Thu, May 23, 2013 at 6:20 AM, Ateq Ejaz wrote:

    Hi Guys,

    i'm trying to upgrade t0 spree2.0.0 along with extension that i used in
    my spree app that all depends upon spree_core1.3.x .

    I have following in my Gemfile

    Gemfile:
    -----------

    gem 'spree', '2.0.0'
    gem 'spree_auth_devise', github: 'spree/spree_auth_devise', *branch:
    '2-0-stable'*
    gem 'spree_gateway', :github => 'spree/spree_gateway'
    gem "spree_social", :git => "git://github.com/spree/spree_social.git",*branch: '1-3-stable'
    *
    gem 'spree_active_sale' , :git => '
    git://github.com/suryart/spree_active_sale.git', :branch => '1-3-stable'
    ------------

    When i do "gem install spree" it successfully install spree 2.0.0(Core).
    But the extension which depends upon spree1.3.X and have their
    stable releases for(spree_core 1.3.x) conflicts with the newer version of
    Spree_core(2.0.0).

    *Sample Error look like:*
    Bundler could not find compatible versions for gem "spree_core":
    In Gemfile:
    spree_social (>= 0) ruby depends on
    spree_core (~> 1.3.0) ruby

    spree_auth_devise (>= 0) ruby depends on
    spree_core (2.0.0)

    ----------------------------------------------------------------------

    Further more, please tell me should i wait for the newer versions of
    these extensions(spree-social etc.. mentioned above) to pull them from git
    hub that will depend upon "spree_core 2.0.0" ? or Alternatively should i
    make my on custom extension to achieve the functionalists provided by above
    spree extensions? Help me?
  • Ryan Bigg at May 23, 2013 at 2:16 pm
    Please file an issue on those repos so that we know that we need to create a 2-0-stable branch.
    On Thu, May 23, 2013 at 9:10 AM, Ateq Ejaz wrote:

    Hi Ryan,
    Thanks but what about the gems that are in master and don't have any stable
    release for spree 2.0.0 like
    *spree-multi-currency <https://github.com/pronix/spree-multi-currency>*
    Can i clone its repo. and may use it as a standalone extension?
    Thanks,
    On Thu, May 23, 2013 at 9:30 AM, Alexey Topolyanskiy
    wrote:
    I saw same problem when generating sandbox from 2-0-stable branch

    23 мая 2013, в 15:29, "Ryan Bigg" <ryan@spreecommerce.com> написал(а):

    You should be using the master or 2-0-stable branch from spree_social if
    it is available. Attempting to use the 1-3-stable branch will not work.

    On Thu, May 23, 2013 at 6:20 AM, Ateq Ejaz wrote:

    Hi Guys,

    i'm trying to upgrade t0 spree2.0.0 along with extension that i used in
    my spree app that all depends upon spree_core1.3.x .

    I have following in my Gemfile

    Gemfile:
    -----------

    gem 'spree', '2.0.0'
    gem 'spree_auth_devise', github: 'spree/spree_auth_devise', *branch:
    '2-0-stable'*
    gem 'spree_gateway', :github => 'spree/spree_gateway'
    gem "spree_social", :git => "git://github.com/spree/spree_social.git",*branch: '1-3-stable'
    *
    gem 'spree_active_sale' , :git => '
    git://github.com/suryart/spree_active_sale.git', :branch => '1-3-stable'
    ------------

    When i do "gem install spree" it successfully install spree 2.0.0(Core).
    But the extension which depends upon spree1.3.X and have their
    stable releases for(spree_core 1.3.x) conflicts with the newer version of
    Spree_core(2.0.0).

    *Sample Error look like:*
    Bundler could not find compatible versions for gem "spree_core":
    In Gemfile:
    spree_social (>= 0) ruby depends on
    spree_core (~> 1.3.0) ruby

    spree_auth_devise (>= 0) ruby depends on
    spree_core (2.0.0)

    ----------------------------------------------------------------------

    Further more, please tell me should i wait for the newer versions of
    these extensions(spree-social etc.. mentioned above) to pull them from git
    hub that will depend upon "spree_core 2.0.0" ? or Alternatively should i
    make my on custom extension to achieve the functionalists provided by above
    spree extensions? Help me?
  • Ateq Ejaz at May 23, 2013 at 2:45 pm
    Thanks Ryan,

       I just clone the spree-multi_currency repo. from git hub and use it as a
    stand alone extension in the app. its work. I will keep posting the
    extension that not have a spree 2.0.0 stable version. One more thing that i
    have successfully upgraded to spree 2.0.0 but have one error . My
    application is unable to find spree/spree_core for Javasripts and for
    Stylesheets. Also translation is completely missing after upgradation. ?
    Any clue?

    Thanks.
    On Thursday, May 23, 2013 7:20:05 AM UTC-3, Ateq Ejaz wrote:

    Hi Guys,

    i'm trying to upgrade t0 spree2.0.0 along with extension that i used in my
    spree app that all depends upon spree_core1.3.x .

    I have following in my Gemfile

    Gemfile:
    -----------

    gem 'spree', '2.0.0'
    gem 'spree_auth_devise', github: 'spree/spree_auth_devise', *branch:
    '2-0-stable'*
    gem 'spree_gateway', :github => 'spree/spree_gateway'
    gem "spree_social", :git => "git://github.com/spree/spree_social.git",*branch: '1-3-stable'
    *
    gem 'spree_active_sale' , :git => 'git://
    github.com/suryart/spree_active_sale.git', :branch => '1-3-stable'
    ------------

    When i do "gem install spree" it successfully install spree 2.0.0(Core).
    But the extension which depends upon spree1.3.X and have their
    stable releases for(spree_core 1.3.x) conflicts with the newer version of
    Spree_core(2.0.0).

    *Sample Error look like:*
    Bundler could not find compatible versions for gem "spree_core":
    In Gemfile:
    spree_social (>= 0) ruby depends on
    spree_core (~> 1.3.0) ruby

    spree_auth_devise (>= 0) ruby depends on
    spree_core (2.0.0)

    ----------------------------------------------------------------------

    Further more, please tell me should i wait for the newer versions of these
    extensions(spree-social etc.. mentioned above) to pull them from git hub
    that will depend upon "spree_core 2.0.0" ? or Alternatively should i make
    my on custom extension to achieve the functionalists provided by above
    spree extensions? Help me?
  • Ryan Bigg at May 23, 2013 at 3:03 pm
    That's one thing we didn't mention in the release notes.


    Change spree_core references to spree_frontend in all your assets and it will work fine. Admin assets will need to reference spree_backend instead.


    Also, please explain what you mean by the translations missing. The translations were namespaced in Spree 2.0 so you might be using an extension that has not been updated.


    Steps to reproduce that translations problem would be extremely useful for us to know how you're seeing that problem.
    On Thu, May 23, 2013 at 10:45 AM, Ateq Ejaz wrote:

    Thanks Ryan,
    I just clone the spree-multi_currency repo. from git hub and use it as a
    stand alone extension in the app. its work. I will keep posting the
    extension that not have a spree 2.0.0 stable version. One more thing that i
    have successfully upgraded to spree 2.0.0 but have one error . My
    application is unable to find spree/spree_core for Javasripts and for
    Stylesheets. Also translation is completely missing after upgradation. ?
    Any clue?
    Thanks.
    On Thursday, May 23, 2013 7:20:05 AM UTC-3, Ateq Ejaz wrote:

    Hi Guys,

    i'm trying to upgrade t0 spree2.0.0 along with extension that i used in my
    spree app that all depends upon spree_core1.3.x .

    I have following in my Gemfile

    Gemfile:
    -----------

    gem 'spree', '2.0.0'
    gem 'spree_auth_devise', github: 'spree/spree_auth_devise', *branch:
    '2-0-stable'*
    gem 'spree_gateway', :github => 'spree/spree_gateway'
    gem "spree_social", :git => "git://github.com/spree/spree_social.git",*branch: '1-3-stable'
    *
    gem 'spree_active_sale' , :git => 'git://
    github.com/suryart/spree_active_sale.git', :branch => '1-3-stable'
    ------------

    When i do "gem install spree" it successfully install spree 2.0.0(Core).
    But the extension which depends upon spree1.3.X and have their
    stable releases for(spree_core 1.3.x) conflicts with the newer version of
    Spree_core(2.0.0).

    *Sample Error look like:*
    Bundler could not find compatible versions for gem "spree_core":
    In Gemfile:
    spree_social (>= 0) ruby depends on
    spree_core (~> 1.3.0) ruby

    spree_auth_devise (>= 0) ruby depends on
    spree_core (2.0.0)

    ----------------------------------------------------------------------

    Further more, please tell me should i wait for the newer versions of these
    extensions(spree-social etc.. mentioned above) to pull them from git hub
    that will depend upon "spree_core 2.0.0" ? or Alternatively should i make
    my on custom extension to achieve the functionalists provided by above
    spree extensions? Help me?
  • Ateq Ejaz at May 23, 2013 at 7:11 pm
    Thanks Ryan,

    Really appreciate your work towards the community great job. I'm currently
    in the middle of up gradation Definitely will rewrite the steps for
    translations absence.

    On Thu, May 23, 2013 at 12:03 PM, Ryan Bigg wrote:

    That's one thing we didn't mention in the release notes.

    Change spree_core references to spree_frontend in all your assets and it
    will work fine. Admin assets will need to reference spree_backend instead.

    Also, please explain what you mean by the translations missing. The
    translations were namespaced in Spree 2.0 so you might be using an
    extension that has not been updated.

    Steps to reproduce that translations problem would be extremely useful for
    us to know how you're seeing that problem.

    On Thu, May 23, 2013 at 10:45 AM, Ateq Ejaz wrote:

    Thanks Ryan,

    I just clone the spree-multi_currency repo. from git hub and use it as
    a stand alone extension in the app. its work. I will keep posting the
    extension that not have a spree 2.0.0 stable version. One more thing that i
    have successfully upgraded to spree 2.0.0 but have one error . My
    application is unable to find spree/spree_core for Javasripts and for
    Stylesheets. Also translation is completely missing after upgradation. ?
    Any clue?

    Thanks.
    On Thursday, May 23, 2013 7:20:05 AM UTC-3, Ateq Ejaz wrote:

    Hi Guys,

    i'm trying to upgrade t0 spree2.0.0 along with extension that i used in
    my spree app that all depends upon spree_core1.3.x .

    I have following in my Gemfile

    Gemfile:
    -----------

    gem 'spree', '2.0.0'
    gem 'spree_auth_devise', github: 'spree/spree_auth_devise', *branch:
    '2-0-stable'*
    gem 'spree_gateway', :github => 'spree/spree_gateway'
    gem "spree_social", :git => "git://github.com/spree/spree_**social.git**<http://github.com/spree/spree_social.git>
    ",* branch: '1-3-stable'*
    gem 'spree_active_sale' , :git => 'git://github.com/suryart/**
    spree_active_sale.git**<http://github.com/suryart/spree_active_sale.git>',
    :branch => '1-3-stable'
    ------------

    When i do "gem install spree" it successfully install spree 2.0.0(Core).
    But the extension which depends upon spree1.3.X and have their
    stable releases for(spree_core 1.3.x) conflicts with the newer version of
    Spree_core(2.0.0).

    *Sample Error look like:*
    Bundler could not find compatible versions for gem "spree_core":
    In Gemfile:
    spree_social (>= 0) ruby depends on
    spree_core (~> 1.3.0) ruby

    spree_auth_devise (>= 0) ruby depends on
    spree_core (2.0.0)

    ------------------------------**------------------------------**
    ----------****

    Further more, please tell me should i wait for the newer versions of
    these extensions(spree-social etc.. mentioned above) to pull them from git
    hub that will depend upon "spree_core 2.0.0" ? or Alternatively should i
    make my on custom extension to achieve the functionalists provided by above
    spree extensions? Help me?

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedMay 23, '13 at 10:20a
activeMay 23, '13 at 7:11p
posts7
users3
websitespreecommerce.com
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase