FAQ
Hi Guys,

  I'm trying to upgrade my spree store to spree new release 2.0.0 my gem
file is as follow it gives me following error when i do "bundle install"
  Any clue?
Error:

Bundler could not find compatible versions for gem "spree_frontend":
   In Gemfile:
     spree (>= 0) ruby depends on
       spree_frontend (= 2.0.0) ruby

     spree_auth_devise (>= 0) ruby depends on
       spree_frontend (2.0.0.rc1)
==============================
GemFile:
------------

source 'https://rubygems.org'

gem 'rails', '3.2.13'

# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'

gem 'sqlite3'
gem 'mysql'

# Gems used only for assets and not required
# in production environments by default.
group :assets do
   gem 'sass-rails', '~> 3.2.3'
   gem 'coffee-rails', '~> 3.2.1'

   # See https://github.com/sstephenson/execjs#readme for more supported
runtimes
   # gem 'therubyracer', :platforms => :ruby

   gem 'uglifier', '>= 1.0.3'
end

gem 'jquery-rails'

# To use ActiveModel has_secure_password
# gem 'bcrypt-ruby', '~> 3.0.0'

# To use Jbuilder templates for JSON
# gem 'jbuilder'

# Use unicorn as the app server
# gem 'unicorn'

# Deploy with Capistrano
# gem 'capistrano'

# To use debugger
# gem 'debugger'
*gem 'spree', github: 'spree/spree', branch: '2-0-stable'*
gem 'spree_gateway', :github => 'spree/spree_gateway', :branch =>
'1-3-stable'
*gem 'spree_auth_devise', github: 'spree/spree_auth_devise', branch:
'2-0-stable'*
gem "spree_social", :git => "git://github.com/spree/spree_social.git",
:branch => '1-3-stable'
gem 'spree_active_sale' , :git =>
'git://github.com/suryart/spree_active_sale.git', :branch => '1-3-stable'
gem 'spree_multi_currency', :github => "spree/spree_multi_currency"
=================================================

Search Discussions

  • Ryan Bigg at May 24, 2013 at 2:51 am
    I would really recommend using the 2-0-stable branches for both
    spree_gateway and spree_auth_devise. Any official extension's master branch
    can and will change without warning to be updated to be relevant to any
    changes within Spree's master branch. Because Spree's master is typically
    quite chaotic, the extensions are too. Please point to 2-0-stable.

    On Thu, May 23, 2013 at 3:08 AM, magnus_vb wrote:

    Hello Ateq
    I had (almost) the same issue. I created a brand new installation and had
    the same error. This is how I solved it.

    I'm using RVM and had an old gemset with spree 2.0 rc1. So I created a new
    gemset ("spree200") and installed spree 2.0 ("gem install spree"). But when
    installing the spree in the new rails project, the Terminal printed this:

    loading ruby /Users/magnus/.rvm/gems/ruby-2.0.0-p195@spree200rc1/gems/
    spree_core-2.0.0.rc1/db/default/spree/countries.rb


    (It is loading ruby and spree_core from "wrong" gemset!?!).

    So I deleted that old, rc1 gemset (and restarted the Terminal to be sure),
    created a new rails project and installed spree (using "gem install
    spree_cmd") again. This time no errors :)

    Also, in the wrong installation the gemfile had this:
    gem 'spree', '2.0.0.rc1'
    gem 'spree_gateway', :git => 'https://github.com/spree/spree_gateway.git'
    gem 'spree_auth_devise', :git => '
    https://github.com/spree/spree_auth_devise.git'


    But in the successful installation, the gemfile looks like this:
    gem 'spree', '2.0.0'
    gem 'spree_gateway', :git => 'https://github.com/spree/spree_gateway.git'
    gem 'spree_auth_devise', :git => '
    https://github.com/spree/spree_auth_devise.git'


    Not sure if the problem was with RVM, Terminal or what…

    Regards, Magnus
    On Wednesday, May 22, 2013 10:15:26 PM UTC+2, Ateq Ejaz wrote:

    Hi Guys,

    I'm trying to upgrade my spree store to spree new release 2.0.0 my gem
    file is as follow it gives me following error when i do "bundle install"
    Any clue?
    Error:

    Bundler could not find compatible versions for gem "spree_frontend":
    In Gemfile:
    spree (>= 0) ruby depends on
    spree_frontend (= 2.0.0) ruby

    spree_auth_devise (>= 0) ruby depends on
    spree_frontend (2.0.0.rc1)
    ==============================
    GemFile:
    ------------

    source 'https://rubygems.org'

    gem 'rails', '3.2.13'

    # Bundle edge Rails instead:
    # gem 'rails', :git => 'git://github.com/rails/rails.**git<http://github.com/rails/rails.git>
    '

    gem 'sqlite3'
    gem 'mysql'

    # Gems used only for assets and not required
    # in production environments by default.
    group :assets do
    gem 'sass-rails', '~> 3.2.3'
    gem 'coffee-rails', '~> 3.2.1'

    # See https://github.com/**sstephenson/execjs#readme<https://github.com/sstephenson/execjs#readme>for more supported runtimes
    # gem 'therubyracer', :platforms => :ruby

    gem 'uglifier', '>= 1.0.3'
    end

    gem 'jquery-rails'

    # To use ActiveModel has_secure_password
    # gem 'bcrypt-ruby', '~> 3.0.0'

    # To use Jbuilder templates for JSON
    # gem 'jbuilder'

    # Use unicorn as the app server
    # gem 'unicorn'

    # Deploy with Capistrano
    # gem 'capistrano'

    # To use debugger
    # gem 'debugger'
    *gem 'spree', github: 'spree/spree', branch: '2-0-stable'*
    gem 'spree_gateway', :github => 'spree/spree_gateway', :branch =>
    '1-3-stable'
    *gem 'spree_auth_devise', github: 'spree/spree_auth_devise', branch:
    '2-0-stable'*
    gem "spree_social", :git => "git://github.com/spree/spree_**social.git<http://github.com/spree/spree_social.git>",
    :branch => '1-3-stable'
    gem 'spree_active_sale' , :git => 'git://github.com/suryart/**
    spree_active_sale.git <http://github.com/suryart/spree_active_sale.git>',
    :branch => '1-3-stable'
    gem 'spree_multi_currency', :github => "spree/spree_multi_currency"
    ==============================**===================

    --

    Ryan Bigg
    Community Manager
    Spree Commerce, Inc.

    Register now for SpreeConf
    May 20-21 in Washington, D.C.
    http://spreeconf.com
  • Ateq Ejaz at May 24, 2013 at 10:33 am
    Hi Ryan,

    Firstly i will definitely point spree_gateway to their 2-0-stable branch.
    Now here again, the problem is related to Extensions like Spree_social that
    doesn't have 2-0-stable branch, spree_auth_devise again doesn't have 2-0
    stable branch and spree_active_sale that has 2.0.0.beta branch but don't
    have 2-0-stable branch yet on git hub. For Spree_social i'm using its
    master branch to remove its dependency on spree_core 1.3.x as we had a talk
    yesterday in this regard and you suggested either to use Master or
    2-0-stable branches for these extensions if they exist. i'm using master
    for those that doesn't have 2-0-stable branches. Tell me what to do for
    these extensions? to work with spree 2.0.0? Thanks.

    On Thu, May 23, 2013 at 11:51 PM, Ryan Bigg wrote:

    I would really recommend using the 2-0-stable branches for both
    spree_gateway and spree_auth_devise. Any official extension's master branch
    can and will change without warning to be updated to be relevant to any
    changes within Spree's master branch. Because Spree's master is typically
    quite chaotic, the extensions are too. Please point to 2-0-stable.

    On Thu, May 23, 2013 at 3:08 AM, magnus_vb wrote:

    Hello Ateq
    I had (almost) the same issue. I created a brand new installation and had
    the same error. This is how I solved it.

    I'm using RVM and had an old gemset with spree 2.0 rc1. So I created a
    new gemset ("spree200") and installed spree 2.0 ("gem install spree"). But
    when installing the spree in the new rails project, the Terminal printed
    this:

    loading ruby /Users/magnus/.rvm/gems/ruby-2.0.0-p195@spree200rc1/gems/
    spree_core-2.0.0.rc1/db/default/spree/countries.rb


    (It is loading ruby and spree_core from "wrong" gemset!?!).

    So I deleted that old, rc1 gemset (and restarted the Terminal to be
    sure), created a new rails project and installed spree (using "gem install
    spree_cmd") again. This time no errors :)

    Also, in the wrong installation the gemfile had this:
    gem 'spree', '2.0.0.rc1'
    gem 'spree_gateway', :git => 'https://github.com/spree/spree_gateway.git'
    gem 'spree_auth_devise', :git => '
    https://github.com/spree/spree_auth_devise.git'


    But in the successful installation, the gemfile looks like this:
    gem 'spree', '2.0.0'
    gem 'spree_gateway', :git => 'https://github.com/spree/spree_gateway.git'
    gem 'spree_auth_devise', :git => '
    https://github.com/spree/spree_auth_devise.git'


    Not sure if the problem was with RVM, Terminal or what…

    Regards, Magnus
    On Wednesday, May 22, 2013 10:15:26 PM UTC+2, Ateq Ejaz wrote:

    Hi Guys,

    I'm trying to upgrade my spree store to spree new release 2.0.0 my gem
    file is as follow it gives me following error when i do "bundle install"
    Any clue?
    Error:

    Bundler could not find compatible versions for gem "spree_frontend":
    In Gemfile:
    spree (>= 0) ruby depends on
    spree_frontend (= 2.0.0) ruby

    spree_auth_devise (>= 0) ruby depends on
    spree_frontend (2.0.0.rc1)
    ==============================
    GemFile:
    ------------

    source 'https://rubygems.org'

    gem 'rails', '3.2.13'

    # Bundle edge Rails instead:
    # gem 'rails', :git => 'git://github.com/rails/rails.**git<http://github.com/rails/rails.git>
    '

    gem 'sqlite3'
    gem 'mysql'

    # Gems used only for assets and not required
    # in production environments by default.
    group :assets do
    gem 'sass-rails', '~> 3.2.3'
    gem 'coffee-rails', '~> 3.2.1'

    # See https://github.com/**sstephenson/execjs#readme<https://github.com/sstephenson/execjs#readme>for more supported runtimes
    # gem 'therubyracer', :platforms => :ruby

    gem 'uglifier', '>= 1.0.3'
    end

    gem 'jquery-rails'

    # To use ActiveModel has_secure_password
    # gem 'bcrypt-ruby', '~> 3.0.0'

    # To use Jbuilder templates for JSON
    # gem 'jbuilder'

    # Use unicorn as the app server
    # gem 'unicorn'

    # Deploy with Capistrano
    # gem 'capistrano'

    # To use debugger
    # gem 'debugger'
    *gem 'spree', github: 'spree/spree', branch: '2-0-stable'*
    gem 'spree_gateway', :github => 'spree/spree_gateway', :branch =>
    '1-3-stable'
    *gem 'spree_auth_devise', github: 'spree/spree_auth_devise', branch:
    '2-0-stable'*
    gem "spree_social", :git => "git://github.com/spree/spree_**social.git<http://github.com/spree/spree_social.git>",
    :branch => '1-3-stable'
    gem 'spree_active_sale' , :git => 'git://github.com/suryart/**
    spree_active_sale.git <http://github.com/suryart/spree_active_sale.git>',
    :branch => '1-3-stable'
    gem 'spree_multi_currency', :github => "spree/spree_multi_currency"
    ==============================**===================

    --

    Ryan Bigg
    Community Manager
    Spree Commerce, Inc.

    Register now for SpreeConf
    May 20-21 in Washington, D.C.
    http://spreeconf.com

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedMay 22, '13 at 8:15p
activeMay 24, '13 at 10:33a
posts3
users2
websitespreecommerce.com
irc#RubyOnRails

2 users in discussion

Ateq Ejaz: 2 posts Ryan Bigg: 1 post

People

Translate

site design / logo © 2022 Grokbase