FAQ
Hi,

when deploying Spree 2 on Heroku cedar :

        Installing spree (2.0.0)
        Gem::InstallError: spree requires RubyGems version >= 1.8.25. Try
'gem update --system' to update RubyGems itself.


:(. I don't think it's easy to do something for this?

Nicolas.

Search Discussions

  • MichaelB at May 23, 2013 at 3:56 pm
    I'm encountering this same error. I would like to hear more about what
    might be happening as well.

    Here is my Gemfile for reference:
    source 'https://rubygems.org'
    ruby "1.9.3"
    gem 'rails', '3.2.13'


    gem 'sqlite3'

    group :assets do
       gem 'sass-rails', '~> 3.2.3'
       gem 'coffee-rails', '~> 3.2.1'
       gem 'uglifier', '>= 1.0.3'
    end

    gem 'jquery-rails'


    gem 'spree', '2.0.0'
    gem 'spree_gateway', :git => 'https://github.com/spree/spree_gateway.git'
    gem 'spree_auth_devise', :git =>
    'https://github.com/spree/spree_auth_devise.git'
    On Tuesday, May 21, 2013 7:06:06 AM UTC-4, Nicolas Blanco wrote:

    Hi,

    when deploying Spree 2 on Heroku cedar :

    Installing spree (2.0.0)
    Gem::InstallError: spree requires RubyGems version >= 1.8.25. Try
    'gem update --system' to update RubyGems itself.


    :(. I don't think it's easy to do something for this?

    Nicolas.
  • MichaelB at May 23, 2013 at 6:48 pm
    This caused by Heroku not supporting the required version of RubyGems. I'm
    not sure if Spree actually requires it. Heroku would work with just one
    version down:
    https://devcenter.heroku.com/articles/ruby-support#ruby-versions

    Github
    discussion: https://github.com/spree/spree/commit/7d8ffb573aef7bb141541484167f0f13e838e14b
    On Thursday, May 23, 2013 11:42:32 AM UTC-4, MichaelB wrote:

    I'm encountering this same error. I would like to hear more about what
    might be happening as well.

    Here is my Gemfile for reference:
    source 'https://rubygems.org'
    ruby "1.9.3"
    gem 'rails', '3.2.13'


    gem 'sqlite3'

    group :assets do
    gem 'sass-rails', '~> 3.2.3'
    gem 'coffee-rails', '~> 3.2.1'
    gem 'uglifier', '>= 1.0.3'
    end

    gem 'jquery-rails'


    gem 'spree', '2.0.0'
    gem 'spree_gateway', :git => 'https://github.com/spree/spree_gateway.git'
    gem 'spree_auth_devise', :git => '
    https://github.com/spree/spree_auth_devise.git'
    On Tuesday, May 21, 2013 7:06:06 AM UTC-4, Nicolas Blanco wrote:

    Hi,

    when deploying Spree 2 on Heroku cedar :

    Installing spree (2.0.0)
    Gem::InstallError: spree requires RubyGems version >= 1.8.25. Try
    'gem update --system' to update RubyGems itself.


    :(. I don't think it's easy to do something for this?

    Nicolas.
  • MichaelB at May 23, 2013 at 9:52 pm
    No problem. I fixed it and created a pull request that was approved.
    Hosting is working great now on Heroku.
    On Thursday, May 23, 2013 5:35:29 PM UTC-4, Ryan Bigg wrote:

    Sorry that this happened. I think that we'll be doing a 2.0.1 release in
    the next couple of weeks which will fix all the little bugs in 2.0.
    Hopefully someone will fix this in 2-0-stable and master before then, and
    you can use those versions.


    On Thu, May 23, 2013 at 11:56 AM, MichaelB <mic...@actven.com<javascript:>
    wrote:
    I'm encountering this same error. I would like to hear more about what
    might be happening as well.

    Here is my Gemfile for reference:
    source 'https://rubygems.org'
    ruby "1.9.3"
    gem 'rails', '3.2.13'


    gem 'sqlite3'

    group :assets do
    gem 'sass-rails', '~> 3.2.3'
    gem 'coffee-rails', '~> 3.2.1'
    gem 'uglifier', '>= 1.0.3'
    end

    gem 'jquery-rails'


    gem 'spree', '2.0.0'
    gem 'spree_gateway', :git => 'https://github.com/spree/spree_gateway.git'
    gem 'spree_auth_devise', :git => '
    https://github.com/spree/spree_auth_devise.git'
    On Tuesday, May 21, 2013 7:06:06 AM UTC-4, Nicolas Blanco wrote:

    Hi,

    when deploying Spree 2 on Heroku cedar :

    Installing spree (2.0.0)
    Gem::InstallError: spree requires RubyGems version >= 1.8.25. Try
    'gem update --system' to update RubyGems itself.


    :(. I don't think it's easy to do something for this?

    Nicolas.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedMay 21, '13 at 11:07a
activeMay 23, '13 at 9:52p
posts4
users2
websitespreecommerce.com
irc#RubyOnRails

2 users in discussion

MichaelB: 3 posts Nicolas Blanco: 1 post

People

Translate

site design / logo © 2022 Grokbase