I'm trying to add spree_mail gem to my Spree project.

& when I run "bundle install"

I get this message:

Bundler could not find compatible versions for gem "devise":
In Gemfile:
spree_mail (= 0.40.0.4) ruby depends on
devise (= 1.2.rc) ruby

spree_auth_devise (>= 0) ruby depends on
devise (2.2.3)

Bundler could not find compatible versions for gem "spree_core":
In Gemfile:
spree_mail (= 0.40.0.4) ruby depends on
spree_core (= 0.30.1) ruby

spree_mail (= 0.40.0.4) ruby depends on
spree_core (1.3.2)


my Gemfile

source 'http://rubygems.org'

gem 'spree_i18n', :git => "git://github.com/spree/spree_i18n.git"

gem 'rails', '3.2.13'

# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'

gem 'sqlite3'


# Gems used only for assets and not required
# in production environments by default.
group :assets do
gem 'sass-rails', '~> 3.2.3'
gem 'coffee-rails', '~> 3.2.1'

# See https://github.com/sstephenson/execjs#readme for more supported
runtimes
# gem 'therubyracer', :platforms => :ruby

gem 'uglifier', '>= 1.0.3'
end

gem 'jquery-rails'

# To use ActiveModel has_secure_password
# gem 'bcrypt-ruby', '~> 3.0.0'

# To use Jbuilder templates for JSON
# gem 'jbuilder'

# Use unicorn as the app server
# gem 'unicorn'

# Deploy with Capistrano
# gem 'capistrano'

# To use debugger
# gem 'debugger'
gem 'spree', '1.3.2'
gem 'spree_gateway', :github => 'spree/spree_gateway', :branch =>
'1-3-stable'
gem 'spree_auth_devise', :github => 'spree/spree_auth_devise', :branch
=> '1-3-stable'
gem 'spree_mail', '0.40.0.4'

--
Don't miss SpreeConf on May 20-21: http://spreeconf.com
Spree is hiring: http://spreecommerce.com/careers

Search Discussions

  • Ryan Bigg at Apr 17, 2013 at 7:12 am
    Hi Artem,


    You are getting that error because spree_mail depends on a very old version of devise. I would recommend contacting the repo owner on GitHub and asking them to update the project, or you could fork it and update it yourself.
    On Wed, Apr 17, 2013 at 5:11 PM, null wrote:

    I'm trying to add spree_mail gem to my Spree project.
    & when I run "bundle install"
    I get this message:
    Bundler could not find compatible versions for gem "devise":
    In Gemfile:
    spree_mail (= 0.40.0.4) ruby depends on
    devise (= 1.2.rc) ruby
    spree_auth_devise (>= 0) ruby depends on
    devise (2.2.3)
    Bundler could not find compatible versions for gem "spree_core":
    In Gemfile:
    spree_mail (= 0.40.0.4) ruby depends on
    spree_core (= 0.30.1) ruby
    spree_mail (= 0.40.0.4) ruby depends on
    spree_core (1.3.2)
    my Gemfile
    source 'http://rubygems.org'

    gem 'spree_i18n', :git => "git://github.com/spree/spree_i18n.git"

    gem 'rails', '3.2.13'

    # Bundle edge Rails instead:
    # gem 'rails', :git => 'git://github.com/rails/rails.git'

    gem 'sqlite3'


    # Gems used only for assets and not required
    # in production environments by default.
    group :assets do
    gem 'sass-rails', '~> 3.2.3'
    gem 'coffee-rails', '~> 3.2.1'

    # See https://github.com/sstephenson/execjs#readme for more supported
    runtimes
    # gem 'therubyracer', :platforms => :ruby

    gem 'uglifier', '>= 1.0.3'
    end

    gem 'jquery-rails'

    # To use ActiveModel has_secure_password
    # gem 'bcrypt-ruby', '~> 3.0.0'

    # To use Jbuilder templates for JSON
    # gem 'jbuilder'

    # Use unicorn as the app server
    # gem 'unicorn'

    # Deploy with Capistrano
    # gem 'capistrano'

    # To use debugger
    # gem 'debugger'
    gem 'spree', '1.3.2'
    gem 'spree_gateway', :github => 'spree/spree_gateway', :branch =>
    '1-3-stable'
    gem 'spree_auth_devise', :github => 'spree/spree_auth_devise', :branch
    => '1-3-stable'
    gem 'spree_mail', '0.40.0.4'
    --
    Don't miss SpreeConf on May 20-21: http://spreeconf.com
    Spree is hiring: http://spreecommerce.com/careers
    --
    Don't miss SpreeConf on May 20-21: http://spreeconf.com
    Spree is hiring: http://spreecommerce.com/careers

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedApr 17, '13 at 7:11a
activeApr 17, '13 at 7:12a
posts2
users2
websitespreecommerce.com
irc#RubyOnRails

2 users in discussion

Artem Belov: 1 post Ryan Bigg: 1 post

People

Translate

site design / logo © 2022 Grokbase