So I need to write some tests for the 1-3-stable branch regarding the
line_item single unit price display. I just started working with Spree
recently and only forked it yesterday. As a starting point I wanted to
make sure that the existing test suite completed properly before I started
adding my own tests. In the core directory a bundle exec rake spec ended
up with the following outcome:

Finished in 4 minutes 32.83 seconds
1028 examples, 55 failures, 1 pending

I am curious if this is normal and I should focus on only testing the stuff
I'm doing or if something is wrong with how I'm running the test suite?

Thanks,
Zach

--
You received this message because you are subscribed to the Google Groups "Spree" group.
To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Andrew Hooker at Mar 29, 2013 at 1:44 pm
    Did you run `rake test_app`? Are most of the failures the same?
    ---
    Andrew Hooker
    Support Engineer
    Spree Commerce, Inc.

    Register now for SpreeConf
    May 20-21 in Washington, D.C.
    http://spreeconf.com
    On Mar 29, 2013, at 8:43 AM, Zach Karpinski wrote:

    So I need to write some tests for the 1-3-stable branch regarding the line_item single unit price display. I just started working with Spree recently and only forked it yesterday. As a starting point I wanted to make sure that the existing test suite completed properly before I started adding my own tests. In the core directory a bundle exec rake spec ended up with the following outcome:

    Finished in 4 minutes 32.83 seconds
    1028 examples, 55 failures, 1 pending

    I am curious if this is normal and I should focus on only testing the stuff I'm doing or if something is wrong with how I'm running the test suite?

    Thanks,
    Zach

    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Zach Karpinski at Mar 29, 2013 at 1:51 pm
    I didn't try that but even after doing it I immediately got some errors
    regarding my local installation of ImageMagick. I will start by solving
    that and seeing how things change.

    Thanks,
    Zach
    On Friday, March 29, 2013 8:44:22 AM UTC-5, Andrew Hooker wrote:

    Did you run `rake test_app`? Are most of the failures the same?
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Zach Karpinski at Mar 29, 2013 at 3:38 pm
    After reinstalling libpng and imagemagick from source I ended up with much
    better results.

    Finished in 4 minutes 46.02 seconds
    1028 examples, 0 failures, 2 pending


    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedMar 29, '13 at 1:43p
activeMar 29, '13 at 3:38p
posts4
users2
websitespreecommerce.com
irc#RubyOnRails

2 users in discussion

Zach Karpinski: 3 posts Andrew Hooker: 1 post

People

Translate

site design / logo © 2022 Grokbase