Hi,


I have to send e-mail after the following events:

- New client registration
- Payment complete
- Order sent (shipment)

Spree isn't sending any email. I already configured my SMTP server in
configuration (admin)


Thanks in advance,

Giulliano Bueno.

--
You received this message because you are subscribed to the Google Groups "Spree" group.
To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • theCrab at Mar 25, 2013 at 6:21 pm
    hmmm! any errors in the log?
    On Monday, 25 March 2013 18:12:41 UTC, Giulliano Bueno wrote:

    Hi,


    I have to send e-mail after the following events:

    - New client registration
    - Payment complete
    - Order sent (shipment)

    Spree isn't sending any email. I already configured my SMTP server in
    configuration (admin)


    Thanks in advance,

    Giulliano Bueno.
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jason Rylance at Apr 1, 2013 at 11:46 am
    Both in development and production I am having similar email issues.


    - In Development: The app appears to send the email (after maybe a 30
    second 'loading' or 'pause'), I get the 'email sent' confirmation flash
    message, (no errors, I can see the email information in the log, as if the
    email was sent) but I receive no email at the destination address.
    - In Production: I click 'send test email' , there is a multi-second
    pause, then a "502 Bad Gateway nginx/1.1.19" error message appears. There
    are no errors in my logs, however (which seems odd).



    This appears at the end of my production logs after I attempt to send a
    test mail.

    Started POST "/store/admin/mail_methods/1/testmail" for 67.79.238.78 at
    2013-04-01 11:33:06 +0000
    Processing by Spree::Admin::MailMethodsController#testmail as HTML
    Parameters: {"authenticity_token"=>"*****", "id"=>"1"}
    Rendered
    /home/spree/angel_wood/shared/bundle/ruby/1.9.1/gems/spree_core-1.3.2/app/views/spree/test_mailer/test_email.text.erb
    (1.0ms)


    I am only attempting to configure email using the admin panel's "Mail
    Methods" section. I cannot find any Spree related documentation on the
    subject. *Am I supposed to configure anything other than what is found
    explicitly within the admin panel within the spree app itself?*
    On Monday, March 25, 2013 2:42:07 PM UTC-5, Giulliano Bueno wrote:

    No error, I must be missing something.
    Em segunda-feira, 25 de março de 2013 15h21min32s UTC-3, theCrab escreveu:

    hmmm! any errors in the log?
    On Monday, 25 March 2013 18:12:41 UTC, Giulliano Bueno wrote:

    Hi,


    I have to send e-mail after the following events:

    - New client registration
    - Payment complete
    - Order sent (shipment)

    Spree isn't sending any email. I already configured my SMTP server in
    configuration (admin)


    Thanks in advance,

    Giulliano Bueno.
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jason Rylance at Apr 2, 2013 at 10:58 am
    The issue I was having was directly related to gmail. I switched to
    another provider and things worked fine when only configuring the mail
    settings from my app/store's configuration screen.
    On Monday, April 1, 2013 6:46:45 AM UTC-5, Jason Rylance wrote:

    Both in development and production I am having similar email issues.


    - In Development: The app appears to send the email (after maybe a 30
    second 'loading' or 'pause'), I get the 'email sent' confirmation flash
    message, (no errors, I can see the email information in the log, as if the
    email was sent) but I receive no email at the destination address.
    - In Production: I click 'send test email' , there is a multi-second
    pause, then a "502 Bad Gateway nginx/1.1.19" error message appears. There
    are no errors in my logs, however (which seems odd).



    This appears at the end of my production logs after I attempt to send a
    test mail.

    Started POST "/store/admin/mail_methods/1/testmail" for 67.79.238.78 at
    2013-04-01 11:33:06 +0000
    Processing by Spree::Admin::MailMethodsController#testmail as HTML
    Parameters: {"authenticity_token"=>"*****", "id"=>"1"}
    Rendered
    /home/spree/angel_wood/shared/bundle/ruby/1.9.1/gems/spree_core-1.3.2/app/views/spree/test_mailer/test_email.text.erb
    (1.0ms)


    I am only attempting to configure email using the admin panel's "Mail
    Methods" section. I cannot find any Spree related documentation on the
    subject. *Am I supposed to configure anything other than what is found
    explicitly within the admin panel within the spree app itself?*
    On Monday, March 25, 2013 2:42:07 PM UTC-5, Giulliano Bueno wrote:

    No error, I must be missing something.
    Em segunda-feira, 25 de março de 2013 15h21min32s UTC-3, theCrab escreveu:

    hmmm! any errors in the log?
    On Monday, 25 March 2013 18:12:41 UTC, Giulliano Bueno wrote:

    Hi,


    I have to send e-mail after the following events:

    - New client registration
    - Payment complete
    - Order sent (shipment)

    Spree isn't sending any email. I already configured my SMTP server in
    configuration (admin)


    Thanks in advance,

    Giulliano Bueno.
    --
    Don't miss SpreeConf on May 20-21: http://spreeconf.com
    Spree is hiring: http://spreecommerce.com/careers

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedMar 25, '13 at 6:12p
activeApr 2, '13 at 10:58a
posts4
users3
websitespreecommerce.com
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase