Hi,

While deploying Spree on Heroku I am getting the following error:

Could not find ransack-0.7.3 in any of the sources


Is anybody else is experiencing the same problem?

Thanks

--
You received this message because you are subscribed to the Google Groups "Spree" group.
To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Nate Lowrie at Mar 13, 2013 at 12:07 pm
    Can you post your gem file?

    Regards,

    Nate
    On Tuesday, March 12, 2013 11:42:36 PM UTC-4, Muhammad Aamir wrote:

    Hi,

    While deploying Spree on Heroku I am getting the following error:

    Could not find ransack-0.7.3 in any of the sources


    Is anybody else is experiencing the same problem?

    Thanks
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Muhammad Aamir at Mar 13, 2013 at 6:43 pm
    Thanks for your response. This is my Gemfile. It is OOTB, no change except
    ruby "1.9.3":

    source 'https://rubygems.org'

    ruby "1.9.3"

    gem 'rails', '3.2.11'


    # Bundle edge Rails instead:
    # gem 'rails', :git => 'git://github.com/rails/rails.git'


    gem 'sqlite3'

    # Gems used only for assets and not required
    # in production environments by default.
    group :assets do
    gem 'sass-rails', '~> 3.2.3'
    gem 'coffee-rails', '~> 3.2.1'


    gem 'uglifier', '>= 1.0.3'
    end


    gem 'jquery-rails'


    gem 'spree', '1.3.2'
    gem 'spree_gateway', :github => 'spree/spree_gateway', :branch =>
    '1-3-stable'
    gem 'spree_auth_devise', :github => 'spree/spree_auth_devise', :branch =>
    '1-3-stable'




    Thanks
    On Wednesday, March 13, 2013 5:07:55 PM UTC+5, Nate Lowrie wrote:

    Can you post your gem file?

    Regards,

    Nate
    On Tuesday, March 12, 2013 11:42:36 PM UTC-4, Muhammad Aamir wrote:

    Hi,

    While deploying Spree on Heroku I am getting the following error:

    Could not find ransack-0.7.3 in any of the sources


    Is anybody else is experiencing the same problem?

    Thanks
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Nate Lowrie at Mar 13, 2013 at 7:15 pm
    Try running bundle install and seeing if that updates your gemfile.lock
    file. I am not really sure why ransack is being included in the first place
    as spree doesn't require it. Make sure you are checking you gemfile.lock
    into source control. The only other thing I would say is that instead of
    pulling the spree gem from rubygems I would pull it directly from github.

    Regards,

    Nate
    On Wednesday, March 13, 2013 2:43:20 PM UTC-4, Muhammad Aamir wrote:

    Thanks for your response. This is my Gemfile. It is OOTB, no change except
    ruby "1.9.3":

    source 'https://rubygems.org'

    ruby "1.9.3"

    gem 'rails', '3.2.11'


    # Bundle edge Rails instead:
    # gem 'rails', :git => 'git://github.com/rails/rails.git'


    gem 'sqlite3'

    # Gems used only for assets and not required
    # in production environments by default.
    group :assets do
    gem 'sass-rails', '~> 3.2.3'
    gem 'coffee-rails', '~> 3.2.1'


    gem 'uglifier', '>= 1.0.3'
    end


    gem 'jquery-rails'


    gem 'spree', '1.3.2'
    gem 'spree_gateway', :github => 'spree/spree_gateway', :branch =>
    '1-3-stable'
    gem 'spree_auth_devise', :github => 'spree/spree_auth_devise', :branch =>
    '1-3-stable'




    Thanks
    On Wednesday, March 13, 2013 5:07:55 PM UTC+5, Nate Lowrie wrote:

    Can you post your gem file?

    Regards,

    Nate
    On Tuesday, March 12, 2013 11:42:36 PM UTC-4, Muhammad Aamir wrote:

    Hi,

    While deploying Spree on Heroku I am getting the following error:

    Could not find ransack-0.7.3 in any of the sources


    Is anybody else is experiencing the same problem?

    Thanks
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Muhammad Aamir at Mar 13, 2013 at 7:55 pm
    I notice ransack in Gemfile.lock file. I deleted the .lock file, pushed to
    heroku and got the same error. Then I put following line in Gemfile before
    spree gem line:

    gem 'ransack', :github => 'ernie/ransack', :tag => 'v0.7.3'

    Tried push and got the same error.

    Thanks

    On Thursday, March 14, 2013 12:15:31 AM UTC+5, Nate Lowrie wrote:

    Try running bundle install and seeing if that updates your gemfile.lock
    file. I am not really sure why ransack is being included in the first place
    as spree doesn't require it. Make sure you are checking you gemfile.lock
    into source control. The only other thing I would say is that instead of
    pulling the spree gem from rubygems I would pull it directly from github.

    Regards,

    Nate
    On Wednesday, March 13, 2013 2:43:20 PM UTC-4, Muhammad Aamir wrote:

    Thanks for your response. This is my Gemfile. It is OOTB, no change
    except ruby "1.9.3":

    source 'https://rubygems.org'

    ruby "1.9.3"

    gem 'rails', '3.2.11'


    # Bundle edge Rails instead:
    # gem 'rails', :git => 'git://github.com/rails/rails.git'


    gem 'sqlite3'

    # Gems used only for assets and not required
    # in production environments by default.
    group :assets do
    gem 'sass-rails', '~> 3.2.3'
    gem 'coffee-rails', '~> 3.2.1'


    gem 'uglifier', '>= 1.0.3'
    end


    gem 'jquery-rails'


    gem 'spree', '1.3.2'
    gem 'spree_gateway', :github => 'spree/spree_gateway', :branch =>
    '1-3-stable'
    gem 'spree_auth_devise', :github => 'spree/spree_auth_devise', :branch =>
    '1-3-stable'




    Thanks
    On Wednesday, March 13, 2013 5:07:55 PM UTC+5, Nate Lowrie wrote:

    Can you post your gem file?

    Regards,

    Nate
    On Tuesday, March 12, 2013 11:42:36 PM UTC-4, Muhammad Aamir wrote:

    Hi,

    While deploying Spree on Heroku I am getting the following error:

    Could not find ransack-0.7.3 in any of the sources


    Is anybody else is experiencing the same problem?

    Thanks
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Muhammad Aamir at Mar 13, 2013 at 8:30 pm
    I think ransack-0.7.3 is needed by spree and it's been yanked from
    rubygems.org and that is probably the reason of this problem. Not sure how
    to resolve this issue.


    On Thursday, March 14, 2013 12:55:03 AM UTC+5, Muhammad Aamir wrote:

    I notice ransack in Gemfile.lock file. I deleted the .lock file, pushed to
    heroku and got the same error. Then I put following line in Gemfile before
    spree gem line:

    gem 'ransack', :github => 'ernie/ransack', :tag => 'v0.7.3'

    Tried push and got the same error.

    Thanks

    On Thursday, March 14, 2013 12:15:31 AM UTC+5, Nate Lowrie wrote:

    Try running bundle install and seeing if that updates your gemfile.lock
    file. I am not really sure why ransack is being included in the first place
    as spree doesn't require it. Make sure you are checking you gemfile.lock
    into source control. The only other thing I would say is that instead of
    pulling the spree gem from rubygems I would pull it directly from github.

    Regards,

    Nate
    On Wednesday, March 13, 2013 2:43:20 PM UTC-4, Muhammad Aamir wrote:

    Thanks for your response. This is my Gemfile. It is OOTB, no change
    except ruby "1.9.3":

    source 'https://rubygems.org'

    ruby "1.9.3"

    gem 'rails', '3.2.11'


    # Bundle edge Rails instead:
    # gem 'rails', :git => 'git://github.com/rails/rails.git'


    gem 'sqlite3'

    # Gems used only for assets and not required
    # in production environments by default.
    group :assets do
    gem 'sass-rails', '~> 3.2.3'
    gem 'coffee-rails', '~> 3.2.1'


    gem 'uglifier', '>= 1.0.3'
    end


    gem 'jquery-rails'


    gem 'spree', '1.3.2'
    gem 'spree_gateway', :github => 'spree/spree_gateway', :branch =>
    '1-3-stable'
    gem 'spree_auth_devise', :github => 'spree/spree_auth_devise', :branch
    => '1-3-stable'




    Thanks
    On Wednesday, March 13, 2013 5:07:55 PM UTC+5, Nate Lowrie wrote:

    Can you post your gem file?

    Regards,

    Nate
    On Tuesday, March 12, 2013 11:42:36 PM UTC-4, Muhammad Aamir wrote:

    Hi,

    While deploying Spree on Heroku I am getting the following error:

    Could not find ransack-0.7.3 in any of the sources


    Is anybody else is experiencing the same problem?

    Thanks
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ryan Bigg at Mar 17, 2013 at 11:08 pm
    Ransack 0.7.3 was indeed yanked from RubyGems.

    What I would recommend doing is hard-coding the Ransack version to 0.7.2 in
    your Gemfile:

    gem 'ransack', '0.7.2'

    On Thu, Mar 14, 2013 at 7:30 AM, Muhammad Aamir wrote:

    I think ransack-0.7.3 is needed by spree and it's been yanked from
    rubygems.org and that is probably the reason of this problem. Not sure
    how to resolve this issue.


    On Thursday, March 14, 2013 12:55:03 AM UTC+5, Muhammad Aamir wrote:

    I notice ransack in Gemfile.lock file. I deleted the .lock file, pushed
    to heroku and got the same error. Then I put following line in Gemfile
    before spree gem line:

    gem 'ransack', :github => 'ernie/ransack', :tag => 'v0.7.3'

    Tried push and got the same error.

    Thanks

    On Thursday, March 14, 2013 12:15:31 AM UTC+5, Nate Lowrie wrote:

    Try running bundle install and seeing if that updates your gemfile.lock
    file. I am not really sure why ransack is being included in the first place
    as spree doesn't require it. Make sure you are checking you gemfile.lock
    into source control. The only other thing I would say is that instead of
    pulling the spree gem from rubygems I would pull it directly from github.

    Regards,

    Nate
    On Wednesday, March 13, 2013 2:43:20 PM UTC-4, Muhammad Aamir wrote:

    Thanks for your response. This is my Gemfile. It is OOTB, no change
    except ruby "1.9.3":

    source 'https://rubygems.org'

    ruby "1.9.3"

    gem 'rails', '3.2.11'


    # Bundle edge Rails instead:
    # gem 'rails', :git => 'git://github.com/rails/rails.**git<http://github.com/rails/rails.git>
    '


    gem 'sqlite3'

    # Gems used only for assets and not required
    # in production environments by default.
    group :assets do
    gem 'sass-rails', '~> 3.2.3'
    gem 'coffee-rails', '~> 3.2.1'


    gem 'uglifier', '>= 1.0.3'
    end


    gem 'jquery-rails'


    gem 'spree', '1.3.2'
    gem 'spree_gateway', :github => 'spree/spree_gateway', :branch =>
    '1-3-stable'
    gem 'spree_auth_devise', :github => 'spree/spree_auth_devise', :branch
    => '1-3-stable'




    Thanks
    On Wednesday, March 13, 2013 5:07:55 PM UTC+5, Nate Lowrie wrote:

    Can you post your gem file?

    Regards,

    Nate
    On Tuesday, March 12, 2013 11:42:36 PM UTC-4, Muhammad Aamir wrote:

    Hi,

    While deploying Spree on Heroku I am getting the following error:

    Could not find ransack-0.7.3 in any of the sources


    Is anybody else is experiencing the same problem?

    Thanks
    --
    You received this message because you are subscribed to the Google Groups
    "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.



    --

    Ryan Bigg
    Community Manager
    Spree Commerce, Inc.

    Register now for SpreeConf
    May 20-21 in Washington, D.C.
    http://spreeconf.com

    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Stan Lun at Mar 24, 2013 at 11:56 am
    I'm running in to same use here, didn't find a proper way to handle it by
    now.

    But I managed to report this problem:
    https://github.com/spree/spree/issues/2740

    Guess this should attract some attention to this issue or help others.
    On Tuesday, March 12, 2013 8:42:36 PM UTC-7, Muhammad Aamir wrote:

    Hi,

    While deploying Spree on Heroku I am getting the following error:

    Could not find ransack-0.7.3 in any of the sources


    Is anybody else is experiencing the same problem?

    Thanks
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Muhammad Aamir at Mar 24, 2013 at 7:17 pm
    Hi,

    I was actually able to solve this problem. The gem although has been yanked
    but it is still available for download from rubygems site. After
    downloading I uploaded it to my Gemfury account and added this source in my
    Gemfile.

    Alternatively I think you can put it in vendor folder too (though I didn't
    personally test it).

    Thanks
    Muhammed Aamir

    On Sunday, March 24, 2013 4:56:19 PM UTC+5, Stan Lun wrote:

    I'm running in to same use here, didn't find a proper way to handle it by
    now.

    But I managed to report this problem:
    https://github.com/spree/spree/issues/2740

    Guess this should attract some attention to this issue or help others.
    On Tuesday, March 12, 2013 8:42:36 PM UTC-7, Muhammad Aamir wrote:

    Hi,

    While deploying Spree on Heroku I am getting the following error:

    Could not find ransack-0.7.3 in any of the sources


    Is anybody else is experiencing the same problem?

    Thanks
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Nate Lowrie at Mar 25, 2013 at 1:21 pm
    +1 on this. To expand on the solution:


    1. Put the following line in your Gemfile: *gem 'ransack', '0.7.2'*
    2. Run *bundle update ransack*
    3. Check your Gemfile and Gemfile.lock into source control

    Regards,

    Nate
    On Sunday, March 24, 2013 7:41:32 PM UTC-4, Ryan Bigg wrote:

    Please see my comment on #2740 for a solution.
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedMar 13, '13 at 3:42a
activeMar 25, '13 at 1:21p
posts10
users4
websitespreecommerce.com
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase