I'm attempting to setup an Authorize.Net gateway and having some trouble
even getting the gateway to connect to the service.

Can anyone give me some idea or point me to info on how to debug this? What
is the purpose of "test mode"? Are these transactions logged somewhere? Not
seeing them in the standard log file.

Also, what is AuthorizeNet:CIM, vs standard Authorize.Net? I see API
options of 'AIM' and 'SIM' from Authorize.Net info, but see no mention of
what "CIM" is.

thanks for any help

--
You received this message because you are subscribed to the Google Groups "Spree" group.
To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Randy Terbush at Mar 2, 2013 at 9:58 pm
    Ok, before I am further reprimanded (deservedly so) for not reading... I
    did stumble upon a few answers.

    I discovered a bit in the gateway docs that I had missed before which says:

    "You do not need to configure the URL for your gateway. The URL for your
    gateway provider is already known and the appropriate URL will be used
    based on the server setting in your configuration."

    Duh... Ok, so I am trying to connect to an EPN processing gateway using
    their Authorize.Net API. Therefore, the server connection is not happening
    because the code is smarter than me.

    It appears that the code in question is in the ActiveMerchant code. Should
    I simply be able to overload the test_url and live_url parameters to make
    this work?

    From active_merchant/lib/active_merchant/billing/gateways/authorize_net.rb
    self.test_url = "https://test.authorize.net/gateway/transact.dll"
    self.live_url = "https://secure.authorize.net/gateway/transact.dll"


    Can someone give me a hint as to where is the appropriate place to do this?
    My gut says config/initializers/spree.rb but prehaps there is somewhere
    more suited.

    Thanks
    On Saturday, March 2, 2013 1:30:51 PM UTC-7, Randy Terbush wrote:

    I'm attempting to setup an Authorize.Net gateway and having some trouble
    even getting the gateway to connect to the service.

    Can anyone give me some idea or point me to info on how to debug this?
    What is the purpose of "test mode"? Are these transactions logged
    somewhere? Not seeing them in the standard log file.

    Also, what is AuthorizeNet:CIM, vs standard Authorize.Net? I see API
    options of 'AIM' and 'SIM' from Authorize.Net info, but see no mention of
    what "CIM" is.

    thanks for any help
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Randy Terbush at Mar 3, 2013 at 9:57 pm
    So it seems that the following decorator now has my gateway config
    communicating with the EPN interface, but still seem to be failing a login.
    Nothing being logged with the test server account. Would still appreciate
    some suggestions as to how to debug this. Seeing the URL that is formed to
    send the request would be interesting. Seeing the response from the gateway
    would also be helpful.


    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    def initialize(options={})
    super
    @live_url = "https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    @test_url = "https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    end
    end


    On Saturday, March 2, 2013 5:35:09 PM UTC-7, Randy Terbush wrote:

    I'm currently trying to work with the following decorator to override
    these values for site urls.

    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    @live_url = "https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    @test_url = "https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    end


    No matter whether this file exists or not, if I sniff the network wire, I
    am not even seeing an attempt to connect to authorize.net servers or the
    servers I set in this file.

    Ideas?

    On Saturday, March 2, 2013 4:22:41 PM UTC-7, Randy Terbush wrote:

    FWIW, I've tried creating
    app/models/spree/authorizenetgateway_decorator.rb with the following with
    no success.

    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    self.test_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    self.live_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"


    end


    On Saturday, March 2, 2013 2:58:06 PM UTC-7, Randy Terbush wrote:

    Ok, before I am further reprimanded (deservedly so) for not reading... I
    did stumble upon a few answers.

    I discovered a bit in the gateway docs that I had missed before which
    says:

    "You do not need to configure the URL for your gateway. The URL for
    your gateway provider is already known and the appropriate URL will be
    used based on the server setting in your configuration."

    Duh... Ok, so I am trying to connect to an EPN processing gateway using
    their Authorize.Net API. Therefore, the server connection is not happening
    because the code is smarter than me.

    It appears that the code in question is in the ActiveMerchant code.
    Should I simply be able to overload the test_url and live_url parameters to
    make this work?

    From
    active_merchant/lib/active_merchant/billing/gateways/authorize_net.rb
    self.test_url = "https://test.authorize.net/gateway/transact.dll"
    self.live_url = "https://secure.authorize.net/gateway/transact.dll"


    Can someone give me a hint as to where is the appropriate place to do
    this? My gut says config/initializers/spree.rb but prehaps there is
    somewhere more suited.

    Thanks
    On Saturday, March 2, 2013 1:30:51 PM UTC-7, Randy Terbush wrote:

    I'm attempting to setup an Authorize.Net gateway and having some
    trouble even getting the gateway to connect to the service.

    Can anyone give me some idea or point me to info on how to debug this?
    What is the purpose of "test mode"? Are these transactions logged
    somewhere? Not seeing them in the standard log file.

    Also, what is AuthorizeNet:CIM, vs standard Authorize.Net? I see API
    options of 'AIM' and 'SIM' from Authorize.Net info, but see no mention of
    what "CIM" is.

    thanks for any help
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Randy Terbush at Mar 4, 2013 at 2:20 am
    To add a bit more debug info, attempts to complete a purchase are logging
    the following response from the EPN gateway. Code 0 seems to effectively be
    no response, however I am getting packets back from the gateway that I can
    see in the tcpdump trace. So the gateway is responding with something.

    Gateway Error
    --- !ruby/object:ActiveMerchant::Billing::Response
    params:
    response_code: 0
    response_reason_code:
    response_reason_text:
    avs_result_code:
    transaction_id:
    card_code:
    action: AUTH_ONLY
    message: ''
    success: false
    test: false
    authorization:
    fraud_review: false
    avs_result:
    code:
    message:
    street_match:
    postal_match:
    cvv_result:
    code:
    message:



    On Sunday, March 3, 2013 2:57:33 PM UTC-7, Randy Terbush wrote:

    So it seems that the following decorator now has my gateway config
    communicating with the EPN interface, but still seem to be failing a login.
    Nothing being logged with the test server account. Would still appreciate
    some suggestions as to how to debug this. Seeing the URL that is formed to
    send the request would be interesting. Seeing the response from the gateway
    would also be helpful.


    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    def initialize(options={})
    super
    @live_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    @test_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    end
    end


    On Saturday, March 2, 2013 5:35:09 PM UTC-7, Randy Terbush wrote:

    I'm currently trying to work with the following decorator to override
    these values for site urls.

    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    @live_url = "https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    @test_url = "https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    end


    No matter whether this file exists or not, if I sniff the network wire, I
    am not even seeing an attempt to connect to authorize.net servers or the
    servers I set in this file.

    Ideas?

    On Saturday, March 2, 2013 4:22:41 PM UTC-7, Randy Terbush wrote:

    FWIW, I've tried creating
    app/models/spree/authorizenetgateway_decorator.rb with the following with
    no success.

    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    self.test_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    self.live_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"


    end


    On Saturday, March 2, 2013 2:58:06 PM UTC-7, Randy Terbush wrote:

    Ok, before I am further reprimanded (deservedly so) for not reading...
    I did stumble upon a few answers.

    I discovered a bit in the gateway docs that I had missed before which
    says:

    "You do not need to configure the URL for your gateway. The URL for
    your gateway provider is already known and the appropriate URL will be
    used based on the server setting in your configuration."

    Duh... Ok, so I am trying to connect to an EPN processing gateway using
    their Authorize.Net API. Therefore, the server connection is not happening
    because the code is smarter than me.

    It appears that the code in question is in the ActiveMerchant code.
    Should I simply be able to overload the test_url and live_url parameters to
    make this work?

    From
    active_merchant/lib/active_merchant/billing/gateways/authorize_net.rb
    self.test_url = "https://test.authorize.net/gateway/transact.dll"
    self.live_url = "https://secure.authorize.net/gateway/transact.dll"


    Can someone give me a hint as to where is the appropriate place to do
    this? My gut says config/initializers/spree.rb but prehaps there is
    somewhere more suited.

    Thanks
    On Saturday, March 2, 2013 1:30:51 PM UTC-7, Randy Terbush wrote:

    I'm attempting to setup an Authorize.Net gateway and having some
    trouble even getting the gateway to connect to the service.

    Can anyone give me some idea or point me to info on how to debug this?
    What is the purpose of "test mode"? Are these transactions logged
    somewhere? Not seeing them in the standard log file.

    Also, what is AuthorizeNet:CIM, vs standard Authorize.Net? I see API
    options of 'AIM' and 'SIM' from Authorize.Net info, but see no mention of
    what "CIM" is.

    thanks for any help
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Randy Terbush at Mar 4, 2013 at 3:55 pm
    So I have dropped back and setup a test account with Authorize.Net and it
    seems the results reflect some problems in the past that were reported here
    about credit card number not getting passed. Yes, I am sending a test
    credit card number as specified by AN. Here is the result code I am seeing.

    Gateway Error
    --- !ruby/object:ActiveMerchant::Billing::Response
    params:
    response_code: 3
    response_reason_code: '33'
    response_reason_text: (TESTMODE) Credit card number is required.
    avs_result_code: P
    transaction_id: '0'
    card_code: ''
    action: AUTH_ONLY
    message: (TESTMODE) Credit card number is required
    success: false
    test: true
    authorization: '0'
    fraud_review: false
    avs_result:
    code: P
    message: Postal code matches, but street address not verified.
    street_match:
    postal_match: Y
    cvv_result:
    code:
    message:



    On Sunday, March 3, 2013 7:20:17 PM UTC-7, Randy Terbush wrote:

    To add a bit more debug info, attempts to complete a purchase are logging
    the following response from the EPN gateway. Code 0 seems to effectively be
    no response, however I am getting packets back from the gateway that I can
    see in the tcpdump trace. So the gateway is responding with something.

    Gateway Error
    --- !ruby/object:ActiveMerchant::Billing::Response
    params:
    response_code: 0
    response_reason_code:
    response_reason_text:
    avs_result_code:
    transaction_id:
    card_code:
    action: AUTH_ONLY
    message: ''
    success: false
    test: false
    authorization:
    fraud_review: false
    avs_result:
    code:
    message:
    street_match:
    postal_match:
    cvv_result:
    code:
    message:



    On Sunday, March 3, 2013 2:57:33 PM UTC-7, Randy Terbush wrote:

    So it seems that the following decorator now has my gateway config
    communicating with the EPN interface, but still seem to be failing a login.
    Nothing being logged with the test server account. Would still appreciate
    some suggestions as to how to debug this. Seeing the URL that is formed to
    send the request would be interesting. Seeing the response from the gateway
    would also be helpful.


    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    def initialize(options={})
    super
    @live_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    @test_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    end
    end


    On Saturday, March 2, 2013 5:35:09 PM UTC-7, Randy Terbush wrote:

    I'm currently trying to work with the following decorator to override
    these values for site urls.

    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    @live_url = "https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    @test_url = "https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    end


    No matter whether this file exists or not, if I sniff the network wire,
    I am not even seeing an attempt to connect to authorize.net servers or
    the servers I set in this file.

    Ideas?

    On Saturday, March 2, 2013 4:22:41 PM UTC-7, Randy Terbush wrote:

    FWIW, I've tried creating
    app/models/spree/authorizenetgateway_decorator.rb with the following with
    no success.

    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    self.test_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    self.live_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"


    end


    On Saturday, March 2, 2013 2:58:06 PM UTC-7, Randy Terbush wrote:

    Ok, before I am further reprimanded (deservedly so) for not reading...
    I did stumble upon a few answers.

    I discovered a bit in the gateway docs that I had missed before which
    says:

    "You do not need to configure the URL for your gateway. The URL for
    your gateway provider is already known and the appropriate URL will
    be used based on the server setting in your configuration."

    Duh... Ok, so I am trying to connect to an EPN processing gateway
    using their Authorize.Net API. Therefore, the server connection is not
    happening because the code is smarter than me.

    It appears that the code in question is in the ActiveMerchant code.
    Should I simply be able to overload the test_url and live_url parameters to
    make this work?

    From
    active_merchant/lib/active_merchant/billing/gateways/authorize_net.rb
    self.test_url = "https://test.authorize.net/gateway/transact.dll"
    self.live_url = "https://secure.authorize.net/gateway/transact.dll"


    Can someone give me a hint as to where is the appropriate place to do
    this? My gut says config/initializers/spree.rb but prehaps there is
    somewhere more suited.

    Thanks
    On Saturday, March 2, 2013 1:30:51 PM UTC-7, Randy Terbush wrote:

    I'm attempting to setup an Authorize.Net gateway and having some
    trouble even getting the gateway to connect to the service.

    Can anyone give me some idea or point me to info on how to debug
    this? What is the purpose of "test mode"? Are these transactions logged
    somewhere? Not seeing them in the standard log file.

    Also, what is AuthorizeNet:CIM, vs standard Authorize.Net? I see API
    options of 'AIM' and 'SIM' from Authorize.Net info, but see no mention of
    what "CIM" is.

    thanks for any help
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Randy Terbush at Mar 4, 2013 at 4:15 pm
    I have also just tried the Authorize.Net:CIM gateway and get similar
    results. However, some interesting points.

    Using the CIM gateway, I get passed to the confirm step of the checkout
    process. The payment information on that page shows a different credit card
    number from the one I am using for this transaction (last 4). I saw this
    same behavior when reporting problems with the Bogus gateway which I did
    not get a response to those questions.

    After confirming, I get a response from Spree that the payment could not be
    processed. HOWEVER, AN sends me an email that the transaction was approved.

    I'm at my wits end on this and would certainly appreciate some guidance
    here.

    On Monday, March 4, 2013 8:55:49 AM UTC-7, Randy Terbush wrote:

    So I have dropped back and setup a test account with Authorize.Net and it
    seems the results reflect some problems in the past that were reported here
    about credit card number not getting passed. Yes, I am sending a test
    credit card number as specified by AN. Here is the result code I am seeing.

    Gateway Error
    --- !ruby/object:ActiveMerchant::Billing::Response
    params:
    response_code: 3
    response_reason_code: '33'
    response_reason_text: (TESTMODE) Credit card number is required.
    avs_result_code: P
    transaction_id: '0'
    card_code: ''
    action: AUTH_ONLY
    message: (TESTMODE) Credit card number is required
    success: false
    test: true
    authorization: '0'
    fraud_review: false
    avs_result:
    code: P
    message: Postal code matches, but street address not verified.
    street_match:
    postal_match: Y
    cvv_result:
    code:
    message:



    On Sunday, March 3, 2013 7:20:17 PM UTC-7, Randy Terbush wrote:

    To add a bit more debug info, attempts to complete a purchase are logging
    the following response from the EPN gateway. Code 0 seems to effectively be
    no response, however I am getting packets back from the gateway that I can
    see in the tcpdump trace. So the gateway is responding with something.

    Gateway Error
    --- !ruby/object:ActiveMerchant::Billing::Response
    params:
    response_code: 0
    response_reason_code:
    response_reason_text:
    avs_result_code:
    transaction_id:
    card_code:
    action: AUTH_ONLY
    message: ''
    success: false
    test: false
    authorization:
    fraud_review: false
    avs_result:
    code:
    message:
    street_match:
    postal_match:
    cvv_result:
    code:
    message:



    On Sunday, March 3, 2013 2:57:33 PM UTC-7, Randy Terbush wrote:

    So it seems that the following decorator now has my gateway config
    communicating with the EPN interface, but still seem to be failing a login.
    Nothing being logged with the test server account. Would still appreciate
    some suggestions as to how to debug this. Seeing the URL that is formed to
    send the request would be interesting. Seeing the response from the gateway
    would also be helpful.


    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    def initialize(options={})
    super
    @live_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    @test_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    end
    end


    On Saturday, March 2, 2013 5:35:09 PM UTC-7, Randy Terbush wrote:

    I'm currently trying to work with the following decorator to override
    these values for site urls.

    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    @live_url = "https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl
    "
    @test_url = "https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl
    "
    end


    No matter whether this file exists or not, if I sniff the network wire,
    I am not even seeing an attempt to connect to authorize.net servers or
    the servers I set in this file.

    Ideas?

    On Saturday, March 2, 2013 4:22:41 PM UTC-7, Randy Terbush wrote:

    FWIW, I've tried creating
    app/models/spree/authorizenetgateway_decorator.rb with the following with
    no success.

    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    self.test_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    self.live_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"


    end


    On Saturday, March 2, 2013 2:58:06 PM UTC-7, Randy Terbush wrote:

    Ok, before I am further reprimanded (deservedly so) for not
    reading... I did stumble upon a few answers.

    I discovered a bit in the gateway docs that I had missed before which
    says:

    "You do not need to configure the URL for your gateway. The URL for
    your gateway provider is already known and the appropriate URL will
    be used based on the server setting in your configuration."

    Duh... Ok, so I am trying to connect to an EPN processing gateway
    using their Authorize.Net API. Therefore, the server connection is not
    happening because the code is smarter than me.

    It appears that the code in question is in the ActiveMerchant code.
    Should I simply be able to overload the test_url and live_url parameters to
    make this work?

    From
    active_merchant/lib/active_merchant/billing/gateways/authorize_net.rb
    self.test_url = "https://test.authorize.net/gateway/transact.dll"
    self.live_url = "https://secure.authorize.net/gateway/transact.dll"


    Can someone give me a hint as to where is the appropriate place to do
    this? My gut says config/initializers/spree.rb but prehaps there is
    somewhere more suited.

    Thanks
    On Saturday, March 2, 2013 1:30:51 PM UTC-7, Randy Terbush wrote:

    I'm attempting to setup an Authorize.Net gateway and having some
    trouble even getting the gateway to connect to the service.

    Can anyone give me some idea or point me to info on how to debug
    this? What is the purpose of "test mode"? Are these transactions logged
    somewhere? Not seeing them in the standard log file.

    Also, what is AuthorizeNet:CIM, vs standard Authorize.Net? I see API
    options of 'AIM' and 'SIM' from Authorize.Net info, but see no mention of
    what "CIM" is.

    thanks for any help
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Randy Terbush at Mar 4, 2013 at 4:24 pm
    More info:

    Created a new account and processed an order successfully. For some reason,
    it appears that credit card information from previous purchase attempts is
    somehow persisted and is being used in place of the current information
    provided.

    On Monday, March 4, 2013 9:15:10 AM UTC-7, Randy Terbush wrote:

    I have also just tried the Authorize.Net:CIM gateway and get similar
    results. However, some interesting points.

    Using the CIM gateway, I get passed to the confirm step of the checkout
    process. The payment information on that page shows a different credit card
    number from the one I am using for this transaction (last 4). I saw this
    same behavior when reporting problems with the Bogus gateway which I did
    not get a response to those questions.

    After confirming, I get a response from Spree that the payment could not
    be processed. HOWEVER, AN sends me an email that the transaction was
    approved.

    I'm at my wits end on this and would certainly appreciate some guidance
    here.

    On Monday, March 4, 2013 8:55:49 AM UTC-7, Randy Terbush wrote:

    So I have dropped back and setup a test account with Authorize.Net and it
    seems the results reflect some problems in the past that were reported here
    about credit card number not getting passed. Yes, I am sending a test
    credit card number as specified by AN. Here is the result code I am seeing.

    Gateway Error
    --- !ruby/object:ActiveMerchant::Billing::Response
    params:
    response_code: 3
    response_reason_code: '33'
    response_reason_text: (TESTMODE) Credit card number is required.
    avs_result_code: P
    transaction_id: '0'
    card_code: ''
    action: AUTH_ONLY
    message: (TESTMODE) Credit card number is required
    success: false
    test: true
    authorization: '0'
    fraud_review: false
    avs_result:
    code: P
    message: Postal code matches, but street address not verified.
    street_match:
    postal_match: Y
    cvv_result:
    code:
    message:



    On Sunday, March 3, 2013 7:20:17 PM UTC-7, Randy Terbush wrote:

    To add a bit more debug info, attempts to complete a purchase are
    logging the following response from the EPN gateway. Code 0 seems to
    effectively be no response, however I am getting packets back from the
    gateway that I can see in the tcpdump trace. So the gateway is responding
    with something.

    Gateway Error
    --- !ruby/object:ActiveMerchant::Billing::Response
    params:
    response_code: 0
    response_reason_code:
    response_reason_text:
    avs_result_code:
    transaction_id:
    card_code:
    action: AUTH_ONLY
    message: ''
    success: false
    test: false
    authorization:
    fraud_review: false
    avs_result:
    code:
    message:
    street_match:
    postal_match:
    cvv_result:
    code:
    message:



    On Sunday, March 3, 2013 2:57:33 PM UTC-7, Randy Terbush wrote:

    So it seems that the following decorator now has my gateway config
    communicating with the EPN interface, but still seem to be failing a login.
    Nothing being logged with the test server account. Would still appreciate
    some suggestions as to how to debug this. Seeing the URL that is formed to
    send the request would be interesting. Seeing the response from the gateway
    would also be helpful.


    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    def initialize(options={})
    super
    @live_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    @test_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    end
    end


    On Saturday, March 2, 2013 5:35:09 PM UTC-7, Randy Terbush wrote:

    I'm currently trying to work with the following decorator to override
    these values for site urls.

    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    @live_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    @test_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    end


    No matter whether this file exists or not, if I sniff the network
    wire, I am not even seeing an attempt to connect to authorize.netservers or the servers I set in this file.

    Ideas?

    On Saturday, March 2, 2013 4:22:41 PM UTC-7, Randy Terbush wrote:

    FWIW, I've tried creating
    app/models/spree/authorizenetgateway_decorator.rb with the following with
    no success.

    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    self.test_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    self.live_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"


    end


    On Saturday, March 2, 2013 2:58:06 PM UTC-7, Randy Terbush wrote:

    Ok, before I am further reprimanded (deservedly so) for not
    reading... I did stumble upon a few answers.

    I discovered a bit in the gateway docs that I had missed before
    which says:

    "You do not need to configure the URL for your gateway. The URL for
    your gateway provider is already known and the appropriate URL will
    be used based on the server setting in your configuration."

    Duh... Ok, so I am trying to connect to an EPN processing gateway
    using their Authorize.Net API. Therefore, the server connection is not
    happening because the code is smarter than me.

    It appears that the code in question is in the ActiveMerchant code.
    Should I simply be able to overload the test_url and live_url parameters to
    make this work?

    From
    active_merchant/lib/active_merchant/billing/gateways/authorize_net.rb
    self.test_url = "https://test.authorize.net/gateway/transact.dll"
    self.live_url = "https://secure.authorize.net/gateway/transact.dll"


    Can someone give me a hint as to where is the appropriate place to
    do this? My gut says config/initializers/spree.rb but prehaps there is
    somewhere more suited.

    Thanks
    On Saturday, March 2, 2013 1:30:51 PM UTC-7, Randy Terbush wrote:

    I'm attempting to setup an Authorize.Net gateway and having some
    trouble even getting the gateway to connect to the service.

    Can anyone give me some idea or point me to info on how to debug
    this? What is the purpose of "test mode"? Are these transactions logged
    somewhere? Not seeing them in the standard log file.

    Also, what is AuthorizeNet:CIM, vs standard Authorize.Net? I see
    API options of 'AIM' and 'SIM' from Authorize.Net info, but see no mention
    of what "CIM" is.

    thanks for any help
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Randy Terbush at Mar 4, 2013 at 7:25 pm
    I've logged an issue for this on the github.

    It appears that after the first successful attempt on a new account,
    subsequent attempts to process payment send a zero length credit card
    number.

    Anxiously waiting to resolve this...

    On Monday, March 4, 2013 9:24:45 AM UTC-7, Randy Terbush wrote:

    More info:

    Created a new account and processed an order successfully. For some
    reason, it appears that credit card information from previous purchase
    attempts is somehow persisted and is being used in place of the current
    information provided.

    On Monday, March 4, 2013 9:15:10 AM UTC-7, Randy Terbush wrote:

    I have also just tried the Authorize.Net:CIM gateway and get similar
    results. However, some interesting points.

    Using the CIM gateway, I get passed to the confirm step of the checkout
    process. The payment information on that page shows a different credit card
    number from the one I am using for this transaction (last 4). I saw this
    same behavior when reporting problems with the Bogus gateway which I did
    not get a response to those questions.

    After confirming, I get a response from Spree that the payment could not
    be processed. HOWEVER, AN sends me an email that the transaction was
    approved.

    I'm at my wits end on this and would certainly appreciate some guidance
    here.

    On Monday, March 4, 2013 8:55:49 AM UTC-7, Randy Terbush wrote:

    So I have dropped back and setup a test account with Authorize.Net and
    it seems the results reflect some problems in the past that were reported
    here about credit card number not getting passed. Yes, I am sending a test
    credit card number as specified by AN. Here is the result code I am seeing.

    Gateway Error
    --- !ruby/object:ActiveMerchant::Billing::Response
    params:
    response_code: 3
    response_reason_code: '33'
    response_reason_text: (TESTMODE) Credit card number is required.
    avs_result_code: P
    transaction_id: '0'
    card_code: ''
    action: AUTH_ONLY
    message: (TESTMODE) Credit card number is required
    success: false
    test: true
    authorization: '0'
    fraud_review: false
    avs_result:
    code: P
    message: Postal code matches, but street address not verified.
    street_match:
    postal_match: Y
    cvv_result:
    code:
    message:



    On Sunday, March 3, 2013 7:20:17 PM UTC-7, Randy Terbush wrote:

    To add a bit more debug info, attempts to complete a purchase are
    logging the following response from the EPN gateway. Code 0 seems to
    effectively be no response, however I am getting packets back from the
    gateway that I can see in the tcpdump trace. So the gateway is responding
    with something.

    Gateway Error
    --- !ruby/object:ActiveMerchant::Billing::Response
    params:
    response_code: 0
    response_reason_code:
    response_reason_text:
    avs_result_code:
    transaction_id:
    card_code:
    action: AUTH_ONLY
    message: ''
    success: false
    test: false
    authorization:
    fraud_review: false
    avs_result:
    code:
    message:
    street_match:
    postal_match:
    cvv_result:
    code:
    message:



    On Sunday, March 3, 2013 2:57:33 PM UTC-7, Randy Terbush wrote:

    So it seems that the following decorator now has my gateway config
    communicating with the EPN interface, but still seem to be failing a login.
    Nothing being logged with the test server account. Would still appreciate
    some suggestions as to how to debug this. Seeing the URL that is formed to
    send the request would be interesting. Seeing the response from the gateway
    would also be helpful.


    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    def initialize(options={})
    super
    @live_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    @test_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    end
    end


    On Saturday, March 2, 2013 5:35:09 PM UTC-7, Randy Terbush wrote:

    I'm currently trying to work with the following decorator to override
    these values for site urls.

    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    @live_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    @test_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    end


    No matter whether this file exists or not, if I sniff the network
    wire, I am not even seeing an attempt to connect to authorize.netservers or the servers I set in this file.

    Ideas?

    On Saturday, March 2, 2013 4:22:41 PM UTC-7, Randy Terbush wrote:

    FWIW, I've tried creating
    app/models/spree/authorizenetgateway_decorator.rb with the following with
    no success.

    ActiveMerchant::Billing::AuthorizeNetGateway.class_eval do

    self.test_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"
    self.live_url = "
    https://www.eprocessingnetwork.com/cgi-bin/an/transact.pl"


    end


    On Saturday, March 2, 2013 2:58:06 PM UTC-7, Randy Terbush wrote:

    Ok, before I am further reprimanded (deservedly so) for not
    reading... I did stumble upon a few answers.

    I discovered a bit in the gateway docs that I had missed before
    which says:

    "You do not need to configure the URL for your gateway. The URL for
    your gateway provider is already known and the appropriate URL will
    be used based on the server setting in your configuration."

    Duh... Ok, so I am trying to connect to an EPN processing gateway
    using their Authorize.Net API. Therefore, the server connection is not
    happening because the code is smarter than me.

    It appears that the code in question is in the ActiveMerchant code.
    Should I simply be able to overload the test_url and live_url parameters to
    make this work?

    From
    active_merchant/lib/active_merchant/billing/gateways/authorize_net.rb
    self.test_url = "https://test.authorize.net/gateway/transact.dll"
    self.live_url = "https://secure.authorize.net/gateway/transact.dll"


    Can someone give me a hint as to where is the appropriate place to
    do this? My gut says config/initializers/spree.rb but prehaps there is
    somewhere more suited.

    Thanks
    On Saturday, March 2, 2013 1:30:51 PM UTC-7, Randy Terbush wrote:

    I'm attempting to setup an Authorize.Net gateway and having some
    trouble even getting the gateway to connect to the service.

    Can anyone give me some idea or point me to info on how to debug
    this? What is the purpose of "test mode"? Are these transactions logged
    somewhere? Not seeing them in the standard log file.

    Also, what is AuthorizeNet:CIM, vs standard Authorize.Net? I see
    API options of 'AIM' and 'SIM' from Authorize.Net info, but see no mention
    of what "CIM" is.

    thanks for any help
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedMar 2, '13 at 8:30p
activeMar 4, '13 at 7:25p
posts8
users1
websitespreecommerce.com
irc#RubyOnRails

1 user in discussion

Randy Terbush: 8 posts

People

Translate

site design / logo © 2022 Grokbase