Hi Alex,
The S3 settings can now be configured in spree (from 1.3 upwards I think).
I migrated from 1.0 to 1.3 and had a view like yours where I ticked the
checkbox for S3 but *didn't* see the extra fields appear to put the S3
settings.

My problem was missing *missing jquery loading from
app/assets/javascript/admin/all.js (and the store too - which solved an
old problem I never figured out too).*
*
*
*I think I also had to add *
gem 'jquery-rails'

*to my gemfile*

If you need a better explanation of that, let me know. Still waking up here
:-)
--
Steve
On Wednesday, February 13, 2013 4:18:30 AM UTC, Alex Aguilar wrote:

In config/initializers/spree.rb I tried checking the development
environment.

if Rails.env.development? or Rails.env.production?
config.use_s3 = true
config.s3_bucket = '<bucket>'
config.s3_access_key = "<key>"
config.s3_secret = "<secret>"
end

but doesn't seem to be enough as the issue appears to be the :rails_root
setting.

Spree config
http://www.screencast.com/t/n8keX2wG

Folders created on S3
http://www.screencast.com/t/YvguEFfKbs

Thanks in advance.
Alex
--
You received this message because you are subscribed to the Google Groups "Spree" group.
To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Steve Root at Feb 13, 2013 at 7:57 am
    My all.js file in case it helps:
    // This is a manifest file that'll be compiled into including all the files
    listed below.
    // Add new JavaScript/Coffee code in separate files in this directory and
    they'll automatically
    // be included in the compiled file accessible from
    http://example.com/assets/application.js
    // It's not advisable to add code directly here, but if you do, it'll
    appear at the bottom of the
    // the compiled file.
    //
    //= require jquery
    //= require jquery_ujs


    //= require admin/spree_core
    //= require admin/spree_auth
    //= require admin/spree_promo


    //= require_tree .

    On Wednesday, February 13, 2013 7:55:11 AM UTC, Steve Root wrote:

    Hi Alex,
    The S3 settings can now be configured in spree (from 1.3 upwards I think).
    I migrated from 1.0 to 1.3 and had a view like yours where I ticked the
    checkbox for S3 but *didn't* see the extra fields appear to put the S3
    settings.

    My problem was missing *missing jquery loading from
    app/assets/javascript/admin/all.js (and the store too - which solved an
    old problem I never figured out too).*
    *
    *
    *I think I also had to add *
    gem 'jquery-rails'

    *to my gemfile*

    If you need a better explanation of that, let me know. Still waking up
    here :-)
    --
    Steve
    On Wednesday, February 13, 2013 4:18:30 AM UTC, Alex Aguilar wrote:

    In config/initializers/spree.rb I tried checking the development
    environment.

    if Rails.env.development? or Rails.env.production?
    config.use_s3 = true
    config.s3_bucket = '<bucket>'
    config.s3_access_key = "<key>"
    config.s3_secret = "<secret>"
    end

    but doesn't seem to be enough as the issue appears to be the :rails_root
    setting.

    Spree config
    http://www.screencast.com/t/n8keX2wG

    Folders created on S3
    http://www.screencast.com/t/YvguEFfKbs

    Thanks in advance.
    Alex
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Alex Aguilar at Feb 13, 2013 at 6:59 pm
    Hi Steve,

    Thanks for your reply. The problem I'm having is that I cannot see images
    in dev (local) environment. http://www.screencast.com/t/FOP2kvWVc1Fq

    And I believe it's because the rails_root setting changes from our
    production / staging environments on Heroku vs our local paths (OS X for me
    and Ubunutu for my coworker)

    Folders created on S3
    http://www.screencast.com/t/YvguEFfKbs

    So my question is what am I missing in my config in order to see images
    correctly (from AWS S3) in my local environment.

    Thanks,
    Alex

    On Wednesday, February 13, 2013 2:57:04 AM UTC-5, Steve Root wrote:

    My all.js file in case it helps:
    // This is a manifest file that'll be compiled into including all the
    files listed below.
    // Add new JavaScript/Coffee code in separate files in this directory and
    they'll automatically
    // be included in the compiled file accessible from
    http://example.com/assets/application.js
    // It's not advisable to add code directly here, but if you do, it'll
    appear at the bottom of the
    // the compiled file.
    //
    //= require jquery
    //= require jquery_ujs


    //= require admin/spree_core
    //= require admin/spree_auth
    //= require admin/spree_promo


    //= require_tree .

    On Wednesday, February 13, 2013 7:55:11 AM UTC, Steve Root wrote:

    Hi Alex,
    The S3 settings can now be configured in spree (from 1.3 upwards I think).
    I migrated from 1.0 to 1.3 and had a view like yours where I ticked the
    checkbox for S3 but *didn't* see the extra fields appear to put the S3
    settings.

    My problem was missing *missing jquery loading from
    app/assets/javascript/admin/all.js (and the store too - which solved an
    old problem I never figured out too).*
    *
    *
    *I think I also had to add *
    gem 'jquery-rails'

    *to my gemfile*

    If you need a better explanation of that, let me know. Still waking up
    here :-)
    --
    Steve
    On Wednesday, February 13, 2013 4:18:30 AM UTC, Alex Aguilar wrote:

    In config/initializers/spree.rb I tried checking the development
    environment.

    if Rails.env.development? or Rails.env.production?
    config.use_s3 = true
    config.s3_bucket = '<bucket>'
    config.s3_access_key = "<key>"
    config.s3_secret = "<secret>"
    end

    but doesn't seem to be enough as the issue appears to be the :rails_root
    setting.

    Spree config
    http://www.screencast.com/t/n8keX2wG

    Folders created on S3
    http://www.screencast.com/t/YvguEFfKbs

    Thanks in advance.
    Alex
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedFeb 13, '13 at 7:55a
activeFeb 13, '13 at 6:59p
posts3
users2
websitespreecommerce.com
irc#RubyOnRails

2 users in discussion

Steve Root: 2 posts Alex Aguilar: 1 post

People

Translate

site design / logo © 2022 Grokbase