Try changing initializers/spree.rb to have

Spree.user_class = "Spree::User"

instead of

Spree.user_class = "Spree::LegacyUser"
On Monday, July 9, 2012 6:12:14 PM UTC-4, Ryan Bigg wrote:

Without SSL being enabled by default in production, your login page is
subject to Man-in-the-middle attacks. This is not a problem that is unique
to Spree, but rather all web applications. Login should be done through
SSL.

On Monday, 9 July 2012 at 7:18 PM, Nikolay Ponomarev wrote:

I had the same issue
fixed this by adding:

../config/initilizers/spree.rb
Spree.config do |config|
config.allow_ssl_in_production = false #This line
end

And I also thinks it's bad idea turn ssl on default to true.

--
You received this message because you are subscribed to the Google Groups
"Spree" group.
To view this discussion on the web visit
https://groups.google.com/d/msg/spree-user/-/er9AHMBBvuYJ.
To post to this group, send email to spree...@googlegroups.com<javascript:>
.
To unsubscribe from this group, send email to
spree-user+...@googlegroups.com <javascript:>.
For more options, visit this group at
http://groups.google.com/group/spree-user?hl=en.

--
You received this message because you are subscribed to the Google Groups "Spree" group.
To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedFeb 4, '13 at 9:05p
activeFeb 4, '13 at 9:05p
posts1
users1
websitespreecommerce.com
irc#RubyOnRails

1 user in discussion

Scott Ringwelski: 1 post

People

Translate

site design / logo © 2022 Grokbase