After installing a clean 1.3.1 Spree version in a clean rvm gemset the
front end worked well.

However, on the admin pages you were not allowed to delete anything
(orders, products, ...) because the messagebox asking for confirmation
did'nt work properly
(on first confirmation click, it did nothing, on second click it caused a
page error report a<biut being unable to use the 'show action').

Some other strange thing happened when trying to edit an order. The field
to add a new sku for the order did not exist.

Any clues on what could be wrong.

Thank in advance for any suggestions or help. Best regards,

Antonio

--
You received this message because you are subscribed to the Google Groups "Spree" group.
To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Jet at Jan 31, 2013 at 9:45 pm
    Are you using:

    gem 'jquery-rails', '~> 2.1.4'

    Jet
    On Thursday, January 31, 2013 1:35:48 PM UTC-8, antoniov wrote:

    After installing a clean 1.3.1 Spree version in a clean rvm gemset the
    front end worked well.

    However, on the admin pages you were not allowed to delete anything
    (orders, products, ...) because the messagebox asking for confirmation
    did'nt work properly
    (on first confirmation click, it did nothing, on second click it caused a
    page error report a<biut being unable to use the 'show action').

    Some other strange thing happened when trying to edit an order. The field
    to add a new sku for the order did not exist.

    Any clues on what could be wrong.

    Thank in advance for any suggestions or help. Best regards,

    Antonio
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Antoniov at Jan 31, 2013 at 10:00 pm
    Thanks for the suggestion. I did change to gem 'jquery-rails', '~> 2.1.4'
    and that allowed me to delete things.

    However, I still can not add new line items when editing orders,
    and in addition to that I discovered that I cannot see (even less edit) the
    Tree in the edit taxonomies page.
    I read another post with this last problem (and in that post changing to
    gem 'jquery-rails', '~> 2.1.4' seemed to fix the problem.
    Unfortunately I still have this problem around

    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ryan Bigg at Feb 1, 2013 at 12:17 am
    Please show us your Gemfile.


    On Fri, Feb 1, 2013 at 9:00 AM, antoniov
    wrote:
    Thanks for the suggestion. I did change to gem 'jquery-rails', '~>
    2.1.4' and that allowed me to delete things.

    However, I still can not add new line items when editing orders,
    and in addition to that I discovered that I cannot see (even less edit)
    the Tree in the edit taxonomies page.
    I read another post with this last problem (and in that post changing to
    gem 'jquery-rails', '~> 2.1.4' seemed to fix the problem.
    Unfortunately I still have this problem around

    --
    You received this message because you are subscribed to the Google Groups
    "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Antonio Velázquez at Feb 1, 2013 at 6:19 pm
    You are right Steve. It was your post.

    I discovered there the need for updating gemfile to gem 'jquery-rails',
    '~> 2.1.4', and with that part of my problems disappeared (the inability to
    delete things -products, option types, ... - ).

    However some others remained : The field to add new lineitems when editing
    an order from the admin pages does'nt work.

    And I discovered a new problem in your post : I cannot view, much less
    edit, the Taxonomy trees. This problem I still have, even after updating
    gemfile to gem 'jquery-rails', '~> 2.1.4',.

    Do you have any of these problems ? Did you make any other changes to the
    gemfile or config?

    Thank you for your care.

    Antonio


    2013/2/1 Steve Root <steve@rkbb.co.uk>
    That post was probably my post.
    updating gemfile to gem 'jquery-rails', '~> 2.1.4'
    checking that jquery was required in
    app/assets/spree/javascript/admin/all.css (and the store/all.css too)

    It was immediate on my development machine but I think my browser cached
    the files so it didn't work on my production site until I tried on a new
    browser.


    On Thursday, January 31, 2013 10:00:16 PM UTC, antoniov wrote:

    Thanks for the suggestion. I did change to gem 'jquery-rails', '~>
    2.1.4' and that allowed me to delete things.

    However, I still can not add new line items when editing orders,
    and in addition to that I discovered that I cannot see (even less edit)
    the Tree in the edit taxonomies page.
    I read another post with this last problem (and in that post changing to
    gem 'jquery-rails', '~> 2.1.4' seemed to fix the problem.
    Unfortunately I still have this problem around
    --
    You received this message because you are subscribed to the Google Groups
    "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Vinni at Feb 23, 2013 at 10:30 pm

    On Friday, 1 February 2013 14:19:31 UTC-4, antoniov wrote:
    You are right Steve. It was your post.

    I discovered there the need for updating gemfile to gem 'jquery-rails',
    '~> 2.1.4', and with that part of my problems disappeared (the inability to
    delete things -products, option types, ... - ).

    However some others remained : The field to add new lineitems when editing
    an order from the admin pages does'nt work.

    And I discovered a new problem in your post : I cannot view, much less
    edit, the Taxonomy trees. This problem I still have, even after updating
    gemfile to gem 'jquery-rails', '~> 2.1.4',.

    Do you have any of these problems ? Did you make any other changes to the
    gemfile or config?

    Thank you for your care.

    Antonio


    2013/2/1 Steve Root <st...@rkbb.co.uk <javascript:>>
    That post was probably my post.
    updating gemfile to gem 'jquery-rails', '~> 2.1.4'
    checking that jquery was required in
    app/assets/spree/javascript/admin/all.css (and the store/all.css too)

    It was immediate on my development machine but I think my browser cached
    the files so it didn't work on my production site until I tried on a new
    browser.


    On Thursday, January 31, 2013 10:00:16 PM UTC, antoniov wrote:

    Thanks for the suggestion. I did change to gem 'jquery-rails', '~>
    2.1.4' and that allowed me to delete things.

    However, I still can not add new line items when editing orders,
    and in addition to that I discovered that I cannot see (even less edit)
    the Tree in the edit taxonomies page.
    I read another post with this last problem (and in that post changing to
    gem 'jquery-rails', '~> 2.1.4' seemed to fix the problem.
    Unfortunately I still have this problem around
    --
    You received this message because you are subscribed to the Google Groups
    "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to spree-user+...@googlegroups.com <javascript:>.
    For more options, visit https://groups.google.com/groups/opt_out.

    Hi Antonio,

    I have the sam problem. Were you able to get yours resolved?

    Vinni

    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Vinni at Feb 24, 2013 at 12:00 am

    On Saturday, 23 February 2013 16:01:33 UTC-4, vinni wrote:

    On Friday, 1 February 2013 14:19:31 UTC-4, antoniov wrote:

    You are right Steve. It was your post.

    I discovered there the need for updating gemfile to gem 'jquery-rails',
    '~> 2.1.4', and with that part of my problems disappeared (the inability to
    delete things -products, option types, ... - ).

    However some others remained : The field to add new lineitems when
    editing an order from the admin pages does'nt work.

    And I discovered a new problem in your post : I cannot view, much less
    edit, the Taxonomy trees. This problem I still have, even after updating
    gemfile to gem 'jquery-rails', '~> 2.1.4',.

    Do you have any of these problems ? Did you make any other changes to the
    gemfile or config?

    Thank you for your care.

    Antonio


    2013/2/1 Steve Root <st...@rkbb.co.uk>
    That post was probably my post.
    updating gemfile to gem 'jquery-rails', '~> 2.1.4'
    checking that jquery was required in
    app/assets/spree/javascript/admin/all.css (and the store/all.css too)

    It was immediate on my development machine but I think my browser cached
    the files so it didn't work on my production site until I tried on a new
    browser.


    On Thursday, January 31, 2013 10:00:16 PM UTC, antoniov wrote:

    Thanks for the suggestion. I did change to gem 'jquery-rails', '~>
    2.1.4' and that allowed me to delete things.

    However, I still can not add new line items when editing orders,
    and in addition to that I discovered that I cannot see (even less edit)
    the Tree in the edit taxonomies page.
    I read another post with this last problem (and in that post changing
    to gem 'jquery-rails', '~> 2.1.4' seemed to fix the problem.
    Unfortunately I still have this problem around
    --
    You received this message because you are subscribed to the Google
    Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to spree-user+...@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

    Hi Antonio,

    I have the same problem. Were you able to get yours resolved?

    Vinni
    --
    You received this message because you are subscribed to the Google Groups "Spree" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to spree-user+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedJan 31, '13 at 9:35p
activeFeb 24, '13 at 12:00a
posts7
users4
websitespreecommerce.com
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase