Thanks a lot Ryan.
Let me explain what I was trying to do. I wanted to install spree_gateway
on the sandbox application of a spree 1.3.1 -sourcecode app. The spree
version number (on the SPREE_VERSION file ) is 2.0.0.beta, even when I
downloaded the sourcecode form git expecting to get 1.3.1. My guess was
that the origin of the conflict was that bundle might not consider beta
versions (spree_core 2.0.beta) adequate to "cover" the needs of
spree_gateway, wich depends on spree_core ~>1.0., even when the number of
the 2.0 version is higher, but ours is a beta. Probably this thinking of
mine is very confused, but that was my guess
Please find below my gemfile:
gem 'rails', '3.2.11'
# Bundle edge Rails instead:
# gem 'rails', :git => 'git://github.com/rails/rails.git'
# Gems used only for assets and not required
# in production environments by default.
group :assets do
gem 'sass-rails', '~> 3.2.3'
gem 'coffee-rails', '~> 3.2.1'
# See https://github.com/sstephenson/execjs#readme
for more supported
# gem 'therubyracer', :platforms => :ruby
gem 'uglifier', '>= 1.0.3'
# To use ActiveModel has_secure_password
# gem 'bcrypt-ruby', '~> 3.0.0'
# To use Jbuilder templates for JSON
# gem 'jbuilder'
# Use unicorn as the app server
# gem 'unicorn'
# Deploy with Capistrano
# gem 'capistrano'
# To use debugger
# gem 'debugger'
gem 'spree', :path => '..'
gem 'spree_auth_devise', :github => 'spree/spree_auth_devise', :branch =>
gem 'spree_gateway', :git => 'git://github.com/spree/spree_gateway.git',
:branch => "1-3-stable" # make sure to include after spree
El jueves, 24 de enero de 2013 20:36:52 UTC+1, Ryan Bigg escribió:
Please show us your complete Gemfile
When trying to install spree_gateway in spree 1-3-1 gem (spree version
2.0.0.beta), following these instructions on github ( add the following
line to Gemfile :
gem 'spree_gateway', :git => 'git://github.com/spree/spree_gateway.git', :branch => "1-1-stable" # make sure to include after spree
I get this error when trying bundle install :
Fetching gem metadata from https://rubygems.org/.......
Fetching gem metadata from https://rubygems.org/..
Bundler could not find compatible versions for gem "spree_core":
spree_gateway (>= 0) ruby depends on
spree_core (~> 1.0) ruby
spree (>= 0) ruby depends on
I guess it has something to do with my spree_core gem being a beta
version, however, I'm not sure.
I want to use the spree downloaded code to study itś internal workings,
and I used this 2.0.0.beta version because it was the last one available on
github, and the git version with tag 1.3.1 gave errors to me ( ... missing
translations for succesful login, ... missing product images when trying to
edit an order by adding additional line_items from the admin
interface,...), while the 2.0.0.beta ammended some of those errors).
Any suggestions on how to proceed ? Perhaps it is not possible to add
new gems over the downloaded spree gems ? Should I try with a different
version? How to face this type of version conflicts when installing
Thank you very much for your care and suggestions.