Hi

I am using webdriver 2.25 with java. I am trying to automate a page where
there are 4 textboxes and a submit button.
In the textboxes, I provide username, password, confirm password and mobile
number respectively and they click on 'Join' button.
My problem over here is my script is able to click the 'Join' button
because I see 'In Progress' sysmbol to appear on the screen after the
'Join' button is clicked. But the 'In Progress' bar just appears and
disappears and the page is not navigated to the next page. It just stays on
the current sign-up page.

When I try this functionality manually, after clicking the 'Join' button, I
am able to navigate to the next page. I added wait also in my script, but
it just stays in the current page and my script fails with error 'Timeout
looking for element 'XYZ'' where "XYZ" is an element in the next page which
I am supposed to select.

Can somebody please help me with this issue?

Thanks in advance!

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To post to this group, send email to selenium-users@googlegroups.com.
To unsubscribe from this group, send email to selenium-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msg/selenium-users/-/gFWM77v_N9YJ.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Karthik Kulkarni at Nov 26, 2012 at 8:46 am
    Put the code here and the DOM excerpt . I guess der is a java script being
    called on clicking join


    On Mon, Nov 26, 2012 at 1:47 PM, Automation User
    wrote:
    Hi

    I am using webdriver 2.25 with java. I am trying to automate a page where
    there are 4 textboxes and a submit button.
    In the textboxes, I provide username, password, confirm password and
    mobile number respectively and they click on 'Join' button.
    My problem over here is my script is able to click the 'Join' button
    because I see 'In Progress' sysmbol to appear on the screen after the
    'Join' button is clicked. But the 'In Progress' bar just appears and
    disappears and the page is not navigated to the next page. It just stays on
    the current sign-up page.

    When I try this functionality manually, after clicking the 'Join' button,
    I am able to navigate to the next page. I added wait also in my script, but
    it just stays in the current page and my script fails with error 'Timeout
    looking for element 'XYZ'' where "XYZ" is an element in the next page which
    I am supposed to select.

    Can somebody please help me with this issue?

    Thanks in advance!

    --
    You received this message because you are subscribed to the Google Groups
    "Selenium Users" group.
    To post to this group, send email to selenium-users@googlegroups.com.
    To unsubscribe from this group, send email to
    selenium-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/selenium-users/-/gFWM77v_N9YJ.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Selenium Users" group.
    To post to this group, send email to selenium-users@googlegroups.com.
    To unsubscribe from this group, send email to selenium-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Pavan at Jan 8, 2013 at 5:17 pm
    Hi,

    I am facing the same issue like yours. Have you resolved this issue? If
    yes, could you please share what you did to fix this issue?

    Thanks!
    On Monday, November 26, 2012 2:17:01 AM UTC-6, Automation User wrote:

    Hi

    I am using webdriver 2.25 with java. I am trying to automate a page where
    there are 4 textboxes and a submit button.
    In the textboxes, I provide username, password, confirm password and
    mobile number respectively and they click on 'Join' button.
    My problem over here is my script is able to click the 'Join' button
    because I see 'In Progress' sysmbol to appear on the screen after the
    'Join' button is clicked. But the 'In Progress' bar just appears and
    disappears and the page is not navigated to the next page. It just stays on
    the current sign-up page.

    When I try this functionality manually, after clicking the 'Join' button,
    I am able to navigate to the next page. I added wait also in my script, but
    it just stays in the current page and my script fails with error 'Timeout
    looking for element 'XYZ'' where "XYZ" is an element in the next page which
    I am supposed to select.

    Can somebody please help me with this issue?

    Thanks in advance!
    --
    You received this message because you are subscribed to the Google Groups "Selenium Users" group.
    To post to this group, send email to selenium-users@googlegroups.com.
    To unsubscribe from this group, send email to selenium-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msg/selenium-users/-/yuph2ItBKakJ.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Santosh Hulisandra Srikanta at Jan 8, 2013 at 4:53 pm
    is that a cross domain HTTP request.
    where on click it navigates to a page of different domain.?

    /Santosh
    On Tue, Jan 8, 2013 at 9:39 PM, Pavan wrote:

    Hi,

    I am facing the same issue like yours. Have you resolved this issue? If
    yes, could you please share what you did to fix this issue?

    Thanks!
    On Monday, November 26, 2012 2:17:01 AM UTC-6, Automation User wrote:

    Hi

    I am using webdriver 2.25 with java. I am trying to automate a page where
    there are 4 textboxes and a submit button.
    In the textboxes, I provide username, password, confirm password and
    mobile number respectively and they click on 'Join' button.
    My problem over here is my script is able to click the 'Join' button
    because I see 'In Progress' sysmbol to appear on the screen after the
    'Join' button is clicked. But the 'In Progress' bar just appears and
    disappears and the page is not navigated to the next page. It just stays on
    the current sign-up page.

    When I try this functionality manually, after clicking the 'Join' button,
    I am able to navigate to the next page. I added wait also in my script, but
    it just stays in the current page and my script fails with error 'Timeout
    looking for element 'XYZ'' where "XYZ" is an element in the next page which
    I am supposed to select.

    Can somebody please help me with this issue?

    Thanks in advance!
    --
    You received this message because you are subscribed to the Google Groups
    "Selenium Users" group.
    To post to this group, send email to selenium-users@googlegroups.com.
    To unsubscribe from this group, send email to
    selenium-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/selenium-users/-/yuph2ItBKakJ.
    For more options, visit https://groups.google.com/groups/opt_out.



    --

    /Santosh

    --
    You received this message because you are subscribed to the Google Groups "Selenium Users" group.
    To post to this group, send email to selenium-users@googlegroups.com.
    To unsubscribe from this group, send email to selenium-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupselenium-users @
categoriesselenium
postedNov 26, '12 at 8:17a
activeJan 8, '13 at 5:17p
posts4
users4
websiteseleniumhq.org

People

Translate

site design / logo © 2022 Grokbase