Hi,

Button is not getting clicked in IE.

When did same in Firefox, it works fine. Please suggest some work around.

Thanks and Regards,
Neha

--
You received this message because you are subscribed to the Google Groups "Selenium Users" group.
To post to this group, send email to selenium-users@googlegroups.com.
To unsubscribe from this group, send email to selenium-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msg/selenium-users/-/7HvY4SH-hiAJ.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Sateesh babu at Sep 11, 2012 at 12:16 pm
    Hi Neha,


    Can you tell me the exact scenario?

    Better to use wait command before click on button.

    driver.manage().timeouts().implicitlyWait(5,TimeUnit.SECONDS);

    driver.findElement(By.id("Button")).click();

    On Tue, Sep 11, 2012 at 5:23 PM, Neha Kolhe wrote:

    Hi,

    Button is not getting clicked in IE.

    When did same in Firefox, it works fine. Please suggest some work around.

    Thanks and Regards,
    Neha

    --
    You received this message because you are subscribed to the Google Groups
    "Selenium Users" group.
    To post to this group, send email to selenium-users@googlegroups.com.
    To unsubscribe from this group, send email to
    selenium-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/selenium-users/-/7HvY4SH-hiAJ.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    SATEESH BABU.K

    --
    You received this message because you are subscribed to the Google Groups "Selenium Users" group.
    To post to this group, send email to selenium-users@googlegroups.com.
    To unsubscribe from this group, send email to selenium-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jeevan at Sep 11, 2012 at 3:09 pm
    You can use till the element appears instead of implicit wait...check for
    visibilityOfElementLocated

    Thanks,
    Jeevan.

    On Tue, Sep 11, 2012 at 5:40 PM, sateesh babu wrote:

    Hi Neha,


    Can you tell me the exact scenario?

    Better to use wait command before click on button.

    driver.manage().timeouts().implicitlyWait(5,TimeUnit.SECONDS);

    driver.findElement(By.id("Button")).click();

    On Tue, Sep 11, 2012 at 5:23 PM, Neha Kolhe wrote:

    Hi,

    Button is not getting clicked in IE.

    When did same in Firefox, it works fine. Please suggest some work around.

    Thanks and Regards,
    Neha

    --
    You received this message because you are subscribed to the Google Groups
    "Selenium Users" group.
    To post to this group, send email to selenium-users@googlegroups.com.
    To unsubscribe from this group, send email to
    selenium-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/selenium-users/-/7HvY4SH-hiAJ.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    SATEESH BABU.K


    --
    You received this message because you are subscribed to the Google Groups
    "Selenium Users" group.
    To post to this group, send email to selenium-users@googlegroups.com.
    To unsubscribe from this group, send email to
    selenium-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Selenium Users" group.
    To post to this group, send email to selenium-users@googlegroups.com.
    To unsubscribe from this group, send email to selenium-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Santosh Hulisandra Srikanta at Sep 11, 2012 at 5:23 pm
    Wait for button to be enabled and that use
    driver.switchTo.defaultContent(); before click
    On Tue, Sep 11, 2012 at 5:23 PM, Neha Kolhe wrote:

    Hi,

    Button is not getting clicked in IE.

    When did same in Firefox, it works fine. Please suggest some work around.

    Thanks and Regards,
    Neha

    --
    You received this message because you are subscribed to the Google Groups
    "Selenium Users" group.
    To post to this group, send email to selenium-users@googlegroups.com.
    To unsubscribe from this group, send email to
    selenium-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/selenium-users/-/7HvY4SH-hiAJ.
    For more options, visit https://groups.google.com/groups/opt_out.



    --

    /Santosh

    --
    You received this message because you are subscribed to the Google Groups "Selenium Users" group.
    To post to this group, send email to selenium-users@googlegroups.com.
    To unsubscribe from this group, send email to selenium-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupselenium-users @
categoriesselenium
postedSep 11, '12 at 11:53a
activeSep 11, '12 at 5:23p
posts4
users4
websiteseleniumhq.org

People

Translate

site design / logo © 2021 Grokbase