FAQ
When I use orchestrate runner with `test: True` set as default in Salt
minion config file `/etc/salt/minion`, I have no idea how to force/override
it to be `test=False`.

*Tradition*

If default config for all minions is `test: True`, I can always override it
from command line for `state.highstate`:
     salt '*' state.highstate test=False

*Orchestrate example*

The following is example of "orchestrate" state in `/srv/salt/whatever.sls`:
     whatever_example:
         salt.state:
             - tgt: '*'
             - highstate: True

*Fail 1*

Overriding default on the command line using `test=False` does not work
with orchestrate runner (there are many `result: None` in the output due to
test mode):
     salt-run -l all state.orchestrate whatever test=False

*Fail 2*

I also cannot override default config `test: True` inside "orchestrate"
state above - this won't work:
     whatever_example:
         salt.state:
             - tgt: '*'
             - highstate: True
             - test: False

Any ideas?

--
You received this message because you are subscribed to the Google Groups "Salt-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Colton Myers at May 27, 2015 at 11:27 pm
    This appears to be a bug. Mind opening an issue on Github? Please include
    the output of `salt --versions-report`.

    --
    Colton Myers
    Platform Engineer, SaltStack
    @basepi on Twitter/Github/IRC
    On Tue, May 19, 2015 at 10:35 AM, wrote:


    When I use orchestrate runner with `test: True` set as default in Salt
    minion config file `/etc/salt/minion`, I have no idea how to
    force/override it to be `test=False`.

    *Tradition*

    If default config for all minions is `test: True`, I can always override
    it from command line for `state.highstate`:
    salt '*' state.highstate test=False

    *Orchestrate example*

    The following is example of "orchestrate" state in
    `/srv/salt/whatever.sls`:
    whatever_example:
    salt.state:
    - tgt: '*'
    - highstate: True

    *Fail 1*

    Overriding default on the command line using `test=False` does not work
    with orchestrate runner (there are many `result: None` in the output due
    to test mode):
    salt-run -l all state.orchestrate whatever test=False

    *Fail 2*

    I also cannot override default config `test: True` inside "orchestrate"
    state above - this won't work:
    whatever_example:
    salt.state:
    - tgt: '*'
    - highstate: True
    - test: False

    Any ideas?

    --
    You received this message because you are subscribed to the Google Groups
    "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Uvsmtid at May 28, 2015 at 1:08 pm
    Done:
    https://github.com/saltstack/salt/issues/24209
    On Thursday, May 28, 2015 at 7:27:41 AM UTC+8, basepi wrote:

    This appears to be a bug. Mind opening an issue on Github? Please include
    the output of `salt --versions-report`.

    --
    Colton Myers
    Platform Engineer, SaltStack
    @basepi on Twitter/Github/IRC
    On Tue, May 19, 2015 at 10:35 AM, <uvs...@gmail.com <javascript:>> wrote:


    When I use orchestrate runner with `test: True` set as default in Salt
    minion config file `/etc/salt/minion`, I have no idea how to
    force/override it to be `test=False`.

    *Tradition*

    If default config for all minions is `test: True`, I can always override
    it from command line for `state.highstate`:
    salt '*' state.highstate test=False

    *Orchestrate example*

    The following is example of "orchestrate" state in
    `/srv/salt/whatever.sls`:
    whatever_example:
    salt.state:
    - tgt: '*'
    - highstate: True

    *Fail 1*

    Overriding default on the command line using `test=False` does not work
    with orchestrate runner (there are many `result: None` in the output due
    to test mode):
    salt-run -l all state.orchestrate whatever test=False

    *Fail 2*

    I also cannot override default config `test: True` inside "orchestrate"
    state above - this won't work:
    whatever_example:
    salt.state:
    - tgt: '*'
    - highstate: True
    - test: False

    Any ideas?

    --
    You received this message because you are subscribed to the Google Groups
    "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to salt-users+...@googlegroups.com <javascript:>.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupsalt-users @
postedMay 19, '15 at 4:35p
activeMay 28, '15 at 1:08p
posts3
users2

2 users in discussion

Uvsmtid: 2 posts Colton Myers: 1 post

People

Translate

site design / logo © 2022 Grokbase