FAQ
I'm trying to get the ec2 grains from the salt-contrib package to work with
our current implementation of Salt and AWS.

In the master config file under file_roots I have defined the following:

file_roots:
   base:
     - /path/to/states
   _grains:
    - /path/to/_grains

The python scripts have been copied into the _grains directory and the
master restarted. When I try to sync the minions either through
state.highstate or saltutil.sync_all the grains are not synced. If I run
salt-call saltutil.sync_all -l debug on a minion there are no errors
produced but the grains are not recognized.

There is probably something straight forward that I've missed but I'm
stumped as to how to troubleshoot it further. Any help would be greatly
appreciated.

Cheers,
Tyler

--
You received this message because you are subscribed to the Google Groups "Salt-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Tyler Field at Nov 4, 2014 at 8:38 pm
    I've resolved the issue. It turns out to basically have been a pebcak
    issue.

    I had read the documentation to mean I have to define the _grains location
    in the master config and all I had to do was create a _grains directory in
    my base (eg. /srv/salt/_grains).

    Cheers,
    Tyler
    On Mon, Nov 3, 2014 at 4:33 PM, wrote:

    I'm trying to get the ec2 grains from the salt-contrib package to work
    with our current implementation of Salt and AWS.

    In the master config file under file_roots I have defined the following:

    file_roots:
    base:
    - /path/to/states
    _grains:
    - /path/to/_grains

    The python scripts have been copied into the _grains directory and the
    master restarted. When I try to sync the minions either through
    state.highstate or saltutil.sync_all the grains are not synced. If I run
    salt-call saltutil.sync_all -l debug on a minion there are no errors
    produced but the grains are not recognized.

    There is probably something straight forward that I've missed but I'm
    stumped as to how to troubleshoot it further. Any help would be greatly
    appreciated.

    Cheers,
    Tyler

    --
    You received this message because you are subscribed to a topic in the
    Google Groups "Salt-users" group.
    To unsubscribe from this topic, visit
    https://groups.google.com/d/topic/salt-users/9FEALxFmZSQ/unsubscribe.
    To unsubscribe from this group and all its topics, send an email to
    salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.


    --
    Tyler Field
    Dev/Ops Specialist
    --------------------------
    This e-mail and any attachments may contain information that
    is confidential and/or privileged. If you are not the intended recipient
    and appear to have received this e-mail in error, please notify us
    immediately and then delete all copies from your computer system. Any
    unauthorized use, copying or further distribution is prohibited. Please
    also note that if you send us e-mails containing time-sensitive or
    important instructions, you should ensure that receipt has been timely
    acknowledged in view of the potential for misdirection or inadvertent
    interception. Thank you.

    --
    You received this message because you are subscribed to the Google Groups "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupsalt-users @
postedNov 3, '14 at 11:33p
activeNov 4, '14 at 8:38p
posts2
users1

1 user in discussion

Tyler Field: 2 posts

People

Translate

site design / logo © 2022 Grokbase