FAQ
Hi All,

I'm trying to invoke the pyobjects renderer in a users.sls file via the
shebang first line:

#!pyobjects

but am getting errors of the form:
     Data failed to compile:
----------
     Rendering SLS "base:users" failed: Unknown yaml render error; line 5

which leads me to believe that the pyobjects renderer is not being invoked
on my minions.

Is there some other config needed on either master or minions that allows
pyobjects to be used?

I'm using the Ubuntu PPA installation of saltstack if that matters...

TIA for any help you might be able to provide!

Frank Horowitz


--
You received this message because you are subscribed to the Google Groups "Salt-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Tim O'Guin at Sep 4, 2014 at 3:49 pm
    Hey Frank,

    If you're using the PPA then you're on 2014.1.10, but pyobjects is not
    available in that release. It's in the 2014.7 branch, which hasn't been
    officially released yet. You'll either have to run from that release or
    copy salt/renderers/pyobjects.py from that branch (not sure if it will work
    100% or not though).

    On Thu, Sep 4, 2014 at 9:46 AM, Frank Horowitz wrote:

    Hi All,

    I'm trying to invoke the pyobjects renderer in a users.sls file via the
    shebang first line:

    #!pyobjects

    but am getting errors of the form:
    Data failed to compile:
    ----------
    Rendering SLS "base:users" failed: Unknown yaml render error; line 5

    which leads me to believe that the pyobjects renderer is not being invoked
    on my minions.

    Is there some other config needed on either master or minions that allows
    pyobjects to be used?

    I'm using the Ubuntu PPA installation of saltstack if that matters...

    TIA for any help you might be able to provide!

    Frank Horowitz


    --
    You received this message because you are subscribed to the Google Groups
    "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Frank Horowitz at Sep 4, 2014 at 8:50 pm
    OK. Thanks for the info! I guess that explains it! ;-)
    On Thursday, September 4, 2014 11:49:12 AM UTC-4, timoguin wrote:

    Hey Frank,

    If you're using the PPA then you're on 2014.1.10, but pyobjects is not
    available in that release. It's in the 2014.7 branch, which hasn't been
    officially released yet. You'll either have to run from that release or
    copy salt/renderers/pyobjects.py from that branch (not sure if it will work
    100% or not though).
    --
    You received this message because you are subscribed to the Google Groups "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupsalt-users @
postedSep 4, '14 at 2:46p
activeSep 4, '14 at 8:50p
posts3
users2

2 users in discussion

Frank Horowitz: 2 posts Tim O'Guin: 1 post

People

Translate

site design / logo © 2022 Grokbase