FAQ
Hi,
I need help working with external pillar. I have this in my master config
file

ext_pillar:
   - cloud_pillar: pillar_definitions
extension_modules: /csrv/salt/ext_modules

On my master
root@akilesh-lenovo:/csrv/salt/ext_modules/pillar# ls
cloud_pillar.py


And this
<http://docs.saltstack.com/en/latest/topics/development/external_pillars.html#location>
is what salt documentation says about external pillars loading.

And yet my external module is not loaded. Can someone please tell me what I
am doing wrong/ What else has to be done?

--
You received this message because you are subscribed to the Google Groups "Salt-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Wolodja Wentland at Aug 9, 2014 at 6:50 am

    On Fri, Aug 08, 2014 at 15:21 +0530, Akilesh K wrote:
    I need help working with external pillar. I have this in my master config file

    ext_pillar:
    - cloud_pillar: pillar_definitions
    extension_modules:  /csrv/salt/ext_modules
    This is not correct (even if you ignore the "csrv" vs. "srv" typo). You want to
    set "extension_modules" to the name of a subdirectory under root_dir as "This
    path is appended to root_dir." [0]

    I typically just put external modules in _modules (just like _grains, ...)
    in file_roots though

    [0]
    http://docs.saltstack.com/en/latest/ref/configuration/master.html#extension-modules
    --
    Wolodja <babilen@gmail.com>

    4096R/CAF14EFC
    081C B7CD FF04 2BA9 94EA 36B2 8B7F 7D30 CAF1 4EFC
  • Akilesh K at Aug 11, 2014 at 10:15 am
    Hi,
    As you said placing the file in _modules was sufficient. If I run
    saltutil.refresh_pillar I can see the code in my ext_pillar executing but
    after it is run if I run 'pillar.items' I do not see the contents that I
    expect. What could be the reason, Has anybody got an Idea?

    On Sat, Aug 9, 2014 at 12:20 PM, Wolodja Wentland wrote:
    On Fri, Aug 08, 2014 at 15:21 +0530, Akilesh K wrote:
    I need help working with external pillar. I have this in my master
    config file
    ext_pillar:
    - cloud_pillar: pillar_definitions
    extension_modules: /csrv/salt/ext_modules
    This is not correct (even if you ignore the "csrv" vs. "srv" typo). You
    want to
    set "extension_modules" to the name of a subdirectory under root_dir as
    "This
    path is appended to root_dir." [0]

    I typically just put external modules in _modules (just like _grains, ...)
    in file_roots though

    [0]

    http://docs.saltstack.com/en/latest/ref/configuration/master.html#extension-modules
    --
    Wolodja <babilen@gmail.com>

    4096R/CAF14EFC
    081C B7CD FF04 2BA9 94EA 36B2 8B7F 7D30 CAF1 4EFC
    --
    You received this message because you are subscribed to the Google Groups "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Akilesh K at Aug 11, 2014 at 10:51 am
    It looks as if my module is imported but the ext_pillar method is not
    called at all.

    On Mon, Aug 11, 2014 at 3:44 PM, Akilesh K wrote:

    Hi,
    As you said placing the file in _modules was sufficient. If I run
    saltutil.refresh_pillar I can see the code in my ext_pillar executing but
    after it is run if I run 'pillar.items' I do not see the contents that I
    expect. What could be the reason, Has anybody got an Idea?

    On Sat, Aug 9, 2014 at 12:20 PM, Wolodja Wentland wrote:
    On Fri, Aug 08, 2014 at 15:21 +0530, Akilesh K wrote:
    I need help working with external pillar. I have this in my master
    config file
    ext_pillar:
    - cloud_pillar: pillar_definitions
    extension_modules: /csrv/salt/ext_modules
    This is not correct (even if you ignore the "csrv" vs. "srv" typo). You
    want to
    set "extension_modules" to the name of a subdirectory under root_dir as
    "This
    path is appended to root_dir." [0]

    I typically just put external modules in _modules (just like _grains, ...)
    in file_roots though

    [0]

    http://docs.saltstack.com/en/latest/ref/configuration/master.html#extension-modules
    --
    Wolodja <babilen@gmail.com>

    4096R/CAF14EFC
    081C B7CD FF04 2BA9 94EA 36B2 8B7F 7D30 CAF1 4EFC
    --
    You received this message because you are subscribed to the Google Groups "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Akilesh K at Aug 11, 2014 at 12:40 pm
    Finally I realize that unlike execution modules ext pillar modules actually
    run on the master and not on the minion. Someone's got to mention it in the
    documentations.

    On Mon, Aug 11, 2014 at 4:21 PM, Akilesh K wrote:

    It looks as if my module is imported but the ext_pillar method is not
    called at all.

    On Mon, Aug 11, 2014 at 3:44 PM, Akilesh K wrote:

    Hi,
    As you said placing the file in _modules was sufficient. If I run
    saltutil.refresh_pillar I can see the code in my ext_pillar executing but
    after it is run if I run 'pillar.items' I do not see the contents that I
    expect. What could be the reason, Has anybody got an Idea?


    On Sat, Aug 9, 2014 at 12:20 PM, Wolodja Wentland <babilen@gmail.com>
    wrote:
    On Fri, Aug 08, 2014 at 15:21 +0530, Akilesh K wrote:
    I need help working with external pillar. I have this in my master
    config file
    ext_pillar:
    - cloud_pillar: pillar_definitions
    extension_modules: /csrv/salt/ext_modules
    This is not correct (even if you ignore the "csrv" vs. "srv" typo). You
    want to
    set "extension_modules" to the name of a subdirectory under root_dir as
    "This
    path is appended to root_dir." [0]

    I typically just put external modules in _modules (just like _grains,
    ...)
    in file_roots though

    [0]

    http://docs.saltstack.com/en/latest/ref/configuration/master.html#extension-modules
    --
    Wolodja <babilen@gmail.com>

    4096R/CAF14EFC
    081C B7CD FF04 2BA9 94EA 36B2 8B7F 7D30 CAF1 4EFC
    --
    You received this message because you are subscribed to the Google Groups "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupsalt-users @
postedAug 8, '14 at 9:51a
activeAug 11, '14 at 12:40p
posts5
users2

2 users in discussion

Akilesh K: 4 posts Wolodja Wentland: 1 post

People

Translate

site design / logo © 2022 Grokbase