FAQ
Hey All,

Apologies if this is a noob question.

Anyway, I am able to successfully install what I need from the command line
by doing this...

sudo add-apt-repository -y 'deb http://www.rabbitmq.com/debian/ testing
main'
sudo wget http://www.rabbitmq.com/rabbitmq-signing-key-public.asc
sudo apt-key add rabbitmq-signing-key-public.asc
sudo apt-get update
sudo apt-get install -y rabbitmq-server

BUT when I try to salify it I am unable to get it to work. Here are my
definitions...

rabbitmq_deb:
   pkgrepo.managed:
     - name: deb http://www.rabbitmq.com/debian/ testing main
     - keyid: 0x056E8E56
     - keyserver: pgp.mit.edu
     - require_in:
       - pkg: rabbitmq-server

rabbitmq-server:
   pkg:
     - install
     - name: rabbitmq-server
   service:
     - running
     - enable: true
     - watch:
       - pkg: rabbitmq-server

This is the error...

----------

           ID: rabbitmq_deb

     Function: pkgrepo.managed

         Name: deb http://www.rabbitmq.com/debian/ testing main

       Result: True

      Comment: Package repo 'deb http://www.rabbitmq.com/debian/ testing
main' already configured

      Changes:

----------

           ID: rabbitmq-server

     Function: pkg.install

       Result: False

      Comment: State pkg.install found in sls dev-local-server is unavailable

      Changes:

----------

           ID: rabbitmq-server

     Function: service.running

       Result: False

      Comment: One or more requisite failed

      Changes:
  All help much appreciated!

Thanks,
Justin

--
You received this message because you are subscribed to the Google Groups "Salt-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Tim Messier at Jul 2, 2014 at 3:00 pm
    You need:

    pkg:
       - installed

    Instead of:

    pkg:
       - install



    On Wed, Jul 2, 2014 at 10:32 AM, Justin Vincent wrote:

    Hey All,

    Apologies if this is a noob question.

    Anyway, I am able to successfully install what I need from the command
    line by doing this...

    sudo add-apt-repository -y 'deb http://www.rabbitmq.com/debian/ testing
    main'
    sudo wget http://www.rabbitmq.com/rabbitmq-signing-key-public.asc
    sudo apt-key add rabbitmq-signing-key-public.asc
    sudo apt-get update
    sudo apt-get install -y rabbitmq-server

    BUT when I try to salify it I am unable to get it to work. Here are my
    definitions...

    rabbitmq_deb:
    pkgrepo.managed:
    - name: deb http://www.rabbitmq.com/debian/ testing main
    - keyid: 0x056E8E56
    - keyserver: pgp.mit.edu
    - require_in:
    - pkg: rabbitmq-server

    rabbitmq-server:
    pkg:
    - install
    - name: rabbitmq-server
    service:
    - running
    - enable: true
    - watch:
    - pkg: rabbitmq-server

    This is the error...

    ----------

    ID: rabbitmq_deb

    Function: pkgrepo.managed

    Name: deb http://www.rabbitmq.com/debian/ testing main

    Result: True

    Comment: Package repo 'deb http://www.rabbitmq.com/debian/ testing
    main' already configured

    Changes:

    ----------

    ID: rabbitmq-server

    Function: pkg.install

    Result: False

    Comment: State pkg.install found in sls dev-local-server is
    unavailable

    Changes:

    ----------

    ID: rabbitmq-server

    Function: service.running

    Result: False

    Comment: One or more requisite failed

    Changes:
    All help much appreciated!

    Thanks,
    Justin

    --
    You received this message because you are subscribed to the Google Groups
    "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Justin Vincent at Jul 2, 2014 at 3:06 pm
    Ha! What a noob I am! Thanks for the help :)
    On Wednesday, July 2, 2014 8:00:44 AM UTC-7, shadowfac-chc wrote:

    You need:

    pkg:
    - installed

    Instead of:

    pkg:
    - install




    On Wed, Jul 2, 2014 at 10:32 AM, Justin Vincent <justin...@gmail.com
    <javascript:>> wrote:
    Hey All,

    Apologies if this is a noob question.

    Anyway, I am able to successfully install what I need from the command
    line by doing this...

    sudo add-apt-repository -y 'deb http://www.rabbitmq.com/debian/ testing
    main'
    sudo wget http://www.rabbitmq.com/rabbitmq-signing-key-public.asc
    sudo apt-key add rabbitmq-signing-key-public.asc
    sudo apt-get update
    sudo apt-get install -y rabbitmq-server

    BUT when I try to salify it I am unable to get it to work. Here are my
    definitions...

    rabbitmq_deb:
    pkgrepo.managed:
    - name: deb http://www.rabbitmq.com/debian/ testing main
    - keyid: 0x056E8E56
    - keyserver: pgp.mit.edu
    - require_in:
    - pkg: rabbitmq-server

    rabbitmq-server:
    pkg:
    - install
    - name: rabbitmq-server
    service:
    - running
    - enable: true
    - watch:
    - pkg: rabbitmq-server

    This is the error...

    ----------

    ID: rabbitmq_deb

    Function: pkgrepo.managed

    Name: deb http://www.rabbitmq.com/debian/ testing main

    Result: True

    Comment: Package repo 'deb http://www.rabbitmq.com/debian/ testing
    main' already configured

    Changes:

    ----------

    ID: rabbitmq-server

    Function: pkg.install

    Result: False

    Comment: State pkg.install found in sls dev-local-server is
    unavailable

    Changes:

    ----------

    ID: rabbitmq-server

    Function: service.running

    Result: False

    Comment: One or more requisite failed

    Changes:
    All help much appreciated!

    Thanks,
    Justin

    --
    You received this message because you are subscribed to the Google Groups
    "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to salt-users+...@googlegroups.com <javascript:>.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Salt-users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to salt-users+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupsalt-users @
postedJul 2, '14 at 2:32p
activeJul 2, '14 at 3:06p
posts3
users2

2 users in discussion

Justin Vincent: 2 posts Tim Messier: 1 post

People

Translate

site design / logo © 2022 Grokbase