i installed rvm on 2 different machines with the same linux version, one i
have to type `source ~/.rvm/scripts/rvm` the other i have to type `source
/usr/local/rvm/scripts/rvm`, on the latter i get the faraday error
connection refused on port 9200, with the same app

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/f806dccb-728e-462a-8791-023cdf4491d0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Colin Law at Mar 5, 2016 at 9:40 pm

    On 5 March 2016 at 21:22, fugee ohu wrote:
    i installed rvm on 2 different machines with the same linux version, one i
    have to type `source ~/.rvm/scripts/rvm` the other i have to type `source
    /usr/local/rvm/scripts/rvm`, on the latter i get the faraday error
    connection refused on port 9200, with the same app
    I guess you accidentally installed rvm using sudo on the latter one.
    Remove it, you can just delete /usr/local/rvm I think, and reinstall
    using the curl command method on the rvm website, without using sudo.

    Make sure not to use sudo when installing gems also.

    Colin

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLvDdSW517oh0b85_uH7xw15dpgetEnp_pga0f954G%2BQ1Q%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Fugee ohu at Mar 5, 2016 at 10:48 pm

    On Saturday, March 5, 2016 at 4:40:48 PM UTC-5, Colin Law wrote:
    On 5 March 2016 at 21:22, fugee ohu <fuge...@gmail.com <javascript:>>
    wrote:
    i installed rvm on 2 different machines with the same linux version, one i
    have to type `source ~/.rvm/scripts/rvm` the other i have to type `source
    /usr/local/rvm/scripts/rvm`, on the latter i get the faraday error
    connection refused on port 9200, with the same app
    I guess you accidentally installed rvm using sudo on the latter one.
    Remove it, you can just delete /usr/local/rvm I think, and reinstall
    using the curl command method on the rvm website, without using sudo.
      that's what i did, i'm trying to install single user on linux mint but it
    wants to create the directory '/usr/local/rvm' and for single user, it
    shouldn't be creating that directory, my source is supposed to be
    ~/.rvm/scripts/rvm' , what gives?
    Make sure not to use sudo when installing gems also.

    Colin
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/35de0bd8-3c7d-4169-8048-24e0bb362751%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Fugee ohu at Mar 6, 2016 at 12:28 am

    On Saturday, March 5, 2016 at 4:40:48 PM UTC-5, Colin Law wrote:
    On 5 March 2016 at 21:22, fugee ohu <fuge...@gmail.com <javascript:>>
    wrote:
    i installed rvm on 2 different machines with the same linux version, one i
    have to type `source ~/.rvm/scripts/rvm` the other i have to type `source
    /usr/local/rvm/scripts/rvm`, on the latter i get the faraday error
    connection refused on port 9200, with the same app
    I guess you accidentally installed rvm using sudo on the latter one.
    Remove it, you can just delete /usr/local/rvm I think, and reinstall
    using the curl command method on the rvm website, without using sudo.

    Make sure not to use sudo when installing gems also.

    Colin
    Yes I accidentally sudo'd when i installed rvm My next problem was i
    needed to purge the old ruby1.9.1 config files After that I was able to
    install rvm ~ thanks

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/eb025cbd-b6bb-4c0b-bec1-b32845e8e9fc%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedMar 5, '16 at 9:23p
activeMar 6, '16 at 12:28a
posts4
users2
websiterubyonrails.org
irc#RubyOnRails

2 users in discussion

Fugee ohu: 3 posts Colin Law: 1 post

People

Translate

site design / logo © 2022 Grokbase