I have 5 Rails 5 "canery apps' that in the past run bundle cleanly, but
yesterday things changed.


I have two repos (rt_demo_app5, rt_first_app5) that have run bundle cleanly
(after adding rack

master to Gemfile) and 3 that do not (hello_app5, toy_app5,
sample_app_5_0_rt) even after

adding the rack master to Gemfile.


For the ones that do not run bundle cleanly, the error message is (before
adding rack master to Gemfile):


   Bundler could not find compatible versions for gem "rack":
      In Gemfile:
        rails (>= 0) ruby depends on
          actionpack (= 5.0.0.alpha) ruby depends on
            rack (~> 2.x) ruby
      Could not find gem 'rack (~> 2.x) ruby', which is required by
      gem 'actionpack (= 5.0.0.alpha) ruby', in any of the sources.


Example Public repo: https://bitbucket.org/jasnow/sample_app_5_0_rt


<https://bitbucket.org/jasnow/sample_app_5_0_rt>

I checked rubygems.org and latest rack is at 1.6.4 so unclear how to get
2.x.


*So how do I change my Gemfile to find "rack 2.x"?*


Thanks,

Al


--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/2fc904e8-29e1-4947-88e8-26285c11a9be%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Hassan Schroeder at Aug 21, 2015 at 4:54 pm

    On Fri, Aug 21, 2015 at 9:09 AM, Al Snow wrote:

    I checked rubygems.org and latest rack is at 1.6.4 so unclear how to get
    2.x.

    So how do I change my Gemfile to find "rack 2.x"?
    Try:

    gem 'rack', github: 'rack/rack'


    HTH,
    --
    Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
    http://about.me/hassanschroeder
    twitter: @hassan
    Consulting Availability : Silicon Valley or remote

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CACmC4yB26G621HSnYGJZJJgw0qRtJQc-On3JyY82TO0OSM4CRg%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Al Snow at Aug 21, 2015 at 6:19 pm
    After adding "gem 'rack', github: ''rack/rack'" to example repo below, I
    get this when I run "bundle" command:

    Bundler could not find compatible versions for gem "rack":
       In Gemfile:
         rails (>= 0) ruby depends on
           actionpack (= 5.0.0.alpha) ruby depends on
             rack (~> 1.6) ruby

         rack (>= 0) ruby

    It appears that we need both rack (2.x) and rack (1.6).

    FYI,
    Al
    On Friday, August 21, 2015 at 12:09:38 PM UTC-4, Al Snow wrote:

    I have 5 Rails 5 "canery apps' that in the past run bundle cleanly, but
    yesterday things changed.


    I have two repos (rt_demo_app5, rt_first_app5) that have run bundle
    cleanly (after adding rack

    master to Gemfile) and 3 that do not (hello_app5, toy_app5,
    sample_app_5_0_rt) even after

    adding the rack master to Gemfile.


    For the ones that do not run bundle cleanly, the error message is (before
    adding rack master to Gemfile):


    Bundler could not find compatible versions for gem "rack":
    In Gemfile:
    rails (>= 0) ruby depends on
    actionpack (= 5.0.0.alpha) ruby depends on
    rack (~> 2.x) ruby
    Could not find gem 'rack (~> 2.x) ruby', which is required by
    gem 'actionpack (= 5.0.0.alpha) ruby', in any of the sources.


    Example Public repo: https://bitbucket.org/jasnow/sample_app_5_0_rt


    <https://bitbucket.org/jasnow/sample_app_5_0_rt>

    I checked rubygems.org and latest rack is at 1.6.4 so unclear how to get
    2.x.


    *So how do I change my Gemfile to find "rack 2.x"?*


    Thanks,

    Al

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/129fbc9d-20a1-401a-a0b3-23b45996a3f4%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Al Snow at Aug 21, 2015 at 7:59 pm
    Partially fix (but now have new messages):

    After more digging, I added these lines to Gemfile:



    * * gem 'sprockets', git: 'git://github.com/rails/sprockets.git' * gem
    'sass-rails', git: 'git://github.com/rails/sass-rails.git' * gem
    'rack', git: 'git://github.com/rack/rack.git' * gem
    'sprockets-rails', '3.0.0.beta2'*

    But now I get this (even aflter added the line below to
    config/initializers/assets.rb) during rake run:


    *ActionView::Template::Error: Asset was not declared to be precompiled in
    production.Add `Rails.application.config.assets.precompile += %w(
    application.js )` to`config/initializers/assets.rb` and restart your
    server"*


    On Friday, August 21, 2015 at 12:09:38 PM UTC-4, Al Snow wrote:

    I have 5 Rails 5 "canery apps' that in the past run bundle cleanly, but
    yesterday things changed.


    I have two repos (rt_demo_app5, rt_first_app5) that have run bundle
    cleanly (after adding rack

    master to Gemfile) and 3 that do not (hello_app5, toy_app5,
    sample_app_5_0_rt) even after

    adding the rack master to Gemfile.


    For the ones that do not run bundle cleanly, the error message is (before
    adding rack master to Gemfile):


    Bundler could not find compatible versions for gem "rack":
    In Gemfile:
    rails (>= 0) ruby depends on
    actionpack (= 5.0.0.alpha) ruby depends on
    rack (~> 2.x) ruby
    Could not find gem 'rack (~> 2.x) ruby', which is required by
    gem 'actionpack (= 5.0.0.alpha) ruby', in any of the sources.


    Example Public repo: https://bitbucket.org/jasnow/sample_app_5_0_rt


    <https://bitbucket.org/jasnow/sample_app_5_0_rt>

    I checked rubygems.org and latest rack is at 1.6.4 so unclear how to get
    2.x.


    *So how do I change my Gemfile to find "rack 2.x"?*


    Thanks,

    Al

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/67789692-d4e3-4466-90b2-2c99590c58db%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Al Snow at Aug 21, 2015 at 8:28 pm
    TRICK: Must notice what is between the paras and add them to the
    config/initializers/assets.rb file.
    Example: Rails.application.config.assets.precompile += %w(* application.js
    application.css* ).
    Once I added all of the things that needed to be precompile (now with
    sprockets 4.0), "rake" ran cleanly.

    Therefore all 3 repos that I had problems with today and now fixed.
    (Question Closed)
    On Friday, August 21, 2015 at 12:09:38 PM UTC-4, Al Snow wrote:

    I have 5 Rails 5 "canery apps' that in the past run bundle cleanly, but
    yesterday things changed.


    I have two repos (rt_demo_app5, rt_first_app5) that have run bundle
    cleanly (after adding rack

    master to Gemfile) and 3 that do not (hello_app5, toy_app5,
    sample_app_5_0_rt) even after

    adding the rack master to Gemfile.


    For the ones that do not run bundle cleanly, the error message is (before
    adding rack master to Gemfile):


    Bundler could not find compatible versions for gem "rack":
    In Gemfile:
    rails (>= 0) ruby depends on
    actionpack (= 5.0.0.alpha) ruby depends on
    rack (~> 2.x) ruby
    Could not find gem 'rack (~> 2.x) ruby', which is required by
    gem 'actionpack (= 5.0.0.alpha) ruby', in any of the sources.


    Example Public repo: https://bitbucket.org/jasnow/sample_app_5_0_rt


    <https://bitbucket.org/jasnow/sample_app_5_0_rt>

    I checked rubygems.org and latest rack is at 1.6.4 so unclear how to get
    2.x.


    *So how do I change my Gemfile to find "rack 2.x"?*


    Thanks,

    Al

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/94204aab-d0b5-4f3c-8b34-37f558659c25%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedAug 21, '15 at 4:09p
activeAug 21, '15 at 8:28p
posts5
users2
websiterubyonrails.org
irc#RubyOnRails

2 users in discussion

Al Snow: 4 posts Hassan Schroeder: 1 post

People

Translate

site design / logo © 2021 Grokbase