Hello All,

i have this configuration in development.rb

config.action_mailer.delivery_method = :smtp

   config.action_mailer.smtp_settings = {
   address: "smtp.gmail.com",
   port: 587,
   domain: "gmail.com",
   authentication: "plain",
   enable_starttls_auto: true,
   user_name: emailid,
   password: password,
   ssl: true
   }
   config.action_mailer.perform_deliveries = true


Using Rails 4 and ruby 2 versions, emails are not getting delivered though
in the console it shows as below
Sent mail to emailid (30012.9ms)
Date: Thu, 23 Apr 2015 15:40:29 +0530
From: emailid@gmail.com
To: emails@gmail.com
Message-ID: <5538c5159d8dd_2646236a9652297a1@name-virtualbox.mail>
Subject: SMT
Mime-Version: 1.0
Content-Type: text/html;
  charset=UTF-8
Content-Transfer-Encoding: 7bit

<h2>Hi This a mail regarding the cell rotation </h2>





and Error outs as


*Net::OpenTimeout (execution expired):*

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAEGezZUKeeiddOcGrFBHapEGuvNTw6j87_59Rcbi27jKDWzF%2BA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Paul Makepeace at Apr 23, 2015 at 6:02 pm
    Whom are you sending email to? Because which service you connect to,
    and how, affects how Gmail restricts the recipients.

    Make sure you're lined up fully with,
    https://support.google.com/a/answer/176600?hl=en

    Specifically you may need to be using, smtp-relay.gmail.com

    HTH,
    Paul
    On Thu, Apr 23, 2015 at 3:35 AM, Annapoorna R wrote:
    Hello All,

    i have this configuration in development.rb

    config.action_mailer.delivery_method = :smtp

    config.action_mailer.smtp_settings = {
    address: "smtp.gmail.com",
    port: 587,
    domain: "gmail.com",
    authentication: "plain",
    enable_starttls_auto: true,
    user_name: emailid,
    password: password,
    ssl: true
    }
    config.action_mailer.perform_deliveries = true


    Using Rails 4 and ruby 2 versions, emails are not getting delivered though
    in the console it shows as below
    Sent mail to emailid (30012.9ms)
    Date: Thu, 23 Apr 2015 15:40:29 +0530
    From: emailid@gmail.com
    To: emails@gmail.com
    Message-ID: <5538c5159d8dd_2646236a9652297a1@name-virtualbox.mail>
    Subject: SMT
    Mime-Version: 1.0
    Content-Type: text/html;
    charset=UTF-8
    Content-Transfer-Encoding: 7bit

    <h2>Hi This a mail regarding the cell rotation </h2>





    and Error outs as


    Net::OpenTimeout (execution expired):

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/rubyonrails-talk/CAEGezZUKeeiddOcGrFBHapEGuvNTw6j87_59Rcbi27jKDWzF%2BA%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAMEJyiujYp1kZ_m0Peqf2ATxzQTKddcROaNFgBr09zf0nUZ74g%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Cody Skidmore at Apr 24, 2015 at 1:13 pm
    Are you using an ordinary gmail account or a domain account hosted on
    Google Apps? For the former, you can turn on "Access for less secure apps"
    in the account settings. If you're using the latter, you must use SSL. I'm
    not sure your port is correct. The following is a working configuration
    using a domain account hosted on Google Apps.

    ActionMailer::Base.smtp_settings = { :address => 'smtp.gmail.com',
       :port => '465', :authentication => 'plain', :user_name
      => 'exa...@example.com', :password => 'yourpassword', :domain
           => 'yourd...@example.com', :ssl => true }
    On Thursday, April 23, 2015 at 6:35:31 AM UTC-4, anu wrote:

    Hello All,

    i have this configuration in development.rb

    config.action_mailer.delivery_method = :smtp

    config.action_mailer.smtp_settings = {
    address: "smtp.gmail.com",
    port: 587,
    domain: "gmail.com",
    authentication: "plain",
    enable_starttls_auto: true,
    user_name: emailid,
    password: password,
    ssl: true
    }
    config.action_mailer.perform_deliveries = true


    Using Rails 4 and ruby 2 versions, emails are not getting delivered though
    in the console it shows as below
    Sent mail to emailid (30012.9ms)
    Date: Thu, 23 Apr 2015 15:40:29 +0530
    From: ema...@gmail.com <javascript:>
    To: ema...@gmail.com <javascript:>
    Message-ID: <5538c5159d8dd_2646236a9652297a1@name-virtualbox.mail>
    Subject: SMT
    Mime-Version: 1.0
    Content-Type: text/html;
    charset=UTF-8
    Content-Transfer-Encoding: 7bit

    <h2>Hi This a mail regarding the cell rotation </h2>





    and Error outs as


    *Net::OpenTimeout (execution expired):*
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/ad0ebfea-c2a7-4f9e-ab19-5df6aca9f238%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Cody Skidmore at Apr 24, 2015 at 1:19 pm
    Here's the Environment Devise configuration.

       # Devise configuration settings
       config.action_mailer.default_url_options = { :host => 'your host port'}
       config.action_mailer.delivery_method = :smtp
       config.action_mailer.perform_deliveries = true
    On Friday, April 24, 2015 at 9:13:50 AM UTC-4, Cody Skidmore wrote:

    Are you using an ordinary gmail account or a domain account hosted on
    Google Apps? For the former, you can turn on "Access for less secure
    apps" in the account settings. If you're using the latter, you must use
    SSL. I'm not sure your port is correct. The following is a working
    configuration using a domain account hosted on Google Apps.

    ActionMailer::Base.smtp_settings = { :address => 'smtp.gmail.com',
    :port => '465', :authentication => 'plain', :user_name
    => 'exa...@example.com', :password => 'yourpassword', :domain
    => 'yourd...@example.com', :ssl => true }
    On Thursday, April 23, 2015 at 6:35:31 AM UTC-4, anu wrote:

    Hello All,

    i have this configuration in development.rb

    config.action_mailer.delivery_method = :smtp

    config.action_mailer.smtp_settings = {
    address: "smtp.gmail.com",
    port: 587,
    domain: "gmail.com",
    authentication: "plain",
    enable_starttls_auto: true,
    user_name: emailid,
    password: password,
    ssl: true
    }
    config.action_mailer.perform_deliveries = true


    Using Rails 4 and ruby 2 versions, emails are not getting delivered
    though in the console it shows as below
    Sent mail to emailid (30012.9ms)
    Date: Thu, 23 Apr 2015 15:40:29 +0530
    From: ema...@gmail.com
    To: ema...@gmail.com
    Message-ID: <5538c5159d8dd_2646236a9652297a1@name-virtualbox.mail>
    Subject: SMT
    Mime-Version: 1.0
    Content-Type: text/html;
    charset=UTF-8
    Content-Transfer-Encoding: 7bit

    <h2>Hi This a mail regarding the cell rotation </h2>





    and Error outs as


    *Net::OpenTimeout (execution expired):*
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/116d0276-a4bc-46d9-8736-cd13272096ef%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Annapoorna R at Apr 27, 2015 at 4:47 am
    Hello,

    @paul , @cody

    Thank you for the reply, I used ordinary gmail account, I did work around
    your solutions but no luck.. the error "*Net::OpenTimeout (execution
    expired):*." stopped appearing, but mails were not delivered.
    On Fri, Apr 24, 2015 at 6:49 PM, Cody Skidmore wrote:

    Here's the Environment Devise configuration.

    # Devise configuration settings
    config.action_mailer.default_url_options = { :host => 'your host port'}
    config.action_mailer.delivery_method = :smtp
    config.action_mailer.perform_deliveries = true
    On Friday, April 24, 2015 at 9:13:50 AM UTC-4, Cody Skidmore wrote:

    Are you using an ordinary gmail account or a domain account hosted on
    Google Apps? For the former, you can turn on "Access for less secure
    apps" in the account settings. If you're using the latter, you must use
    SSL. I'm not sure your port is correct. The following is a working
    configuration using a domain account hosted on Google Apps.

    ActionMailer::Base.smtp_settings = { :address => 'smtp.gmail.com',
    :port => '465', :authentication => 'plain', :user_name
    => 'exa...@example.com', :password => 'yourpassword', :domain
    => 'yourd...@example.com', :ssl => true }
    On Thursday, April 23, 2015 at 6:35:31 AM UTC-4, anu wrote:

    Hello All,

    i have this configuration in development.rb

    config.action_mailer.delivery_method = :smtp

    config.action_mailer.smtp_settings = {
    address: "smtp.gmail.com",
    port: 587,
    domain: "gmail.com",
    authentication: "plain",
    enable_starttls_auto: true,
    user_name: emailid,
    password: password,
    ssl: true
    }
    config.action_mailer.perform_deliveries = true


    Using Rails 4 and ruby 2 versions, emails are not getting delivered
    though in the console it shows as below
    Sent mail to emailid (30012.9ms)
    Date: Thu, 23 Apr 2015 15:40:29 +0530
    From: ema...@gmail.com
    To: ema...@gmail.com
    Message-ID: <5538c5159d8dd_2646236a9652297a1@name-virtualbox.mail>
    Subject: SMT
    Mime-Version: 1.0
    Content-Type: text/html;
    charset=UTF-8
    Content-Transfer-Encoding: 7bit

    <h2>Hi This a mail regarding the cell rotation </h2>





    and Error outs as


    *Net::OpenTimeout (execution expired):*

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/rubyonrails-talk/116d0276-a4bc-46d9-8736-cd13272096ef%40googlegroups.com
    <https://groups.google.com/d/msgid/rubyonrails-talk/116d0276-a4bc-46d9-8736-cd13272096ef%40googlegroups.com?utm_medium=email&utm_source=footer>
    .

    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAEGezZW4jk7Gzm46OVtfGA_6VDtYG9a9NQsRhAvxJ2TLB8zKMw%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Saravanan B at Apr 27, 2015 at 10:13 am
    1.) Check whether the mail id your using has two step verifiication if so
    change it.
    2.) Check whether port 587 has been added in the IPtables if not add it
    using below command.
    iptables -I INPUT -p tcp --dport 22 -j ACCEPT
    On Monday, April 27, 2015 at 10:18:08 AM UTC+5:30, anu wrote:

    Hello,

    @paul , @cody

    Thank you for the reply, I used ordinary gmail account, I did work around
    your solutions but no luck.. the error "*Net::OpenTimeout (execution
    expired):*." stopped appearing, but mails were not delivered.

    On Fri, Apr 24, 2015 at 6:49 PM, Cody Skidmore <co...@skidmore.us
    <javascript:>> wrote:
    Here's the Environment Devise configuration.

    # Devise configuration settings
    config.action_mailer.default_url_options = { :host => 'your host port'}
    config.action_mailer.delivery_method = :smtp
    config.action_mailer.perform_deliveries = true
    On Friday, April 24, 2015 at 9:13:50 AM UTC-4, Cody Skidmore wrote:

    Are you using an ordinary gmail account or a domain account hosted on
    Google Apps? For the former, you can turn on "Access for less secure
    apps" in the account settings. If you're using the latter, you must use
    SSL. I'm not sure your port is correct. The following is a working
    configuration using a domain account hosted on Google Apps.

    ActionMailer::Base.smtp_settings = { :address => '
    smtp.gmail.com', :port => '465', :authentication =>
    'plain', :user_name => 'exa...@example.com', :password
    => 'yourpassword', :domain => 'yourd...@example.com', :ssl
    => true }
    On Thursday, April 23, 2015 at 6:35:31 AM UTC-4, anu wrote:

    Hello All,

    i have this configuration in development.rb

    config.action_mailer.delivery_method = :smtp

    config.action_mailer.smtp_settings = {
    address: "smtp.gmail.com",
    port: 587,
    domain: "gmail.com",
    authentication: "plain",
    enable_starttls_auto: true,
    user_name: emailid,
    password: password,
    ssl: true
    }
    config.action_mailer.perform_deliveries = true


    Using Rails 4 and ruby 2 versions, emails are not getting delivered
    though in the console it shows as below
    Sent mail to emailid (30012.9ms)
    Date: Thu, 23 Apr 2015 15:40:29 +0530
    From: ema...@gmail.com
    To: ema...@gmail.com
    Message-ID: <5538c5159d8dd_2646236a9652297a1@name-virtualbox.mail>
    Subject: SMT
    Mime-Version: 1.0
    Content-Type: text/html;
    charset=UTF-8
    Content-Transfer-Encoding: 7bit

    <h2>Hi This a mail regarding the cell rotation </h2>





    and Error outs as


    *Net::OpenTimeout (execution expired):*

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to rubyonrails-ta...@googlegroups.com <javascript:>.
    To post to this group, send email to rubyonra...@googlegroups.com
    <javascript:>.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/rubyonrails-talk/116d0276-a4bc-46d9-8736-cd13272096ef%40googlegroups.com
    <https://groups.google.com/d/msgid/rubyonrails-talk/116d0276-a4bc-46d9-8736-cd13272096ef%40googlegroups.com?utm_medium=email&utm_source=footer>
    .

    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/7850d6dc-8cad-4596-8897-a9dbf1be760e%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedApr 23, '15 at 10:35a
activeApr 27, '15 at 10:13a
posts6
users4
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2021 Grokbase