When I run rails new, it's starts to create the files needed to make the
app and then it brings up an error saying that the Rake gem wasn't able to
be pulled from the Rubygem site.

Anybody know what the problem could be?

Here's what returned in my command line:

     $ rails new Connections
     DL is deprecated, please use Fiddle
           create
           create README.rdoc
           create Rakefile
           create config.ru
           create .gitignore
           create Gemfile
           create app
           create app/assets/javascripts/application.js
           create app/assets/stylesheets/application.css
           create app/controllers/application_controller.rb
           create app/helpers/application_helper.rb
           create app/views/layouts/application.html.erb
           create app/assets/images/.keep
           create app/mailers/.keep
           create app/models/.keep
           create app/controllers/concerns/.keep
           create app/models/concerns/.keep
           create bin
           create bin/bundle
           create bin/rails
           create bin/rake
           create bin/setup
           create config
           create config/routes.rb
           create config/application.rb
           create config/environment.rb
           create config/secrets.yml
           create config/environments
           create config/environments/development.rb
           create config/environments/production.rb
           create config/environments/test.rb
           create config/initializers
           create config/initializers/assets.rb
           create config/initializers/backtrace_silencers.rb
           create config/initializers/cookies_serializer.rb
           create config/initializers/filter_parameter_logging.rb
           create config/initializers/inflections.rb
           create config/initializers/mime_types.rb
           create config/initializers/session_store.rb
           create config/initializers/wrap_parameters.rb
           create config/locales
           create config/locales/en.yml
           create config/boot.rb
           create config/database.yml
           create db
           create db/seeds.rb
           create lib
           create lib/tasks
           create lib/tasks/.keep
           create lib/assets
           create lib/assets/.keep
           create log
           create log/.keep
           create public
           create public/404.html
           create public/422.html
           create public/500.html
           create public/favicon.ico
           create public/robots.txt
           create test/fixtures
           create test/fixtures/.keep
           create test/controllers
           create test/controllers/.keep
           create test/mailers
           create test/mailers/.keep
           create test/models
           create test/models/.keep
           create test/helpers
           create test/helpers/.keep
           create test/integration
           create test/integration/.keep
           create test/test_helper.rb
           create tmp/cache
           create tmp/cache/assets
           create vendor/assets/javascripts
           create vendor/assets/javascripts/.keep
           create vendor/assets/stylesheets
           create vendor/assets/stylesheets/.keep
              run bundle install
     DL is deprecated, please use Fiddle
     Fetching gem metadata from https://rubygems.org/..........
     Resolving dependencies...

     Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0
state=SSLv3 read
     server certificate B: certificate verify failed
(https://rubygems.org/gems/rake-
     10.4.2.gem)
     An error occurred while installing rake (10.4.2), and Bundler cannot
continue.
     Make sure that `gem install rake -v '10.4.2'` succeeds before bundling.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/b37396a1-01fd-4d41-9166-de89e6e57bb5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Colin Law at Jan 25, 2015 at 8:03 pm
    Googling for
    Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0
    state=SSLv3 read server certificate B: certificate verify failed
    windows
    brings up a number of hits. One of those may be useful.

    I don't use Windows so I cannot help personally.

    Colin
    On 25 January 2015 at 15:32, Aaron wrote:
    When I run rails new, it's starts to create the files needed to make the app
    and then it brings up an error saying that the Rake gem wasn't able to be
    pulled from the Rubygem site.

    Anybody know what the problem could be?

    Here's what returned in my command line:

    $ rails new Connections
    DL is deprecated, please use Fiddle
    create
    create README.rdoc
    create Rakefile
    create config.ru
    create .gitignore
    create Gemfile
    create app
    create app/assets/javascripts/application.js
    create app/assets/stylesheets/application.css
    create app/controllers/application_controller.rb
    create app/helpers/application_helper.rb
    create app/views/layouts/application.html.erb
    create app/assets/images/.keep
    create app/mailers/.keep
    create app/models/.keep
    create app/controllers/concerns/.keep
    create app/models/concerns/.keep
    create bin
    create bin/bundle
    create bin/rails
    create bin/rake
    create bin/setup
    create config
    create config/routes.rb
    create config/application.rb
    create config/environment.rb
    create config/secrets.yml
    create config/environments
    create config/environments/development.rb
    create config/environments/production.rb
    create config/environments/test.rb
    create config/initializers
    create config/initializers/assets.rb
    create config/initializers/backtrace_silencers.rb
    create config/initializers/cookies_serializer.rb
    create config/initializers/filter_parameter_logging.rb
    create config/initializers/inflections.rb
    create config/initializers/mime_types.rb
    create config/initializers/session_store.rb
    create config/initializers/wrap_parameters.rb
    create config/locales
    create config/locales/en.yml
    create config/boot.rb
    create config/database.yml
    create db
    create db/seeds.rb
    create lib
    create lib/tasks
    create lib/tasks/.keep
    create lib/assets
    create lib/assets/.keep
    create log
    create log/.keep
    create public
    create public/404.html
    create public/422.html
    create public/500.html
    create public/favicon.ico
    create public/robots.txt
    create test/fixtures
    create test/fixtures/.keep
    create test/controllers
    create test/controllers/.keep
    create test/mailers
    create test/mailers/.keep
    create test/models
    create test/models/.keep
    create test/helpers
    create test/helpers/.keep
    create test/integration
    create test/integration/.keep
    create test/test_helper.rb
    create tmp/cache
    create tmp/cache/assets
    create vendor/assets/javascripts
    create vendor/assets/javascripts/.keep
    create vendor/assets/stylesheets
    create vendor/assets/stylesheets/.keep
    run bundle install
    DL is deprecated, please use Fiddle
    Fetching gem metadata from https://rubygems.org/..........
    Resolving dependencies...

    Gem::RemoteFetcher::FetchError: SSL_connect returned=1 errno=0
    state=SSLv3 read
    server certificate B: certificate verify failed
    (https://rubygems.org/gems/rake-
    10.4.2.gem)
    An error occurred while installing rake (10.4.2), and Bundler cannot
    continue.
    Make sure that `gem install rake -v '10.4.2'` succeeds before bundling.

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/rubyonrails-talk/b37396a1-01fd-4d41-9166-de89e6e57bb5%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLueLP8Xe%3D6hdihCWOfO%3DXKQjH32DrPpaghvq2tEq1uYgQ%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedJan 25, '15 at 5:51p
activeJan 25, '15 at 8:03p
posts2
users2
websiterubyonrails.org
irc#RubyOnRails

2 users in discussion

Colin Law: 1 post Aaron: 1 post

People

Translate

site design / logo © 2022 Grokbase