Hi guys, I just got to listing 4.7 on the tutorial. When I run the command
`rails server -b $IP -p $PORT` and opens the correspoding sample_app on the
web browser, I received the following error message on C9's console:

     Started GET "/" for 139.192.9.237 at 2015-01-12 13:47:46 +0000
     Processing by StaticPagesController#home as HTML
      Rendered static_pages/home.html.erb within layouts/application (3.5ms)
     Completed 500 Internal Server Error in 53ms

     EOFError (end of file reached):
      app/views/layouts/application.html.erb:5:in
`_app_views_layouts_application_html_erb___1968168670209067927_48192600'

And the browser displays the following error in screenshot:

http://i.imgur.com/F0UKeQ6.png

Reading the from the error message, I tried to find any typo in
`~/workspace/sample_app/app/assets/views/layout/application.html.erb` but
to no success. Here's what I have in that file:

     <!DOCTYPE html>
     <html>
       <head>
         <title><%= full_title(yield(:title)) %></title>
         <%= stylesheet_link_tag 'application', media: 'all',
'data-turbolinks-track' => true %>
         <%= javascript_include_tag 'application', 'data-turbolinks-track'
=> true %>
         <%= csrf_meta_tags %>
       </head>
       <body>
         <%= yield %>
       </body>
     </html>

I also tried to find any typo in the following 2 files respectively based
on the error message:
`~/workspace/sample_app/app/controllers/static_pages_controller.rb`

     class StaticPagesController < ApplicationController
       def home
       end

       def help
       end

       def about
       end

     end

and `~/workspace/sample_app/app/views/static_pages/home.html.erb`

     <h1>Sample App</h1>
     <p>This is the homepage for the <a href="http://railstutorial.org">
Ruby on Rails Tutorial</a> Sample Application</p>

Can anyone give me a pointer where the "bug" is? Thanks in advance.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/0c36360c-ab52-4213-9926-07aff66f0bae%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Yohannes Wijaya at Jan 12, 2015 at 4:44 pm
    Cleaning up the temp files using the following command fixes this issue:
    `rake tmp:clear`
    On Monday, January 12, 2015 at 10:23:52 PM UTC+7, Yohannes Wijaya wrote:

    Hi guys, I just got to listing 4.7 on the tutorial. When I run the command
    `rails server -b $IP -p $PORT` and opens the correspoding sample_app on the
    web browser, I received the following error message on C9's console:

    Started GET "/" for 139.192.9.237 at 2015-01-12 13:47:46 +0000
    Processing by StaticPagesController#home as HTML
    Rendered static_pages/home.html.erb within layouts/application (3.5ms)
    Completed 500 Internal Server Error in 53ms

    EOFError (end of file reached):
    app/views/layouts/application.html.erb:5:in
    `_app_views_layouts_application_html_erb___1968168670209067927_48192600'

    And the browser displays the following error in screenshot:

    http://i.imgur.com/F0UKeQ6.png

    Reading the from the error message, I tried to find any typo in
    `~/workspace/sample_app/app/assets/views/layout/application.html.erb` but
    to no success. Here's what I have in that file:

    <!DOCTYPE html>
    <html>
    <head>
    <title><%= full_title(yield(:title)) %></title>
    <%= stylesheet_link_tag 'application', media: 'all',
    'data-turbolinks-track' => true %>
    <%= javascript_include_tag 'application', 'data-turbolinks-track'
    => true %>
    <%= csrf_meta_tags %>
    </head>
    <body>
    <%= yield %>
    </body>
    </html>

    I also tried to find any typo in the following 2 files respectively based
    on the error message:
    `~/workspace/sample_app/app/controllers/static_pages_controller.rb`

    class StaticPagesController < ApplicationController
    def home
    end

    def help
    end

    def about
    end

    end

    and `~/workspace/sample_app/app/views/static_pages/home.html.erb`

    <h1>Sample App</h1>
    <p>This is the homepage for the <a href="http://railstutorial.org">
    Ruby on Rails Tutorial</a> Sample Application</p>

    Can anyone give me a pointer where the "bug" is? Thanks in advance.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/06f38a61-a863-4082-a837-10228518ae05%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedJan 12, '15 at 3:25p
activeJan 12, '15 at 4:44p
posts2
users1
websiterubyonrails.org
irc#RubyOnRails

1 user in discussion

Yohannes Wijaya: 2 posts

People

Translate

site design / logo © 2021 Grokbase