Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

     /home/anil/.rvm/rubies/ruby-2.0.0-p481/bin/ruby extconf.rb
checking for Ruby version >= 1.8.5... yes
checking for gcc... yes
checking for Magick-config... no
Can't install RMagick 2.13.2. Can't find Magick-config in
/usr/local/heroku/bin:/home/anil/.rvm/gems/ruby-2.0.0-p481/bin:/home/anil/.rvm/gems/ruby-2.0.0-p481@global/bin:/home/anil/.rvm/rubies/ruby-2.0.0-p481/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/anil/.rvm/bin:/home/anil/.rvm/bin:/home/anil/.rvm/bin

*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details. You
may
need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=/home/anil/.rvm/rubies/ruby-2.0.0-p481/bin/ruby

extconf failed, exit code 1

Gem files will remain installed in
/home/anil/.rvm/gems/ruby-2.0.0-p481/gems/rmagick-2.13.2 for inspection.
Results logged to
/home/anil/.rvm/gems/ruby-2.0.0-p481/extensions/x86-linux/2.0.0/rmagick-2.13.2/gem_make.out
An error occurred while installing rmagick (2.13.2), and Bundler cannot
continue.
Make sure that `gem install rmagick -v '2.13.2'` succeeds before bundling.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/6bbeebbd-4afc-49da-9e56-f6be78a482c0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Hassan Schroeder at Aug 27, 2014 at 10:55 am
    On Wed, Aug 27, 2014 at 12:32 AM, ANIL YADAV wrote:

    <snip/>

    Is there a question to go with this?

    --
    Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
    http://about.me/hassanschroeder
    twitter: @hassan

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CACmC4yBq-RbLQUDPSnaJ2knkSWCHXi116nOGCF-odquz61Tdyg%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Benoit G. at Nov 20, 2014 at 9:47 am
    https://github.com/rmagick/rmagick/wiki/Installing-on-Ubuntu

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/cef919260b898273cf1b7ac8080d5694%40ruby-forum.com.
    For more options, visit https://groups.google.com/d/optout.
  • David Williams at Nov 20, 2014 at 10:42 pm
    RMagick isn't compatible with the latest version of rails. The gem
    hasn't been updated for sometime.

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/96faa1fd96052bf06919a974ad21becc%40ruby-forum.com.
    For more options, visit https://groups.google.com/d/optout.
  • Jim at Nov 21, 2014 at 2:17 pm

    On Thursday, November 20, 2014 5:43:06 PM UTC-5, Ruby-Forum.com User wrote:
    RMagick isn't compatible with the latest version of rails. The gem
    hasn't been updated for sometime.

    The OP is having an issue with the installation of the gem, which in itself
    has absolutely nothing to do with Rails of any version. Besides that,
    rmagick is compatible with Rails 4.

    The current repository is at https://github.com/gemhome/rmagick and all
    tickets should be placed there.

    Jim

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/e947cc7c-3b11-4030-b492-670c5b4e818c%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedAug 27, '14 at 8:27a
activeNov 21, '14 at 2:17p
posts5
users4
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase