Further on migrating my ancient 1.8.6 Rails 2.3.2 app from Windows to Linux
Mint, whatever I do, I keep getting the same error pertaining to "* A key
is required to write a cookie containing the session data. Use
config.action_controller.session = { :key => "_myapp_session", :secret =>
"some secret phrase" } in config/environment.rb."* This is true if I run
run ruby script/server, or rake rails:update. However, in my
config/environent.rb, I already have this statement the error is telling me
I needed (in fact, it was commented out, but uncommenting it changes
nothing for me, I keep getting the same error whenever I go to run
something here). Anyone have an idea where else I can look here? Thaks, RVic


* ruby script/server
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/session/cookie_store.rb:163:in
`ensure_session_key': A key is required to write a cookie containing the
session data. Use config.action_controller.session = { :key =>
"_myapp_session", :secret => "some secret phrase" } in
config/environment.rb (ArgumentError)
     from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/session/cookie_store.rb:74:in
`initialize'
     from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/middleware_stack.rb:72:in
`new'
     from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/middleware_stack.rb:72:in
`build'
     from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/middleware_stack.rb:116:in
`build'
     from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/activesupport-2.3.2/lib/active_support/inflector.rb:361:in
`inject'
     from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/middleware_stack.rb:116:in
`each'
     from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/middleware_stack.rb:116:in
`inject'
     from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/middleware_stack.rb:116:in
`build'
      ... 8 levels...
     from ./script/../config/boot.rb:11:in `boot!'
     from ./script/../config/boot.rb:110
     from script/server:2:in `require'
     from script/server:2
*

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/bf32ee3f-2dce-48c6-84fd-a2ce265086d1%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Hassan Schroeder at Oct 28, 2013 at 8:10 pm

    On Mon, Oct 28, 2013 at 12:45 PM, RVic wrote:
    Further on migrating my ancient 1.8.6 Rails 2.3.2 app from Windows to Linux
    Mint
    Are you sure your time wouldn't be better spent just moving straight
    to current versions of Ruby and Rails? :-)

    It might actually be easier than what you're doing now, and at the end
    you'd have something besides a running but obsolete application with
    known security vulnerabilities...

    Just a suggestion!

    --
    Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
    http://about.me/hassanschroeder
    twitter: @hassan

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CACmC4yCY%2B0HTFTrLaUe8dam%3Dr9HiYr3Hw1oocD8S1vQ-DzcdMA%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ralph Vince at Oct 28, 2013 at 8:36 pm

    On Mon, Oct 28, 2013 at 4:09 PM, Hassan Schroeder wrote:
    Are you sure your time wouldn't be better spent just moving straight
    to current versions of Ruby and Rails? :-)

    It might actually be easier than what you're doing now, and at the end
    you'd have something besides a running but obsolete application with
    known security vulnerabilities...

    Just a suggestion!
    Hassan,

    Oh I certainly will be migrating it -- I;ve just got the order though to
    get this thing up and running in a linux vm asap. Hopefully, Im not far
    from that. But there;s a lot that Iwill have to migrate to the new
    mechanisms (routes are different, invoking the server is different, etc.)
    Thank you!

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKV1-YJNNRg0eSuM4hND8ELJ%3DB4kvxtu-Rk2y%3DFLix8m4w%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Colin Law at Oct 28, 2013 at 9:13 pm

    On 28 October 2013 19:45, RVic wrote:
    Further on migrating my ancient 1.8.6 Rails 2.3.2 app from Windows to Linux
    Mint, whatever I do, I keep getting the same error pertaining to " A key is
    required to write a cookie containing the session data. Use
    config.action_controller.session = { :key => "_myapp_session", :secret =>
    "some secret phrase" } in config/environment.rb." This is true if I run run
    ruby script/server, or rake rails:update. However, in my
    config/environent.rb,
    Can you paste your environment.rb here please?

    Colin

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLtv3wNThVuHovJvPdd9PboDWJb7KyqPxPKd6jtrsyRJeA%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ralph Vince at Oct 28, 2013 at 9:19 pm

    On Mon, Oct 28, 2013 at 5:12 PM, Colin Law wrote:
    Can you paste your environment.rb here please?

    Colin
    Thanks Colin!

    # Be sure to restart your web server when you modify this file.

    # Uncomment below to force Rails into production mode when
    # you don't control web/app server and can't set it the proper way
    # ENV['RAILS_ENV'] ||= 'production'

    # Specifies gem version of Rails to use when vendor/rails is not present
    # RAILS_GEM_VERSION = '2.1.2' unless defined? RAILS_GEM_VERSION

    # Bootstrap the Rails environment, frameworks, and default configuration
    require File.join(File.dirname(__FILE__), 'boot')
    require 'paginator'

    Rails::Initializer.run do |config|

       # Settings in config/environments/* take precedence those specified here

       # Skip frameworks you're not going to use
       #config.frameworks -= [ :action_web_service, :action_mailer ]

       # Add additional load paths for your own custom dirs
       # config.load_paths += %W( #{RAILS_ROOT}/extras )
       config.load_paths += %W( #{RAILS_ROOT}/app/reports )

       # Required for Ruports: ############
        config.after_initialize do
           require "ruport"
         end
       # **SEE CONFIG_LOAD_PATHS ABOVE and require "app/reports/templates"
    BELOW**
       ###########################

       # Force all environments to use the same logger level
       # (by default production uses :info, the others :debug)
       # config.log_level = :debug

       # Use the database for sessions instead of the file system
       # which shouldn't be used to store highly confidential information
       # (create the session table with 'rake db:sessions:create')
       config.action_controller.session_store = :active_record_store

       # Use SQL instead of Active Record's schema dumper when creating the test
    database.
       # This is necessary if your schema can't be completely dumped by the
    schema dumper,
       # like if you have constraints or database-specific column types
       # config.active_record.schema_format = :sql

       # Activate observers that should always be running
       # config.active_record.observers = :cacher, :garbage_collector

       # Make Time.zone default to the specified zone, and make Active Record
    store time values
          # in the database in UTC, and return them converted to the specified
    local zone.
          # Run "rake -D time" for a list of tasks for finding time zone names.
    Comment line to use default local time.
       config.active_record.default_timezone = :utc


       # See Rails::Configuration for more options

       # Your secret key for verifying cookie session data integrity.
        # If you change this key, all old sessions will become invalid!
        # Make sure the secret is at least 30 characters and all random,
        # no regular words or you'll be exposed to dictionary attacks.
      config.action_controller.session = {
         :key => "_gg_session",
        :secret =>
    "caf079519f0a811fa0ba9a0a3202c93f62d9f86ca4f1981harverdouccioe55e3869ee4aa8cbb48aecb518f1059103b7eb49b513f4d6ddc40d92e9488785eb90689229ad"
       }

       config.gem "authlogic"
       config.gem "actionmailer"
       config.gem "calendar_date_select"
       config.gem "paginator"
       config.gem "builder"
    end

    require "app/reports/templates"

    # Add new inflection rules using the following format
    # (all these examples are active by default):
    # Inflector.inflections do |inflect|
    # inflect.plural /^(ox)$/i, '\1en'
    # inflect.singular /^(ox)en/i, '\1'
    # inflect.irregular 'person', 'people'
    # inflect.uncountable %w( fish sheep )
    # end



    # Include your application configuration below

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKXhJO%3Dt95cTPPa%3Dhixbxpq3uM6ryeaaDWKBtJbA9K3ZZA%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Colin Law at Oct 28, 2013 at 9:33 pm

    On 28 October 2013 21:19, Ralph Vince wrote:

    On Mon, Oct 28, 2013 at 5:12 PM, Colin Law wrote:


    Can you paste your environment.rb here please?

    Colin

    Thanks Colin!

    # Be sure to restart your web server when you modify this file.

    # Uncomment below to force Rails into production mode when
    # you don't control web/app server and can't set it the proper way
    # ENV['RAILS_ENV'] ||= 'production'

    # Specifies gem version of Rails to use when vendor/rails is not present
    # RAILS_GEM_VERSION = '2.1.2' unless defined? RAILS_GEM_VERSION
    The above line should not be commented out, but should of course
    reference '2.3.2'. I don't know whether that might have anything to
    do with it or not.
    # Bootstrap the Rails environment, frameworks, and default configuration
    require File.join(File.dirname(__FILE__), 'boot')
    require 'paginator'
    The line above should not be there, again I don't know whether it is
    relevant to the problem.
    Rails::Initializer.run do |config|

    # Settings in config/environments/* take precedence those specified here

    # Skip frameworks you're not going to use
    #config.frameworks -= [ :action_web_service, :action_mailer ]

    # Add additional load paths for your own custom dirs
    # config.load_paths += %W( #{RAILS_ROOT}/extras )
    config.load_paths += %W( #{RAILS_ROOT}/app/reports )

    # Required for Ruports: ############
    config.after_initialize do
    require "ruport"
    end
    # **SEE CONFIG_LOAD_PATHS ABOVE and require "app/reports/templates"
    BELOW**
    ###########################

    # Force all environments to use the same logger level
    # (by default production uses :info, the others :debug)
    # config.log_level = :debug

    # Use the database for sessions instead of the file system
    # which shouldn't be used to store highly confidential information
    # (create the session table with 'rake db:sessions:create')
    Have you done the above? Either do that and/or comment out the line
    below, at least until it is working.
    config.action_controller.session_store = :active_record_store

    # Use SQL instead of Active Record's schema dumper when creating the test
    database.
    # This is necessary if your schema can't be completely dumped by the
    schema dumper,
    # like if you have constraints or database-specific column types
    # config.active_record.schema_format = :sql

    # Activate observers that should always be running
    # config.active_record.observers = :cacher, :garbage_collector

    # Make Time.zone default to the specified zone, and make Active Record
    store time values
    # in the database in UTC, and return them converted to the specified
    local zone.
    # Run "rake -D time" for a list of tasks for finding time zone names.
    Comment line to use default local time.
    config.active_record.default_timezone = :utc


    # See Rails::Configuration for more options

    # Your secret key for verifying cookie session data integrity.
    # If you change this key, all old sessions will become invalid!
    # Make sure the secret is at least 30 characters and all random,
    # no regular words or you'll be exposed to dictionary attacks.
    config.action_controller.session = {
    :key => "_gg_session",
    That should be :session_key I think, at least that is what I have, in
    which case the error message is wrong.
    :secret =>
    "caf079519f0a811fa0ba9a0a3202c93f62d9f86ca4f1981harverdouccioe55e3869ee4aa8cbb48aecb518f1059103b7eb49b513f4d6ddc40d92e9488785eb90689229ad"
    }

    config.gem "authlogic"
    config.gem "actionmailer"
    config.gem "calendar_date_select"
    config.gem "paginator"
    config.gem "builder"
    end

    require "app/reports/templates"

    # Add new inflection rules using the following format
    # (all these examples are active by default):
    # Inflector.inflections do |inflect|
    # inflect.plural /^(ox)$/i, '\1en'
    # inflect.singular /^(ox)en/i, '\1'
    # inflect.irregular 'person', 'people'
    # inflect.uncountable %w( fish sheep )
    # end



    # Include your application configuration below
    Colin

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLsxjcYa%2ByBdc9DTRv-QSfEfVCD7EGVKAxdKgyu8UoYNQg%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ralph Vince at Oct 28, 2013 at 9:46 pm

    On Mon, Oct 28, 2013 at 5:32 PM, Colin Law wrote:
    On 28 October 2013 21:19, Ralph Vince wrote:


    On Mon, Oct 28, 2013 at 5:12 PM, Colin Law wrote:


    Can you paste your environment.rb here please?

    Colin

    Thanks Colin!

    # Be sure to restart your web server when you modify this file.

    # Uncomment below to force Rails into production mode when
    # you don't control web/app server and can't set it the proper way
    # ENV['RAILS_ENV'] ||= 'production'

    # Specifies gem version of Rails to use when vendor/rails is not present
    # RAILS_GEM_VERSION = '2.1.2' unless defined? RAILS_GEM_VERSION
    The above line should not be commented out, but should of course
    reference '2.3.2'. I don't know whether that might have anything to
    do with it or not.
    # Bootstrap the Rails environment, frameworks, and default configuration
    require File.join(File.dirname(__FILE__), 'boot')
    require 'paginator'
    The line above should not be there, again I don't know whether it is
    relevant to the problem.
    Rails::Initializer.run do |config|

    # Settings in config/environments/* take precedence those specified here
    # Skip frameworks you're not going to use
    #config.frameworks -= [ :action_web_service, :action_mailer ]

    # Add additional load paths for your own custom dirs
    # config.load_paths += %W( #{RAILS_ROOT}/extras )
    config.load_paths += %W( #{RAILS_ROOT}/app/reports )

    # Required for Ruports: ############
    config.after_initialize do
    require "ruport"
    end
    # **SEE CONFIG_LOAD_PATHS ABOVE and require "app/reports/templates"
    BELOW**
    ###########################

    # Force all environments to use the same logger level
    # (by default production uses :info, the others :debug)
    # config.log_level = :debug

    # Use the database for sessions instead of the file system
    # which shouldn't be used to store highly confidential information
    # (create the session table with 'rake db:sessions:create')
    Have you done the above? Either do that and/or comment out the line
    below, at least until it is working.
    config.action_controller.session_store = :active_record_store

    # Use SQL instead of Active Record's schema dumper when creating the test
    database.
    # This is necessary if your schema can't be completely dumped by the
    schema dumper,
    # like if you have constraints or database-specific column types
    # config.active_record.schema_format = :sql

    # Activate observers that should always be running
    # config.active_record.observers = :cacher, :garbage_collector

    # Make Time.zone default to the specified zone, and make Active Record
    store time values
    # in the database in UTC, and return them converted to the specified
    local zone.
    # Run "rake -D time" for a list of tasks for finding time zone names.
    Comment line to use default local time.
    config.active_record.default_timezone = :utc


    # See Rails::Configuration for more options

    # Your secret key for verifying cookie session data integrity.
    # If you change this key, all old sessions will become invalid!
    # Make sure the secret is at least 30 characters and all random,
    # no regular words or you'll be exposed to dictionary attacks.
    config.action_controller.session = {
    :key => "_gg_session",
    That should be :session_key I think, at least that is what I have, in
    which case the error message is wrong.
    :secret =>
    "caf079519f0a811fa0ba9a0a3202c93f62d9f86ca4f1981harverdouccioe55e3869ee4aa8cbb48aecb518f1059103b7eb49b513f4d6ddc40d92e9488785eb90689229ad"
    }

    config.gem "authlogic"
    config.gem "actionmailer"
    config.gem "calendar_date_select"
    config.gem "paginator"
    config.gem "builder"
    end

    require "app/reports/templates"

    # Add new inflection rules using the following format
    # (all these examples are active by default):
    # Inflector.inflections do |inflect|
    # inflect.plural /^(ox)$/i, '\1en'
    # inflect.singular /^(ox)en/i, '\1'
    # inflect.irregular 'person', 'people'
    # inflect.uncountable %w( fish sheep )
    # end



    # Include your application configuration below
    Colin

    -
    Colin, I made the changes you said to make here (I did, well before, do
    rake db:sessions:create and have the table resident in the db). I;ve lso
    tried using :session_key in instead of :key.....noe of which seems to be
    affecting it:

    ruby script/server
    /home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/session/cookie_store.rb:163:in
    `ensure_session_key': A key is required to write a cookie containing the
    session data. Use config.action_controller.session = { :key =>
    "_myapp_session", :secret => "some secret phrase" } in
    config/environment.rb (ArgumentError)
         from
    /home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/session/cookie_store.rb:74:in
    `initialize'

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKUd5cw4_OhHUBoOWv7xnN9%3D-rC%3DmJp2jT65Am%2BR1d4VzQ%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ralph Vince at Oct 28, 2013 at 9:51 pm
    I think the issue may be something else Colin. For example, this error
    seems to crop up no matte what the command is:

    user@Mint15-32 ~/ggrip/ggripv2 $ rake rails:update
    rake aborted!
    A key is required to write a cookie containing the session data. Use
    config.action_controller.session = { :key => "_myapp_session", :secret =>
    "some secret phrase" } in config/environment.rb
    /home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/session/cookie_store.rb:163:in
    `ensure_session_key'


    On Mon, Oct 28, 2013 at 5:46 PM, Ralph Vince wrote:

    On Mon, Oct 28, 2013 at 5:32 PM, Colin Law wrote:
    On 28 October 2013 21:19, Ralph Vince wrote:



    On Mon, Oct 28, 2013 at 5:12 PM, Colin Law <clanlaw@googlemail.com>
    wrote:

    Can you paste your environment.rb here please?

    Colin

    Thanks Colin!

    # Be sure to restart your web server when you modify this file.

    # Uncomment below to force Rails into production mode when
    # you don't control web/app server and can't set it the proper way
    # ENV['RAILS_ENV'] ||= 'production'

    # Specifies gem version of Rails to use when vendor/rails is not present
    # RAILS_GEM_VERSION = '2.1.2' unless defined? RAILS_GEM_VERSION
    The above line should not be commented out, but should of course
    reference '2.3.2'. I don't know whether that might have anything to
    do with it or not.
    # Bootstrap the Rails environment, frameworks, and default configuration
    require File.join(File.dirname(__FILE__), 'boot')
    require 'paginator'
    The line above should not be there, again I don't know whether it is
    relevant to the problem.
    Rails::Initializer.run do |config|

    # Settings in config/environments/* take precedence those specified here
    # Skip frameworks you're not going to use
    #config.frameworks -= [ :action_web_service, :action_mailer ]

    # Add additional load paths for your own custom dirs
    # config.load_paths += %W( #{RAILS_ROOT}/extras )
    config.load_paths += %W( #{RAILS_ROOT}/app/reports )

    # Required for Ruports: ############
    config.after_initialize do
    require "ruport"
    end
    # **SEE CONFIG_LOAD_PATHS ABOVE and require "app/reports/templates"
    BELOW**
    ###########################

    # Force all environments to use the same logger level
    # (by default production uses :info, the others :debug)
    # config.log_level = :debug

    # Use the database for sessions instead of the file system
    # which shouldn't be used to store highly confidential information
    # (create the session table with 'rake db:sessions:create')
    Have you done the above? Either do that and/or comment out the line
    below, at least until it is working.
    config.action_controller.session_store = :active_record_store

    # Use SQL instead of Active Record's schema dumper when creating the test
    database.
    # This is necessary if your schema can't be completely dumped by the
    schema dumper,
    # like if you have constraints or database-specific column types
    # config.active_record.schema_format = :sql

    # Activate observers that should always be running
    # config.active_record.observers = :cacher, :garbage_collector

    # Make Time.zone default to the specified zone, and make Active Record
    store time values
    # in the database in UTC, and return them converted to the specified
    local zone.
    # Run "rake -D time" for a list of tasks for finding time zone names.
    Comment line to use default local time.
    config.active_record.default_timezone = :utc


    # See Rails::Configuration for more options

    # Your secret key for verifying cookie session data integrity.
    # If you change this key, all old sessions will become invalid!
    # Make sure the secret is at least 30 characters and all random,
    # no regular words or you'll be exposed to dictionary attacks.
    config.action_controller.session = {
    :key => "_gg_session",
    That should be :session_key I think, at least that is what I have, in
    which case the error message is wrong.
    :secret =>
    "caf079519f0a811fa0ba9a0a3202c93f62d9f86ca4f1981harverdouccioe55e3869ee4aa8cbb48aecb518f1059103b7eb49b513f4d6ddc40d92e9488785eb90689229ad"
    }

    config.gem "authlogic"
    config.gem "actionmailer"
    config.gem "calendar_date_select"
    config.gem "paginator"
    config.gem "builder"
    end

    require "app/reports/templates"

    # Add new inflection rules using the following format
    # (all these examples are active by default):
    # Inflector.inflections do |inflect|
    # inflect.plural /^(ox)$/i, '\1en'
    # inflect.singular /^(ox)en/i, '\1'
    # inflect.irregular 'person', 'people'
    # inflect.uncountable %w( fish sheep )
    # end



    # Include your application configuration below
    Colin

    -
    Colin, I made the changes you said to make here (I did, well before, do
    rake db:sessions:create and have the table resident in the db). I;ve lso
    tried using :session_key in instead of :key.....noe of which seems to be
    affecting it:


    ruby script/server
    /home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/session/cookie_store.rb:163:in
    `ensure_session_key': A key is required to write a cookie containing the
    session data. Use config.action_controller.session = { :key =>
    "_myapp_session", :secret => "some secret phrase" } in
    config/environment.rb (ArgumentError)
    from
    /home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/session/cookie_store.rb:74:in
    `initialize'
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKWs216T6TuvAWPR8q0QbmSgMy73kUd0A5zz06__U5p-dg%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Colin Law at Oct 28, 2013 at 10:00 pm

    On 28 October 2013 21:51, Ralph Vince wrote:
    I think the issue may be something else Colin. For example, this error seems
    to crop up no matte what the command is:

    user@Mint15-32 ~/ggrip/ggripv2 $ rake rails:update
    rake aborted!

    A key is required to write a cookie containing the session data. Use
    config.action_controller.session = { :key => "_myapp_session", :secret =>
    "some secret phrase" } in config/environment.rb
    /home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/session/cookie_store.rb:163:in
    `ensure_session_key'
    That is not all that surprising, it has to load the environment in
    order to run rake.

    Colin

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLtS%2BmRoTXEHHURFYtVE3Ogb7sOCt5MwxNTrCPWM8%2Bj9aA%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Colin Law at Oct 28, 2013 at 9:59 pm

    On 28 October 2013 21:46, Ralph Vince wrote:
    Colin, I made the changes you said to make here (I did, well before, do rake
    db:sessions:create and have the table resident in the db). I;ve lso tried
    using :session_key in instead of :key.....noe of which seems to be affecting
    it:


    ruby script/server
    /home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/session/cookie_store.rb:163:in
    `ensure_session_key': A key is required to write a cookie containing the
    session data. Use config.action_controller.session = { :key =>
    "_myapp_session", :secret => "some secret phrase" } in config/environment.rb
    (ArgumentError)
    from
    /home/user/.rvm/gems/ruby-1.8.6-p420/gems/actionpack-2.3.2/lib/action_controller/session/cookie_store.rb:74:in
    `initialize'
    It is very odd, firstly it should not be using the cookie store, and
    if it were then you have provided the session key. I have tried it
    and it works for me with either :key or :session_key, and if I enable
    the active_record_store then it does not ask in the first place.

    Can you post development.rb please.

    Colin

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLvZjFMekMG4rUgbJ7d4XetrAfDcNodHcEeSD7LprdsC9A%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ralph Vince at Oct 28, 2013 at 10:04 pm

    On Mon, Oct 28, 2013 at 5:58 PM, Colin Law wrote:

    It is very odd, firstly it should not be using the cookie store, and
    if it were then you have provided the session key. I have tried it
    and it works for me with either :key or :session_key, and if I enable
    the active_record_store then it does not ask in the first place.

    Can you post development.rb please.

    Colin

    Thanks Colin, Development.rb:
    # Settings specified here will take precedence over those in
    config/environment.rb
    #require "ruby-debug"

    # In the development environment your application's code is reloaded on
    # every request. This slows down response time but is perfect for
    development
    # since you don't have to restart the webserver when you make code changes.
    config.cache_classes = false

    # Log error messages when you accidentally call methods on nil.
    config.whiny_nils = true

    # Enable the breakpoint server that script/breakpointer connects to
    #config.breakpoint_server = true

    # Show full error reports and disable caching
    config.action_controller.consider_all_requests_local = true
    config.action_controller.perform_caching = false
    #config.action_view.cache_template_extensions = false
    config.action_view.debug_rjs = true

    # config/environments/development.rb
    config.action_mailer.raise_delivery_errors = true

    # set delivery method to :smtp, :sendmail or :test
    config.action_mailer.delivery_method = :smtp

    #set default type to html. Options are "text/plain", "text/html", and
    "text/enriched". The default value is "text/plain".
    config.action_mailer.default_content_type = "text/html"

    # these options are only needed if you choose smtp delivery
    config.action_mailer.smtp_settings = {
       :address => 'outgoing.verizon.net',
       :port => 25,
       :domain => 'www.example.com',
       :authentication => :login,
       :user_name => 'cfgsr',
       :password => 'p6687sq5'
    }

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKXD42p_TjyJ74ohw9qppR0HMHTKCfPRa-%3Dm_f1pOAtoGQ%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ralph Vince at Oct 28, 2013 at 10:10 pm
    Wait,

    Stupid me.

    The database login parameters have changed -- when I change that, it gets
    past that error (give me a new one, of coursem but that must be the
    problem). I fixed it in database.yml.

    On Mon, Oct 28, 2013 at 6:04 PM, Ralph Vince wrote:



    On Mon, Oct 28, 2013 at 5:58 PM, Colin Law wrote:



    It is very odd, firstly it should not be using the cookie store, and
    if it were then you have provided the session key. I have tried it
    and it works for me with either :key or :session_key, and if I enable
    the active_record_store then it does not ask in the first place.

    Can you post development.rb please.

    Colin

    Thanks Colin, Development.rb:
    # Settings specified here will take precedence over those in
    config/environment.rb
    #require "ruby-debug"

    # In the development environment your application's code is reloaded on
    # every request. This slows down response time but is perfect for
    development
    # since you don't have to restart the webserver when you make code changes.
    config.cache_classes = false

    # Log error messages when you accidentally call methods on nil.
    config.whiny_nils = true

    # Enable the breakpoint server that script/breakpointer connects to
    #config.breakpoint_server = true

    # Show full error reports and disable caching
    config.action_controller.consider_all_requests_local = true
    config.action_controller.perform_caching = false
    #config.action_view.cache_template_extensions = false
    config.action_view.debug_rjs = true

    # config/environments/development.rb
    config.action_mailer.raise_delivery_errors = true

    # set delivery method to :smtp, :sendmail or :test
    config.action_mailer.delivery_method = :smtp

    #set default type to html. Options are "text/plain", "text/html", and
    "text/enriched". The default value is "text/plain".
    config.action_mailer.default_content_type = "text/html"

    # these options are only needed if you choose smtp delivery
    config.action_mailer.smtp_settings = {
    :address => 'outgoing.verizon.net',
    :port => 25,
    :domain => 'www.example.com',
    :authentication => :login,
    :user_name => 'cfgsr',
    :password => 'p6687sq5'
    }


    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKU3PzOskh%3DKnfb_FBBagFsyKo%3D%3DfZyi0YuwgO8h9jd1GA%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ralph Vince at Oct 28, 2013 at 10:13 pm
    And...once I get that one fixed...I'm right back to the original error!

    On Mon, Oct 28, 2013 at 6:10 PM, Ralph Vince wrote:

    Wait,

    Stupid me.

    The database login parameters have changed -- when I change that, it gets
    past that error (give me a new one, of coursem but that must be the
    problem). I fixed it in database.yml.

    On Mon, Oct 28, 2013 at 6:04 PM, Ralph Vince wrote:



    On Mon, Oct 28, 2013 at 5:58 PM, Colin Law wrote:



    It is very odd, firstly it should not be using the cookie store, and
    if it were then you have provided the session key. I have tried it
    and it works for me with either :key or :session_key, and if I enable
    the active_record_store then it does not ask in the first place.

    Can you post development.rb please.

    Colin

    Thanks Colin, Development.rb:
    # Settings specified here will take precedence over those in
    config/environment.rb
    #require "ruby-debug"

    # In the development environment your application's code is reloaded on
    # every request. This slows down response time but is perfect for
    development
    # since you don't have to restart the webserver when you make code
    changes.
    config.cache_classes = false

    # Log error messages when you accidentally call methods on nil.
    config.whiny_nils = true

    # Enable the breakpoint server that script/breakpointer connects to
    #config.breakpoint_server = true

    # Show full error reports and disable caching
    config.action_controller.consider_all_requests_local = true
    config.action_controller.perform_caching = false
    #config.action_view.cache_template_extensions = false
    config.action_view.debug_rjs = true

    # config/environments/development.rb
    config.action_mailer.raise_delivery_errors = true

    # set delivery method to :smtp, :sendmail or :test
    config.action_mailer.delivery_method = :smtp

    #set default type to html. Options are "text/plain", "text/html", and
    "text/enriched". The default value is "text/plain".
    config.action_mailer.default_content_type = "text/html"

    # these options are only needed if you choose smtp delivery
    config.action_mailer.smtp_settings = {
    :address => 'outgoing.verizon.net',
    :port => 25,
    :domain => 'www.example.com',
    :authentication => :login,
    :user_name => 'cfgsr',
    :password => 'p6687sq5'
    }


    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKVP7kov3d5AvvCRLimf4KPdOo0GQqGWfR%2BmC%3DHe1Tb13g%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ralph Vince at Oct 28, 2013 at 10:18 pm
    Thanks Colin.

    How would you enable active_record_store? Perhaps I should try that first?

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKVs3ga9g0r3Vt1t7o7_4PWKvMqa%2B%2BxSxszqanOds0MC6A%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ralph Vince at Oct 28, 2013 at 10:30 pm
    I think there's more wrong here than what the error message suggests. For
    example:

    user@Mint15-32 ~/ggrip/ggripv2 $ gem install rails -v 2.3.2
    Successfully installed rails-2.3.2
    1 gem installed
    Installing ri documentation for rails-2.3.2...
    Installing RDoc documentation for rails-2.3.2...

    user@Mint15-32 ~/ggrip/ggripv2 $ rails -v
    The program 'rails' can be found in the following packages:
      * rails
      * ruby-railties-3.2
    Try: sudo apt-get install <selected package>


    When I did rails - v, shouldn;t it have just returned 2.3.2 ?

    On Mon, Oct 28, 2013 at 6:18 PM, Ralph Vince wrote:

    Thanks Colin.

    How would you enable active_record_store? Perhaps I should try that first?
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKVuSHYWDXt0yRqF%3Dv-ErfaQ3XAhycqm1RJ_xK16QAVWZA%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Walter Lee Davis at Oct 28, 2013 at 10:33 pm

    On Oct 28, 2013, at 6:29 PM, Ralph Vince wrote:

    I think there's more wrong here than what the error message suggests. For example:

    user@Mint15-32 ~/ggrip/ggripv2 $ gem install rails -v 2.3.2
    Successfully installed rails-2.3.2
    1 gem installed
    Installing ri documentation for rails-2.3.2...
    Installing RDoc documentation for rails-2.3.2...

    user@Mint15-32 ~/ggrip/ggripv2 $ rails -v
    The program 'rails' can be found in the following packages:
    * rails
    * ruby-railties-3.2
    Try: sudo apt-get install <selected package>


    When I did rails - v, shouldn;t it have just returned 2.3.2 ?
    Yes. I'm late to the party here, but are you using rvm on this server? What does your PATH look like? If you aren't using rvm, then have you tried using sudo, as in

    sudo gem install rails -v 2.3.2

    Without rvm, you may be installing these binaries somewhere that your PATH can't find them.

    Walter

    On Mon, Oct 28, 2013 at 6:18 PM, Ralph Vince wrote:
    Thanks Colin.

    How would you enable active_record_store? Perhaps I should try that first?


    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKVuSHYWDXt0yRqF%3Dv-ErfaQ3XAhycqm1RJ_xK16QAVWZA%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/E5B183DC-33D7-4BDF-A89E-9274833914FE%40wdstudio.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • R Vince at Oct 28, 2013 at 10:42 pm

    On Mon, Oct 28, 2013 at 6:33 PM, Walter Lee Davis wrote:
    Yes. I'm late to the party here, but are you using rvm on this server?
    What does your PATH look like? If you aren't using rvm, then have you tried
    using sudo, as in

    sudo gem install rails -v 2.3.2

    Without rvm, you may be installing these binaries somewhere that your PATH
    can't find them.

    Walter
    Walter,

    I AM using rvm. My path:

    user@Mint15-32 ~/ggrip/ggripv2 $ echo $PATH
    /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/user/.rvm/bin

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKX8X12K1rsDL-_HaqtLrB8rkttW9yqGEbCyhDEbBN-3mw%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Hassan Schroeder at Oct 28, 2013 at 11:31 pm

    On Mon, Oct 28, 2013 at 3:42 PM, R Vince wrote:

    I AM using rvm. My path:

    user@Mint15-32 ~/ggrip/ggripv2 $ echo $PATH
    /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/user/.rvm/bin
    Uh, well. It looks like rvm is installed, but you're not actually using it.
    If you were, your path would start with the rvm bin directories for the
    ruby and gemset you'd selected. Which it obviously doesn't.

    Easy test: what does `rvm current` report? If it's not what you want,
    that's the first thing to fix.

    --
    Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
    http://about.me/hassanschroeder
    twitter: @hassan

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CACmC4yAjuBVyd9LrBQOGxEiZPjQcDAYa3LA53e0SHBHpBd06DQ%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • R Vince at Oct 28, 2013 at 11:49 pm

    On Mon, Oct 28, 2013 at 7:30 PM, Hassan Schroeder wrote:
    On Mon, Oct 28, 2013 at 3:42 PM, R Vince wrote:

    I AM using rvm. My path:

    user@Mint15-32 ~/ggrip/ggripv2 $ echo $PATH
    /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/user/.rvm/bin

    Uh, well. It looks like rvm is installed, but you're not actually using it.
    If you were, your path would start with the rvm bin directories for the
    ruby and gemset you'd selected. Which it obviously doesn't.

    Easy test: what does `rvm current` report? If it's not what you want,
    that's the first thing to fix.


    Hassan,
    user@Mint15-32 ~/ggrip/ggripv2 $ rvm current
    ruby-1.8.6-p420

    which is correct. The /home/user/.rvm/bin in the PATH is correct, yes? What
    else are you saying should be in the PATH? THanks.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKWa_kjG13TOSU%2BiDCG-H948izyPJYY7ANFgpzDaJrsgjw%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Hassan Schroeder at Oct 29, 2013 at 12:09 am

    On Mon, Oct 28, 2013 at 4:49 PM, R Vince wrote:

    user@Mint15-32 ~/ggrip/ggripv2 $ rvm current
    ruby-1.8.6-p420

    which is correct. The /home/user/.rvm/bin in the PATH is correct, yes? What
    else are you saying should be in the PATH? THanks.
    When you install gems that include a command-line component, e.g.
    rails, the executables need to live somewhere in your path. Here's an
    example from one of my rvm gemsets:

    /Users/hassan/.rvm/gems/ruby-2.0.0-p247@rails4/bin:/Users/hassan/.rvm/gems/ruby-2.0.0-p247@global/bin:/Users/hassan/.rvm/rubies/ruby-2.0.0-p247/bin:/Users/hassan/.rvm/bin:
    ... etc. ....

    You clearly don't have `rails` in your path, even though you installed
    the gem. So you need to fix this before proceeding. Personally, I'd
    create a gemset specifically for this app and add a .rvmrc to the dir
    where it lives.

    --
    Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
    http://about.me/hassanschroeder
    twitter: @hassan

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CACmC4yDz1aUvNu8qbn0Ao%2BZuVkMU3uE3pwNaGoELdVZZbYGVWg%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • R Vince at Oct 29, 2013 at 12:22 am

    On Mon, Oct 28, 2013 at 8:09 PM, Hassan Schroeder wrote:
    When you install gems that include a command-line component, e.g.
    rails, the executables need to live somewhere in your path. Here's an
    example from one of my rvm gemsets:

    /Users/hassan/.rvm/gems/ruby-2.0.0-p247@rails4
    /bin:/Users/hassan/.rvm/gems/ruby-2.0.0-p247@global
    /bin:/Users/hassan/.rvm/rubies/ruby-2.0.0-p247/bin:/Users/hassan/.rvm/bin:
    ... etc. ....

    You clearly don't have `rails` in your path, even though you installed
    the gem. So you need to fix this before proceeding. Personally, I'd
    create a gemset specifically for this app and add a .rvmrc to the dir
    where it lives.
    Thanks Hassan. I'll go and learn how to create the gemset then. The
    alternative I am thinking at this point is, for the third time, recreate
    the linux VM, starting with a clean linux vm and begin installing
    everything anew without rvm, I wont be needing other versions of Ruby/Rails
    on this thing (Ill create new Linux VMs for that) and given that I only
    need one instance, I should perhaps look to do this without rvm or even a
    gemset.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKUv2fwRL0uKpHFNBxQ2cVRT2naD4YvED4yfv2h6wjZipg%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • R Vince at Oct 29, 2013 at 2:43 am
    Hassan,

    So, according to your instructions, do I need to only add the path to
    rails? Where would that be under .rvm? Thank you!

    On Mon, Oct 28, 2013 at 8:09 PM, Hassan Schroeder wrote:



    When you install gems that include a command-line component, e.g.
    rails, the executables need to live somewhere in your path. Here's an
    example from one of my rvm gemsets:

    /Users/hassan/.rvm/gems/ruby-2.0.0-p247@rails4
    /bin:/Users/hassan/.rvm/gems/ruby-2.0.0-p247@global
    /bin:/Users/hassan/.rvm/rubies/ruby-2.0.0-p247/bin:/Users/hassan/.rvm/bin:
    ... etc. ....

    You clearly don't have `rails` in your path, even though you installed
    the gem. So you need to fix this before proceeding. Personally, I'd
    create a gemset specifically for this app and add a .rvmrc to the dir
    where it lives.

    --
    Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
    http://about.me/hassanschroeder
    twitter: @hassan

    --
    You received this message because you are subscribed to a topic in the
    Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this topic, visit
    https://groups.google.com/d/topic/rubyonrails-talk/__P7NpklLsM/unsubscribe
    .
    To unsubscribe from this group and all its topics, send an email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/rubyonrails-talk/CACmC4yDz1aUvNu8qbn0Ao%2BZuVkMU3uE3pwNaGoELdVZZbYGVWg%40mail.gmail.com
    .
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAAHNhKXQ%3Di2w69pyU9OWzd%2BULnW8hERCD%3DkNw%3DVTDGCoiJBHgQ%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Colin Law at Oct 28, 2013 at 10:10 pm

    On 28 October 2013 22:04, Ralph Vince wrote:

    On Mon, Oct 28, 2013 at 5:58 PM, Colin Law wrote:



    It is very odd, firstly it should not be using the cookie store, and
    if it were then you have provided the session key. I have tried it
    and it works for me with either :key or :session_key, and if I enable
    the active_record_store then it does not ask in the first place.

    Can you post development.rb please.

    Colin
    Thanks Colin, Development.rb:

    # Settings specified here will take precedence over those in
    config/environment.rb
    #require "ruby-debug"

    # In the development environment your application's code is reloaded on
    # every request. This slows down response time but is perfect for
    development
    # since you don't have to restart the webserver when you make code changes.
    config.cache_classes = false

    # Log error messages when you accidentally call methods on nil.
    config.whiny_nils = true

    # Enable the breakpoint server that script/breakpointer connects to
    #config.breakpoint_server = true

    # Show full error reports and disable caching
    config.action_controller.consider_all_requests_local = true
    config.action_controller.perform_caching = false
    #config.action_view.cache_template_extensions = false
    config.action_view.debug_rjs = true

    # config/environments/development.rb
    config.action_mailer.raise_delivery_errors = true

    # set delivery method to :smtp, :sendmail or :test
    config.action_mailer.delivery_method = :smtp

    #set default type to html. Options are "text/plain", "text/html", and
    "text/enriched". The default value is "text/plain".
    config.action_mailer.default_content_type = "text/html"

    # these options are only needed if you choose smtp delivery
    config.action_mailer.smtp_settings = {
    :address => 'outgoing.verizon.net',
    :port => 25,
    :domain => 'www.example.com',
    :authentication => :login,
    :user_name => 'cfgsr',
    :password => 'p6687sq5'
    }
    That all looks ok. Sorry I am out of ideas. I can only suggest that
    you try making a new app (I can't remember how to do that in rails 2,
    you will have to look it up if you don't know), and see if that works.
      Then if that works add stuff in from your app till it breaks.

    Colin

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLu--P2ZegvX%2BkAr9G2S-yC0O-3fLyk5i%3DMJN88N7vKrTQ%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedOct 28, '13 at 7:45p
activeOct 29, '13 at 2:43a
posts23
users5
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2021 Grokbase