Host: DigitalOcean
OS: Ubuntu 12.04
Ruby: 2.0.0p247
Rails: 3.2.0
* LAMP installed.
* Switched WEBrick out for Thin.

I'm trying to follow a tutorial online (hence the Rails 3.2.0 version).
I make my blog (rails new quick_blog -T). I then run 'rails server' and
I can see it start fine at the console.

I then try and hit the IP:3000 and get nothing. If I hit the IP then I
get the default Apache page.

Can anyone offer some assistance?

phoyce

--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/a3bd7883dbd9b0ecdcf3058d67418ed9%40ruby-forum.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Walter Lee Davis at Sep 25, 2013 at 5:34 pm
    Usually, the :3000 is when you are hosting the site on your development machine, and you can serve with Thin or Webrick from localhost:3000 after starting the server on your console. But if you do that on your server, the only "person" who will be able to network to it will be another user on the server itself.

    If you're just doing a tutorial, why get a server involved at all? Just host it on your Mac, start the server from the terminal as you have done, and open up a browser to localhost:3000.

    If you want to share your work with others, then use Passenger on your Digital Ocean machine, or use Heroku or another one-button hosting provider for that.

    Walter
    On Sep 25, 2013, at 11:17 AM, Phil Boyce wrote:

    Host: DigitalOcean
    OS: Ubuntu 12.04
    Ruby: 2.0.0p247
    Rails: 3.2.0
    * LAMP installed.
    * Switched WEBrick out for Thin.

    I'm trying to follow a tutorial online (hence the Rails 3.2.0 version).
    I make my blog (rails new quick_blog -T). I then run 'rails server' and
    I can see it start fine at the console.

    I then try and hit the IP:3000 and get nothing. If I hit the IP then I
    get the default Apache page.

    Can anyone offer some assistance?

    phoyce

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/a3bd7883dbd9b0ecdcf3058d67418ed9%40ruby-forum.com.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/928E4985-05C3-458D-8C3A-620EBF2E5D45%40wdstudio.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Prashant at Sep 29, 2013 at 7:55 am
    Can you try http://localhost:3000

    On Wednesday, September 25, 2013 8:47:56 PM UTC+5:30, Ruby-Forum.com User
    wrote:
    Host: DigitalOcean
    OS: Ubuntu 12.04
    Ruby: 2.0.0p247
    Rails: 3.2.0
    * LAMP installed.
    * Switched WEBrick out for Thin.

    I'm trying to follow a tutorial online (hence the Rails 3.2.0 version).
    I make my blog (rails new quick_blog -T). I then run 'rails server' and
    I can see it start fine at the console.

    I then try and hit the IP:3000 and get nothing. If I hit the IP then I
    get the default Apache page.

    Can anyone offer some assistance?

    phoyce

    --
    Posted via http://www.ruby-forum.com/.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/b7f25885-02f5-4ead-8f6e-7c323ab787ee%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Walter Lee Davis at Sep 29, 2013 at 5:45 pm
    If you are running your Web browser on the server, then certainly, that would be the path to the server. But localhost is always _your_ computer. The one where you are running the browser, in this context.

    Walter
    On Sep 25, 2013, at 12:51 PM, Prashant wrote:

    Can you try http://localhost:3000

    On Wednesday, September 25, 2013 8:47:56 PM UTC+5:30, Ruby-Forum.com User wrote:
    Host: DigitalOcean
    OS: Ubuntu 12.04
    Ruby: 2.0.0p247
    Rails: 3.2.0
    * LAMP installed.
    * Switched WEBrick out for Thin.

    I'm trying to follow a tutorial online (hence the Rails 3.2.0 version).
    I make my blog (rails new quick_blog -T). I then run 'rails server' and
    I can see it start fine at the console.

    I then try and hit the IP:3000 and get nothing. If I hit the IP then I
    get the default Apache page.

    Can anyone offer some assistance?

    phoyce

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/b7f25885-02f5-4ead-8f6e-7c323ab787ee%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/3BA308A8-D935-4A44-B0B5-988CFB4317A8%40wdstudio.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedSep 25, '13 at 3:18p
activeSep 29, '13 at 5:45p
posts4
users3
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase