Hello all,

I don't have much experience with OmniAuth and I am trying to figure out
what is going on with my routes.

My app is currently running rails 3.1.3. When I run rake routes this is
what I see for my user call back:

  user_omniauth_callback /users/auth/:action/callback(.:format)

{:action=>/company_authentication/, :controller=>"users/omniauth_callbacks"}

Things seem to function without any issue.

I am attempting to upgrade my app to rails 3.2.13. When I run rake routes
this is what I see:

user_omniauth_callback /users/auth/:action/callback(.:format)

users/omniauth_callbacks#(?-mix:company_authentication)

I am not sure I understand what has changed and how to fix it. The error
that I currently getting with this route is:

ActionController::RoutingError (uninitialized constant
Users::OmniauthCallbacksController)

Does anyone have any ideas on how I can go about looking into this issue?


--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/95a02eb5-68f9-4b19-a214-5e4a3347683d%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedAug 1, '13 at 3:35p
activeAug 1, '13 at 3:35p
posts1
users1
websiterubyonrails.org
irc#RubyOnRails

1 user in discussion

Vell: 1 post

People

Translate

site design / logo © 2022 Grokbase