I am a php programmer, learning ruby on rails
I am using ubuntu 10.10. i am not so fine with linux.
i have installed ruby, gems etc.
I want to make app with using mysql.

I have used *$ rails new clogs_web_app -d mysql* to make app but
the process stops with this statement *Gem::Installer::ExtensionBuildError:
ERROR: Failed to build gem native extension.*
it give me error : *
An error occurred while installing mysql2 (0.3.11), and Bundler cannot
continue.
Make sure that `gem install mysql2 -v '0.3.11'` succeeds before bundling.*

Please help me to gatting out.
Thanks in advance



--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msg/rubyonrails-talk/-/bJfu2qeOSIgJ.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Hassan Schroeder at Dec 25, 2012 at 5:42 pm

    On Tue, Dec 25, 2012 at 6:40 AM, Ashvin Gargave wrote:

    ERROR: Failed to build gem native extension.
    it give me error :
    An error occurred while installing mysql2 (0.3.11), and Bundler cannot
    continue.
    Make sure that `gem install mysql2 -v '0.3.11'` succeeds before bundling.
    I'll bet that message also referenced a log file for the installation
    process; have you looked at it?

    --
    Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
    http://about.me/hassanschroeder
    twitter: @hassan

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Norbert Melzer at Dec 25, 2012 at 6:34 pm
    You need to install ruby-Dev and mysql-Dev packages.

    sudo apt-get install ruby-Dev mysql-dev

    Could also be Devel instead of Dev, not sure about that at the moment.

    Also it may be that you have to purge and reinstall ruby after that to get
    it working. This part is covered in any ruby with Ubuntu tutorial I am
    aware of.

    Another one is that you really shouldn't use 10.10 any more. 12.04 is the
    latest Ubuntu with Long Term Support. 10.10 not supported anymore as far as
    I remember.
    Am 25.12.2012 17:46 schrieb "Ashvin Gargave" <ashvin.gargave@techvalens.com
    :
    I am a php programmer, learning ruby on rails
    I am using ubuntu 10.10. i am not so fine with linux.
    i have installed ruby, gems etc.
    I want to make app with using mysql.

    I have used *$ rails new clogs_web_app -d mysql* to make app but
    the process stops with this statement *Gem::Installer::ExtensionBuildError:
    ERROR: Failed to build gem native extension.*
    it give me error : *
    An error occurred while installing mysql2 (0.3.11), and Bundler cannot
    continue.
    Make sure that `gem install mysql2 -v '0.3.11'` succeeds before bundling.*

    Please help me to gatting out.
    Thanks in advance



    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/rubyonrails-talk/-/bJfu2qeOSIgJ.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Hassan Schroeder at Dec 25, 2012 at 10:12 pm

    On Tue, Dec 25, 2012 at 10:34 AM, Norbert Melzer wrote:

    Another one is that you really shouldn't use 10.10 any more. 12.04 is the
    latest Ubuntu with Long Term Support.
    It might have "Long Term Support" but it also includes "Regular
    File System Corruption" :-)

    Based on personal experience (substantiated by Rackspace Cloud
    support as well as a bit of googling...).

    FWIW, YMMV, etc.
    --
    Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
    http://about.me/hassanschroeder
    twitter: @hassan

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedDec 25, '12 at 4:46p
activeDec 25, '12 at 10:12p
posts4
users3
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase