Hello All,

I am getting this error while running bundle install from console...........
I tried to install libyaml & libtool & reinstalled all ruby.
But still I am getting the same error :-
Ruby - 1.9.3-p194
Jruby- 1.6.8
Rails - 3.2.6


Unfortunately, a fatal error has occurred. Please see the Bundler
troubleshooting documentation at http://bit.ly/bundler-issues. Thanks!
/home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require': libcrypto.so.1.0.0: cannot open shared object file: No such file
or directory -
/home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/i686-linux/digest/sha1.so
(LoadError)
from
/home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
from
/home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/definition.rb:1:in
`<top (required)>'
from
/home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler.rb:144:in
`definition'
from
/home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/cli.rb:228:in
`install'
from
/home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/task.rb:27:in
`run'
from
/home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/invocation.rb:120:in
`invoke_task'
from
/home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor.rb:275:in
`dispatch'
from
/home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/base.rb:408:in
`start'
from
/home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
`block in <top (required)>'
from
/home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/friendly_errors.rb:4:in
`with_friendly_errors'
from
/home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
`<top (required)>'
from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `load'
from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `<main>'
from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in
`eval'
from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in
`<main>'


Any guide will be helpful...
Thanks

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msg/rubyonrails-talk/-/uZ-aasgriFwJ.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Jim Ruther Nill at Oct 16, 2012 at 12:28 pm

    On Tue, Oct 16, 2012 at 8:17 PM, Avi wrote:

    Hello All,

    I am getting this error while running bundle install from
    console...........
    I tried to install libyaml & libtool & reinstalled all ruby.
    But still I am getting the same error :-
    Ruby - 1.9.3-p194
    Jruby- 1.6.8
    Rails - 3.2.6


    Unfortunately, a fatal error has occurred. Please see the Bundler
    troubleshooting documentation at http://bit.ly/bundler-issues. Thanks!
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require': libcrypto.so.1.0.0: cannot open shared object file: No such file
    or directory -
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/i686-linux/digest/sha1.so
    (LoadError)
    hi! i recently upgraded to precise pangolin and i encountered issues like
    this one. usually, when you see errors like these, search
    for the missing library and install the package that contains it. For this
    error, the package you want is libssl1.0.0 (in ubuntu). so install
    that by sudo apt-get install libssl1.0.0 (in ubuntu).

    from
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/definition.rb:1:in
    `<top (required)>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler.rb:144:in
    `definition'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/cli.rb:228:in
    `install'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/task.rb:27:in
    `run'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/invocation.rb:120:in
    `invoke_task'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor.rb:275:in
    `dispatch'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/base.rb:408:in
    `start'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
    `block in <top (required)>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/friendly_errors.rb:4:in
    `with_friendly_errors'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
    `<top (required)>'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `load'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `<main>'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in
    `eval'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in
    `<main>'


    Any guide will be helpful...
    Thanks

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/rubyonrails-talk/-/uZ-aasgriFwJ.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    -------------------------------------------------------------
    visit my blog at http://jimlabs.heroku.com

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Avi at Oct 16, 2012 at 4:25 pm
    I executed the command :- But I am getting this. I am in Ubuntu 10.10
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package libssl1.0.0
    E: Couldn't find any package by regex 'libssl1.0.0'

    On Tuesday, October 16, 2012 5:58:27 PM UTC+5:30, jim wrote:



    On Tue, Oct 16, 2012 at 8:17 PM, Avi <aavinas...@gmail.com <javascript:>>wrote:
    Hello All,

    I am getting this error while running bundle install from
    console...........
    I tried to install libyaml & libtool & reinstalled all ruby.
    But still I am getting the same error :-
    Ruby - 1.9.3-p194
    Jruby- 1.6.8
    Rails - 3.2.6


    Unfortunately, a fatal error has occurred. Please see the Bundler
    troubleshooting documentation at http://bit.ly/bundler-issues. Thanks!
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require': libcrypto.so.1.0.0: cannot open shared object file: No such file
    or directory -
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/i686-linux/digest/sha1.so
    (LoadError)
    hi! i recently upgraded to precise pangolin and i encountered issues like
    this one. usually, when you see errors like these, search
    for the missing library and install the package that contains it. For
    this error, the package you want is libssl1.0.0 (in ubuntu). so install
    that by sudo apt-get install libssl1.0.0 (in ubuntu).

    from
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/definition.rb:1:in
    `<top (required)>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler.rb:144:in
    `definition'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/cli.rb:228:in
    `install'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/task.rb:27:in
    `run'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/invocation.rb:120:in
    `invoke_task'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor.rb:275:in
    `dispatch'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/base.rb:408:in
    `start'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
    `block in <top (required)>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/friendly_errors.rb:4:in
    `with_friendly_errors'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
    `<top (required)>'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `load'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `<main>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in
    `<main>'


    Any guide will be helpful...
    Thanks

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonra...@googlegroups.com<javascript:>
    .
    To unsubscribe from this group, send email to
    rubyonrails-ta...@googlegroups.com <javascript:>.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/rubyonrails-talk/-/uZ-aasgriFwJ.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    -------------------------------------------------------------
    visit my blog at http://jimlabs.heroku.com
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msg/rubyonrails-talk/-/m6H6PcxH33IJ.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Colin Law at Oct 16, 2012 at 12:47 pm

    On 16 October 2012 13:42, Avi wrote:
    I executed the command :- But I am getting this. I am in Ubuntu 10.10
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package libssl1.0.0
    E: Couldn't find any package by regex 'libssl1.0.0'
    Try
    sudo apt-get install openssl libssl-dev

    Colin

    On Tuesday, October 16, 2012 5:58:27 PM UTC+5:30, jim wrote:


    On Tue, Oct 16, 2012 at 8:17 PM, Avi wrote:

    Hello All,

    I am getting this error while running bundle install from
    console...........
    I tried to install libyaml & libtool & reinstalled all ruby.
    But still I am getting the same error :-
    Ruby - 1.9.3-p194
    Jruby- 1.6.8
    Rails - 3.2.6


    Unfortunately, a fatal error has occurred. Please see the Bundler
    troubleshooting documentation at http://bit.ly/bundler-issues. Thanks!

    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require': libcrypto.so.1.0.0: cannot open shared object file: No such file
    or directory -
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/i686-linux/digest/sha1.so
    (LoadError)

    hi! i recently upgraded to precise pangolin and i encountered issues like
    this one. usually, when you see errors like these, search
    for the missing library and install the package that contains it. For
    this error, the package you want is libssl1.0.0 (in ubuntu). so install
    that by sudo apt-get install libssl1.0.0 (in ubuntu).
    from
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/definition.rb:1:in
    `<top (required)>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler.rb:144:in
    `definition'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/cli.rb:228:in
    `install'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/task.rb:27:in
    `run'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/invocation.rb:120:in
    `invoke_task'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor.rb:275:in
    `dispatch'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/base.rb:408:in
    `start'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
    `block in <top (required)>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/friendly_errors.rb:4:in
    `with_friendly_errors'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
    `<top (required)>'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `load'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `<main>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in
    `<main>'


    Any guide will be helpful...
    Thanks

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonra...@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-ta...@googlegroups.com.

    To view this discussion on the web visit
    https://groups.google.com/d/msg/rubyonrails-talk/-/uZ-aasgriFwJ.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    -------------------------------------------------------------
    visit my blog at http://jimlabs.heroku.com
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/rubyonrails-talk/-/m6H6PcxH33IJ.

    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Avi at Oct 16, 2012 at 1:04 pm
    I tried with that. It is installing.
    But getting the same error while bundle install.
    On Tuesday, October 16, 2012 6:18:03 PM UTC+5:30, Colin Law wrote:
    On 16 October 2012 13:42, Avi <aavinas...@gmail.com <javascript:>> wrote:
    I executed the command :- But I am getting this. I am in Ubuntu 10.10
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package libssl1.0.0
    E: Couldn't find any package by regex 'libssl1.0.0'
    Try
    sudo apt-get install openssl libssl-dev

    Colin

    On Tuesday, October 16, 2012 5:58:27 PM UTC+5:30, jim wrote:


    On Tue, Oct 16, 2012 at 8:17 PM, Avi wrote:

    Hello All,

    I am getting this error while running bundle install from
    console...........
    I tried to install libyaml & libtool & reinstalled all ruby.
    But still I am getting the same error :-
    Ruby - 1.9.3-p194
    Jruby- 1.6.8
    Rails - 3.2.6


    Unfortunately, a fatal error has occurred. Please see the Bundler
    troubleshooting documentation at http://bit.ly/bundler-issues.
    Thanks!
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require': libcrypto.so.1.0.0: cannot open shared object file: No such
    file
    or directory -
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/i686-linux/digest/sha1.so
    (LoadError)

    hi! i recently upgraded to precise pangolin and i encountered issues
    like
    this one. usually, when you see errors like these, search
    for the missing library and install the package that contains it. For
    this error, the package you want is libssl1.0.0 (in ubuntu). so
    install
    that by sudo apt-get install libssl1.0.0 (in ubuntu).
    from
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/definition.rb:1:in
    `<top (required)>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler.rb:144:in
    `definition'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/cli.rb:228:in
    `install'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/task.rb:27:in
    `run'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/invocation.rb:120:in
    `invoke_task'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor.rb:275:in
    `dispatch'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/base.rb:408:in
    `start'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
    `block in <top (required)>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/friendly_errors.rb:4:in
    `with_friendly_errors'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
    `<top (required)>'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `load'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `<main>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in
    `eval'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in
    `<main>'


    Any guide will be helpful...
    Thanks

    --
    You received this message because you are subscribed to the Google
    Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonra...@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-ta...@googlegroups.com.

    To view this discussion on the web visit
    https://groups.google.com/d/msg/rubyonrails-talk/-/uZ-aasgriFwJ.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    -------------------------------------------------------------
    visit my blog at http://jimlabs.heroku.com
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonra...@googlegroups.com<javascript:>.
    To unsubscribe from this group, send email to
    rubyonrails-ta...@googlegroups.com <javascript:>.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/rubyonrails-talk/-/m6H6PcxH33IJ.

    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msg/rubyonrails-talk/-/p_Vty0mRRDQJ.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Colin Law at Oct 16, 2012 at 1:11 pm

    On 16 October 2012 13:57, Avi wrote:
    I tried with that. It is installing.
    But getting the same error while bundle install.
    Is rvm working ok? Does
    rvm info
    show sensible data? Have you added the line to .bashrc as indicated in
    rvm notes

    Colin
    On Tuesday, October 16, 2012 6:18:03 PM UTC+5:30, Colin Law wrote:
    On 16 October 2012 13:42, Avi wrote:
    I executed the command :- But I am getting this. I am in Ubuntu 10.10
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package libssl1.0.0
    E: Couldn't find any package by regex 'libssl1.0.0'
    Try
    sudo apt-get install openssl libssl-dev

    Colin

    On Tuesday, October 16, 2012 5:58:27 PM UTC+5:30, jim wrote:


    On Tue, Oct 16, 2012 at 8:17 PM, Avi wrote:

    Hello All,

    I am getting this error while running bundle install from
    console...........
    I tried to install libyaml & libtool & reinstalled all ruby.
    But still I am getting the same error :-
    Ruby - 1.9.3-p194
    Jruby- 1.6.8
    Rails - 3.2.6


    Unfortunately, a fatal error has occurred. Please see the Bundler
    troubleshooting documentation at http://bit.ly/bundler-issues. Thanks!


    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require': libcrypto.so.1.0.0: cannot open shared object file: No such
    file
    or directory -

    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/i686-linux/digest/sha1.so
    (LoadError)

    hi! i recently upgraded to precise pangolin and i encountered issues
    like
    this one. usually, when you see errors like these, search
    for the missing library and install the package that contains it. For
    this error, the package you want is libssl1.0.0 (in ubuntu). so
    install
    that by sudo apt-get install libssl1.0.0 (in ubuntu).
    from

    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    from

    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/definition.rb:1:in
    `<top (required)>'
    from

    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler.rb:144:in
    `definition'
    from

    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/cli.rb:228:in
    `install'
    from

    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/task.rb:27:in
    `run'
    from

    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/invocation.rb:120:in
    `invoke_task'
    from

    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor.rb:275:in
    `dispatch'
    from

    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/base.rb:408:in
    `start'
    from

    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
    `block in <top (required)>'
    from

    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/friendly_errors.rb:4:in
    `with_friendly_errors'
    from

    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
    `<top (required)>'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `load'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `<main>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in
    `eval'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in
    `<main>'


    Any guide will be helpful...
    Thanks

    --
    You received this message because you are subscribed to the Google
    Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonra...@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-ta...@googlegroups.com.

    To view this discussion on the web visit
    https://groups.google.com/d/msg/rubyonrails-talk/-/uZ-aasgriFwJ.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    -------------------------------------------------------------
    visit my blog at http://jimlabs.heroku.com
    --
    You received this message because you are subscribed to the Google
    Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonra...@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-ta...@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/rubyonrails-talk/-/m6H6PcxH33IJ.

    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Avi at Oct 16, 2012 at 1:45 pm
    Yes, rvm is working fine.
    version - 1.16.13
    I have added in .bashrc file also .
    But I don't know why I am getting this error.
    On Tuesday, October 16, 2012 6:38:36 PM UTC+5:30, Colin Law wrote:
    On 16 October 2012 13:57, Avi <aavinas...@gmail.com <javascript:>> wrote:
    I tried with that. It is installing.
    But getting the same error while bundle install.
    Is rvm working ok? Does
    rvm info
    show sensible data? Have you added the line to .bashrc as indicated in
    rvm notes

    Colin
    On Tuesday, October 16, 2012 6:18:03 PM UTC+5:30, Colin Law wrote:
    On 16 October 2012 13:42, Avi wrote:
    I executed the command :- But I am getting this. I am in Ubuntu
    10.10
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package libssl1.0.0
    E: Couldn't find any package by regex 'libssl1.0.0'
    Try
    sudo apt-get install openssl libssl-dev

    Colin

    On Tuesday, October 16, 2012 5:58:27 PM UTC+5:30, jim wrote:


    On Tue, Oct 16, 2012 at 8:17 PM, Avi wrote:

    Hello All,

    I am getting this error while running bundle install from
    console...........
    I tried to install libyaml & libtool & reinstalled all ruby.
    But still I am getting the same error :-
    Ruby - 1.9.3-p194
    Jruby- 1.6.8
    Rails - 3.2.6


    Unfortunately, a fatal error has occurred. Please see the Bundler
    troubleshooting documentation at http://bit.ly/bundler-issues.
    Thanks!
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require': libcrypto.so.1.0.0: cannot open shared object file: No
    such
    file
    or directory -
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/i686-linux/digest/sha1.so
    (LoadError)

    hi! i recently upgraded to precise pangolin and i encountered issues
    like
    this one. usually, when you see errors like these, search
    for the missing library and install the package that contains it.
    For
    this error, the package you want is libssl1.0.0 (in ubuntu). so
    install
    that by sudo apt-get install libssl1.0.0 (in ubuntu).
    from
    /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/definition.rb:1:in
    `<top (required)>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler.rb:144:in
    `definition'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/cli.rb:228:in
    `install'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/task.rb:27:in
    `run'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/invocation.rb:120:in
    `invoke_task'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor.rb:275:in
    `dispatch'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/base.rb:408:in
    `start'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
    `block in <top (required)>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/friendly_errors.rb:4:in
    `with_friendly_errors'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in
    `<top (required)>'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in
    `load'
    from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in
    `<main>'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in
    `eval'
    from
    /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in
    `<main>'


    Any guide will be helpful...
    Thanks

    --
    You received this message because you are subscribed to the Google
    Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonra...@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-ta...@googlegroups.com.

    To view this discussion on the web visit
    https://groups.google.com/d/msg/rubyonrails-talk/-/uZ-aasgriFwJ.
    For more options, visit https://groups.google.com/groups/opt_out.



    --
    -------------------------------------------------------------
    visit my blog at http://jimlabs.heroku.com
    --
    You received this message because you are subscribed to the Google
    Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonra...@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-ta...@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/rubyonrails-talk/-/m6H6PcxH33IJ.

    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msg/rubyonrails-talk/-/8xj4NodRxjcJ.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jordon Bedwell at Oct 16, 2012 at 1:49 pm

    On Tue, Oct 16, 2012 at 8:45 AM, Avi wrote:
    Yes, rvm is working fine.
    version - 1.16.13
    I have added in .bashrc file also .
    But I don't know why I am getting this error.
    What is the output of ldconfig -p? You should see something like:

    ldconfig -p |grep libssl
    libssl3.so (libc6) => /usr/lib/i386-linux-gnu/libssl3.so
    libssl.so.1.0.0 (libc6) => /lib/i386-linux-gnu/libssl.so.1.0.0
    libssl.so.0.9.8 (libc6) => /lib/i386-linux-gnu/libssl.so.0.9.8
    libssl.so.0.9.8 (libc6) => /usr/lib/i386-linux-gnu/libssl.so.0.9.8
    libssl.so (libc6) => /usr/lib/i386-linux-gnu/libssl.so

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Avi at Oct 16, 2012 at 3:03 pm
    I uninstalled rvm, ruby, & gems everything...
    Then I installed a fresh from start. It seems to be working...
    Thanks all for your replies to help me out. :-)
    On Tuesday, October 16, 2012 7:19:55 PM UTC+5:30, Jordon Bedwell wrote:

    On Tue, Oct 16, 2012 at 8:45 AM, Avi <aavinas...@gmail.com <javascript:>>
    wrote:
    Yes, rvm is working fine.
    version - 1.16.13
    I have added in .bashrc file also .
    But I don't know why I am getting this error.
    What is the output of ldconfig -p? You should see something like:

    ldconfig -p |grep libssl
    libssl3.so (libc6) => /usr/lib/i386-linux-gnu/libssl3.so
    libssl.so.1.0.0 (libc6) => /lib/i386-linux-gnu/libssl.so.1.0.0
    libssl.so.0.9.8 (libc6) => /lib/i386-linux-gnu/libssl.so.0.9.8
    libssl.so.0.9.8 (libc6) => /usr/lib/i386-linux-gnu/libssl.so.0.9.8
    libssl.so (libc6) => /usr/lib/i386-linux-gnu/libssl.so
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msg/rubyonrails-talk/-/VUoF85MQyJIJ.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jordon Bedwell at Oct 16, 2012 at 1:05 pm

    On Tue, Oct 16, 2012 at 7:47 AM, Colin Law wrote:
    sudo apt-get install openssl libssl-dev
    To add to what Colin said when I can't recognize a lib right off the
    bat I do something like:

    apt-cache search libssl |grep -- -dev
    then pick the one that is right
    apt-cache show libssl-dev will give you the version.

    Though most of the time you will not have version issues with deep
    system libs like that unless the library is mad outdated then
    obviously you don't want it anyways.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jim Ruther Nill at Oct 16, 2012 at 1:50 pm

    On Tue, Oct 16, 2012 at 8:42 PM, Avi wrote:

    I executed the command :- But I am getting this. I am in Ubuntu 10.10
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package libssl1.0.0
    E: Couldn't find any package by regex 'libssl1.0.0'
    Have you tried installing other packages? like libssl-dev? see if that
    fixes it. If not, try to reinstall bundler and see
    what specific packages you're missing.

    On Tuesday, October 16, 2012 5:58:27 PM UTC+5:30, jim wrote:


    On Tue, Oct 16, 2012 at 8:17 PM, Avi wrote:

    Hello All,

    I am getting this error while running bundle install from
    console...........
    I tried to install libyaml & libtool & reinstalled all ruby.
    But still I am getting the same error :-
    Ruby - 1.9.3-p194
    Jruby- 1.6.8
    Rails - 3.2.6


    Unfortunately, a fatal error has occurred. Please see the Bundler
    troubleshooting documentation at http://bit.ly/bundler-issues. Thanks!
    /home/avinash/.rvm/rubies/**ruby-1.9.3-p194/lib/ruby/site_**
    ruby/1.9.1/rubygems/custom_**require.rb:36:in `require':
    libcrypto.so.1.0.0: cannot open shared object file: No such file or
    directory - /home/avinash/.rvm/rubies/**ruby-1.9.3-p194/lib/ruby/1.9.**1/i686-linux/digest/sha1.so
    (LoadError)
    hi! i recently upgraded to precise pangolin and i encountered issues like
    this one. usually, when you see errors like these, search
    for the missing library and install the package that contains it. For
    this error, the package you want is libssl1.0.0 (in ubuntu). so install
    that by sudo apt-get install libssl1.0.0 (in ubuntu).

    from /home/avinash/.rvm/rubies/**ruby-1.9.3-p194/lib/ruby/site_**
    ruby/1.9.1/rubygems/custom_**require.rb:36:in `require'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/gems/bundler-1.2.1/**lib/bundler/definition.rb:1:in
    `<top (required)>'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/gems/bundler-1.2.1/**lib/bundler.rb:144:in
    `definition'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/gems/bundler-1.2.1/**lib/bundler/cli.rb:228:in
    `install'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/gems/bundler-1.2.1/**
    lib/bundler/vendor/thor/task.**rb:27:in `run'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/gems/bundler-1.2.1/**
    lib/bundler/vendor/thor/**invocation.rb:120:in `invoke_task'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/gems/bundler-1.2.1/**
    lib/bundler/vendor/thor.rb:**275:in `dispatch'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/gems/bundler-1.2.1/**
    lib/bundler/vendor/thor/base.**rb:408:in `start'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/gems/bundler-1.2.1/**bin/bundle:14:in
    `block in <top (required)>'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/gems/bundler-1.2.1/**
    lib/bundler/friendly_errors.**rb:4:in `with_friendly_errors'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/gems/bundler-1.2.1/**bin/bundle:14:in
    `<top (required)>'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/bin/bundle:19:in `load'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/bin/bundle:19:in `<main>'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/bin/ruby_noexec_**wrapper:14:in
    `eval'
    from /home/avinash/.rvm/gems/ruby-**1.9.3-p194/bin/ruby_noexec_**wrapper:14:in
    `<main>'


    Any guide will be helpful...
    Thanks

    --
    You received this message because you are subscribed to the Google
    Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonra...@googlegroups.**com.
    To unsubscribe from this group, send email to rubyonrails-ta...@**
    googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/**
    msg/rubyonrails-talk/-/uZ-**aasgriFwJ<https://groups.google.com/d/msg/rubyonrails-talk/-/uZ-aasgriFwJ>
    .
    For more options, visit https://groups.google.com/**groups/opt_out<https://groups.google.com/groups/opt_out>
    .



    --
    ------------------------------**------------------------------**-
    visit my blog at http://jimlabs.heroku.com
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msg/rubyonrails-talk/-/m6H6PcxH33IJ.

    For more options, visit https://groups.google.com/groups/opt_out.



    --
    -------------------------------------------------------------
    visit my blog at http://jimlabs.heroku.com

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedOct 16, '12 at 12:18p
activeOct 16, '12 at 4:25p
posts11
users4
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase