Hello, since two days I have problem with a scenario that started to fails
with the error that there is a missing link. I narrowed the problem to
config/environments/test.rb and config.cache_classes and I change the
value now the scenario is passing with config.cache_classes = true. Here is
my full test.rb:

RbpCm::Application.configure do

config.action_mailer.default_url_options = { :host => PATH_TO_USE }

config.action_mailer.delivery_method = :test

config.cache_classes = true

config.whiny_nils = true

config.consider_all_requests_local = true
config.action_view.debug_rjs = true
config.action_controller.perform_caching = false

config.log_level = :debug

config.action_mailer.raise_delivery_errors = false

config.active_support.deprecation = :log

config.action_dispatch.best_standards_support = :builtin

end

I looked in google about config.cache_classes and I understood that if I
set it to false then my objects will be reloaded on every request. I found
that capybara wants this to be set to true. I am using cucumber and
capybara, rails 3.0.9 and ruby 1.9.2-p290
Can you tell me what are the proper settings for test.rb and for
config.cache_classes?

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To view this discussion on the web visit https://groups.google.com/d/msg/rubyonrails-talk/-/35TkSOpnBacJ.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedJun 27, '12 at 1:12p
activeJun 27, '12 at 1:12p
posts1
users1
websiterubyonrails.org
irc#RubyOnRails

1 user in discussion

Tsvetelina Borisova: 1 post

People

Translate

site design / logo © 2022 Grokbase