Hi,

I am getting an error while creating a new rails (3.2.3) project on
mac os x lion with rvm (with jewelrybox gui) and ruby v 1.9.3 as
default.

I tried gem install rails, gem install railties, and gem list does
show rails and railties, both version 3.2.3 are present.
rails new myproject
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/
1.8/rubygems.rb:777:in `report_activate_error': Could not find RubyGem
railties (>= 0) (Gem::LoadError)
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
ruby/1.8/rubygems.rb:211:in `activate'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
ruby/1.8/rubygems.rb:1056:in `gem'
from /usr/bin/rails:18

I get the same error when I run rails -v.

ruby -v shows 1.9.3, but rails seems to be picking ruby framework
version 1.8 above - is that the problem? If so, how can I get rails to
use ruby 1.9.3 instead?

Thanks
Anand

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Candor at Apr 5, 2012 at 2:51 pm
    I found the answer here
    - http://stackoverflow.com/questions/5713872/rails-command-line-not-found-when-installed-with-rvm

    I should *not* use sudo while installing rails - that way, rvm manages a
    separate copy of gems for each version of ruby.
    On Thursday, April 5, 2012 12:34:46 PM UTC+5:30, candor wrote:

    Hi,

    I am getting an error while creating a new rails (3.2.3) project on
    mac os x lion with rvm (with jewelrybox gui) and ruby v 1.9.3 as
    default.

    I tried gem install rails, gem install railties, and gem list does
    show rails and railties, both version 3.2.3 are present.
    rails new myproject
    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/
    1.8/rubygems.rb:777:in `report_activate_error': Could not find RubyGem
    railties (>= 0) (Gem::LoadError)
    from
    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
    ruby/1.8/rubygems.rb:211:in `activate'
    from
    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/
    ruby/1.8/rubygems.rb:1056:in `gem'
    from /usr/bin/rails:18

    I get the same error when I run rails -v.

    ruby -v shows 1.9.3, but rails seems to be picking ruby framework
    version 1.8 above - is that the problem? If so, how can I get rails to
    use ruby 1.9.3 instead?

    Thanks
    Anand
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/rubyonrails-talk/-/FI9cEK09_YEJ.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedApr 5, '12 at 7:04a
activeApr 5, '12 at 2:51p
posts2
users1
websiterubyonrails.org
irc#RubyOnRails

1 user in discussion

Candor: 2 posts

People

Translate

site design / logo © 2022 Grokbase