I have installed

ruby 1.9.2p318 (2012-02-14 revision 34678) [i686-linux]
rails 3.2.2
gem 1.8.21

on ubuntu 10.04


when i created my first application and tried running it on server I
get the following error not sure how to proceed further....

/home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/execjs/
runtimes.rb:50:in `autodetect': Could not find a JavaScript runtime.
See https://github.com/sstephenson/execjs for a list of available
runtimes. (ExecJS::RuntimeUnavailable)
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
execjs.rb:5:in `<module:ExecJS>'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
execjs.rb:4:in `<top (required)>'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
script-2.2.0/lib/coffee_script.rb:1:in `require'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
script-2.2.0/lib/coffee_script.rb:1:in `<top (required)>'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
script-2.2.0/lib/coffee-script.rb:1:in `require'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
script-2.2.0/lib/coffee-script.rb:1:in `<top (required)>'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
rails-3.2.2/lib/coffee-rails.rb:1:in `require'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
rails-3.2.2/lib/coffee-rails.rb:1:in `<top (required)>'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
bundler/runtime.rb:68:in `require'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
bundler/runtime.rb:68:in `block (2 levels) in require'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
bundler/runtime.rb:66:in `each'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
bundler/runtime.rb:66:in `block in require'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
bundler/runtime.rb:55:in `each'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
bundler/runtime.rb:55:in `require'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
bundler.rb:119:in `require'
  from /home/fakirbaba/mitin/railsprograms/firstapp/config/
application.rb:7:in `<top (required)>'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
lib/rails/commands.rb:53:in `require'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
lib/rails/commands.rb:53:in `block in <top (required)>'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
lib/rails/commands.rb:50:in `tap'
  from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
lib/rails/commands.rb:50:in `<top (required)>'
  from script/rails:6:in `require'
  from script/rails:6:in `<main>'


thanks

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Rai M at Mar 27, 2012 at 6:13 am
    re installed gem
    execjs (1.3.0)
    On Tue, Mar 27, 2012 at 11:34 AM, Rai M wrote:



    I have installed

    ruby 1.9.2p318 (2012-02-14 revision 34678) [i686-linux]
    rails 3.2.2
    gem 1.8.21

    on ubuntu 10.04


    when i created my first application and tried running it on server I
    get the following error not sure how to proceed further....

    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/execjs/
    runtimes.rb:50:in `autodetect': Could not find a JavaScript runtime.
    See https://github.com/sstephenson/execjs for a list of available
    runtimes. (ExecJS::RuntimeUnavailable)
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
    execjs.rb:5:in `<module:ExecJS>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
    execjs.rb:4:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee_script.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee_script.rb:1:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee-script.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee-script.rb:1:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    rails-3.2.2/lib/coffee-rails.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    rails-3.2.2/lib/coffee-rails.rb:1:in `<top (required)>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:68:in `require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:68:in `block (2 levels) in require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:66:in `each'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:66:in `block in require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:55:in `each'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:55:in `require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler.rb:119:in `require'
    from /home/fakirbaba/mitin/railsprograms/firstapp/config/
    application.rb:7:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:53:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:53:in `block in <top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:50:in `tap'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:50:in `<top (required)>'
    from script/rails:6:in `require'
    from script/rails:6:in `<main>'


    thanks

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Colin Law at Mar 27, 2012 at 8:59 am

    On 27 March 2012 07:13, Rai M wrote:
    re installed gem
    execjs (1.3.0)
    So has that fixed it? Not much point telling us you have re-installed
    unless you tell us what the outcome was.

    Colin
    On Tue, Mar 27, 2012 at 11:34 AM, Rai M wrote:



    I have installed

    ruby 1.9.2p318 (2012-02-14 revision 34678) [i686-linux]
    rails 3.2.2
    gem 1.8.21

    on ubuntu 10.04


    when i created my first application and tried running it on server I
    get the following error not sure how to proceed further....

    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/execjs/
    runtimes.rb:50:in `autodetect': Could not find a JavaScript runtime.
    See https://github.com/sstephenson/execjs for a list of available
    runtimes. (ExecJS::RuntimeUnavailable)
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
    execjs.rb:5:in `<module:ExecJS>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
    execjs.rb:4:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee_script.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee_script.rb:1:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee-script.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee-script.rb:1:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    rails-3.2.2/lib/coffee-rails.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    rails-3.2.2/lib/coffee-rails.rb:1:in `<top (required)>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:68:in `require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:68:in `block (2 levels) in require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:66:in `each'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:66:in `block in require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:55:in `each'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:55:in `require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler.rb:119:in `require'
    from /home/fakirbaba/mitin/railsprograms/firstapp/config/
    application.rb:7:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:53:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:53:in `block in <top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:50:in `tap'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:50:in `<top (required)>'
    from script/rails:6:in `require'
    from script/rails:6:in `<main>'


    thanks

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.


    --
    gplus.to/clanlaw

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Pravin Mishra at Mar 27, 2012 at 9:22 am
    I faced same issues. add these gem in assets group

    gem 'uglifier'
       gem 'therubyracer'

    then run bundle install.

    It works for me.
    On 27 March 2012 14:28, Colin Law wrote:
    On 27 March 2012 07:13, Rai M wrote:
    re installed gem
    execjs (1.3.0)
    So has that fixed it? Not much point telling us you have re-installed
    unless you tell us what the outcome was.

    Colin
    On Tue, Mar 27, 2012 at 11:34 AM, Rai M wrote:



    I have installed

    ruby 1.9.2p318 (2012-02-14 revision 34678) [i686-linux]
    rails 3.2.2
    gem 1.8.21

    on ubuntu 10.04


    when i created my first application and tried running it on server I
    get the following error not sure how to proceed further....

    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/execjs/
    runtimes.rb:50:in `autodetect': Could not find a JavaScript runtime.
    See https://github.com/sstephenson/execjs for a list of available
    runtimes. (ExecJS::RuntimeUnavailable)
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
    execjs.rb:5:in `<module:ExecJS>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
    execjs.rb:4:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee_script.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee_script.rb:1:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee-script.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee-script.rb:1:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    rails-3.2.2/lib/coffee-rails.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    rails-3.2.2/lib/coffee-rails.rb:1:in `<top (required)>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:68:in `require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:68:in `block (2 levels) in require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:66:in `each'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:66:in `block in require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:55:in `each'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:55:in `require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler.rb:119:in `require'
    from /home/fakirbaba/mitin/railsprograms/firstapp/config/
    application.rb:7:in `<top (required)>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:53:in `require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:53:in `block in <top (required)>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:50:in `tap'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:50:in `<top (required)>'
    from script/rails:6:in `require'
    from script/rails:6:in `<main>'


    thanks

    --
    You received this message because you are subscribed to the Google
    Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.


    --
    gplus.to/clanlaw

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Rai M at Mar 27, 2012 at 10:01 am
    no the problem is still same.......
    On Tue, Mar 27, 2012 at 2:28 PM, Colin Law wrote:
    On 27 March 2012 07:13, Rai M wrote:
    re installed gem
    execjs (1.3.0)o t
    So has that fixed it? Not much point telling us you have re-installed
    unless you tell us what the outcome was.

    Colin
    On Tue, Mar 27, 2012 at 11:34 AM, Rai M wrote:



    I have installed

    ruby 1.9.2p318 (2012-02-14 revision 34678) [i686-linux]
    rails 3.2.2
    gem 1.8.21

    on ubuntu 10.04


    when i created my first application and tried running it on server I
    get the following error not sure how to proceed further....

    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/execjs/
    runtimes.rb:50:in `autodetect': Could not find a JavaScript runtime.
    See https://github.com/sstephenson/execjs for a list of available
    runtimes. (ExecJS::RuntimeUnavailable)
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
    execjs.rb:5:in `<module:ExecJS>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
    execjs.rb:4:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee_script.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee_script.rb:1:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee-script.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee-script.rb:1:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    rails-3.2.2/lib/coffee-rails.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    rails-3.2.2/lib/coffee-rails.rb:1:in `<top (required)>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:68:in `require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:68:in `block (2 levels) in require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:66:in `each'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:66:in `block in require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:55:in `each'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:55:in `require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler.rb:119:in `require'
    from /home/fakirbaba/mitin/railsprograms/firstapp/config/
    application.rb:7:in `<top (required)>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:53:in `require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:53:in `block in <top (required)>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:50:in `tap'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:50:in `<top (required)>'
    from script/rails:6:in `require'
    from script/rails:6:in `<main>'


    thanks

    --
    You received this message because you are subscribed to the Google
    Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.


    --
    gplus.to/clanlaw

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Chitrank Samaiya at Mar 27, 2012 at 10:03 am
    add gem therubyracer in your gemfile,then check it.
    for ubantu users it gives problem while fir window there is no such problem.


    regards
    chitrank

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Pravin Mishra at Mar 27, 2012 at 10:16 am
    include this gem too in gem file and run bunlde install

    gem 'execjs'

    http://stackoverflow.com/questions/6282307/execjs-and-could-not-find-a-javascript-runtime
    On 27/03/2012, Chitrank Samaiya wrote:
    add gem therubyracer in your gemfile,then check it.
    for ubantu users it gives problem while fir window there is no such problem.


    regards
    chitrank

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Prabu Duraisamy at Mar 27, 2012 at 6:18 am
    Hi,

    Install JavaScript runtime environment in your systems by using
    following steps.

    Add in Gemfile,

    gem 'execjs'
    gem 'therubyracer'

    and run bundle install.

    Rai M wrote in post #1053476:
    I have installed

    ruby 1.9.2p318 (2012-02-14 revision 34678) [i686-linux]
    rails 3.2.2
    gem 1.8.21

    on ubuntu 10.04


    when i created my first application and tried running it on server I
    get the following error not sure how to proceed further....

    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/execjs/
    runtimes.rb:50:in `autodetect': Could not find a JavaScript runtime.
    See https://github.com/sstephenson/execjs for a list of available
    runtimes. (ExecJS::RuntimeUnavailable)
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
    execjs.rb:5:in `<module:ExecJS>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
    execjs.rb:4:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee_script.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee_script.rb:1:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee-script.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee-script.rb:1:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    rails-3.2.2/lib/coffee-rails.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    rails-3.2.2/lib/coffee-rails.rb:1:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:68:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:68:in `block (2 levels) in require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:66:in `each'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:66:in `block in require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:55:in `each'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:55:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler.rb:119:in `require'
    from /home/fakirbaba/mitin/railsprograms/firstapp/config/
    application.rb:7:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:53:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:53:in `block in <top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:50:in `tap'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:50:in `<top (required)>'
    from script/rails:6:in `require'
    from script/rails:6:in `<main>'


    thanks
    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Munyekif at Feb 12, 2013 at 8:21 pm
    sudo apt-get install nodejs
    worked for me
    On Tuesday, March 27, 2012 9:04:27 AM UTC+3, Rai M wrote:



    I have installed

    ruby 1.9.2p318 (2012-02-14 revision 34678) [i686-linux]
    rails 3.2.2
    gem 1.8.21

    on ubuntu 10.04


    when i created my first application and tried running it on server I
    get the following error not sure how to proceed further....

    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/execjs/
    runtimes.rb:50:in `autodetect': Could not find a JavaScript runtime.
    See https://github.com/sstephenson/execjs for a list of available
    runtimes. (ExecJS::RuntimeUnavailable)
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
    execjs.rb:5:in `<module:ExecJS>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/execjs-1.3.0/lib/
    execjs.rb:4:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee_script.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee_script.rb:1:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee-script.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    script-2.2.0/lib/coffee-script.rb:1:in `<top (required)>'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    rails-3.2.2/lib/coffee-rails.rb:1:in `require'
    from /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/coffee-
    rails-3.2.2/lib/coffee-rails.rb:1:in `<top (required)>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:68:in `require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:68:in `block (2 levels) in require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:66:in `each'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:66:in `block in require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:55:in `each'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler/runtime.rb:55:in `require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/bundler-1.1.3/lib/
    bundler.rb:119:in `require'
    from /home/fakirbaba/mitin/railsprograms/firstapp/config/
    application.rb:7:in `<top (required)>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:53:in `require'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:53:in `block in <top (required)>'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:50:in `tap'
    from
    /home/fakirbaba/.rvm/gems/ruby-1.9.2-p318/gems/railties-3.2.2/
    lib/rails/commands.rb:50:in `<top (required)>'
    from script/rails:6:in `require'
    from script/rails:6:in `<main>'


    thanks
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msg/rubyonrails-talk/-/6ZgIxR9hC94J.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Buminda N. at Jul 10, 2013 at 3:13 pm

    unknown wrote in post #1096534:
    sudo apt-get install nodejs
    worked for me

    Thanks , this worked for me and rails server is now up and running.

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/651551d257a9a535399e95feb068d2ec%40ruby-forum.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Buminda N. at Jul 10, 2013 at 3:13 pm

    unknown wrote in post #1096534:
    sudo apt-get install nodejs
    worked for me

    Thanks , this worked for me and rails server is now up and running.

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/c6f0e92d277ff9b0e2697401118eff8d%40ruby-forum.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedMar 27, '12 at 6:04a
activeJul 10, '13 at 3:13p
posts11
users6
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2021 Grokbase