My system is:
Ubuntu 10.04, JRuby 1.6.7, Ruby on Rails 3.0.9,
activerecord-jdbc-adapter 1.2.2, activerecord-jdbcderby-adapter

Up until a few days ago, "rake test:units" was working fine, but now
suddenly it fails with the following message:

-------------------------------------------------
Task not supported by 'jdbc' <<--same msg for 'jdbcsqlite3' and 'derby'

Tasks: TOP => db:test:load => db:test:purge
--------------------------------------------------

I tried this using derby, jdbcsqlite and jdbc, all fail with the same
message. I assume it is environment related, as the same code in another
Ubuntu machine (11.10) runs just fine. I compared gem versions and they
are the same in both machines.

Has anyone faced this problem before and can suggest a solution or
workaround?

--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedMar 20, '12 at 2:29a
activeMar 20, '12 at 2:29a
posts1
users1
websiterubyonrails.org
irc#RubyOnRails

1 user in discussion

Alex S.: 1 post

People

Translate

site design / logo © 2021 Grokbase