HiAll,

Here is strange problem.

Application is on cloud server. Database server is on another instance
and application hosted on different instance.

databse server ip : 170.2.14.131
application server ip : 170.2.14.137

development:
adapter: mysql
database: database_name
username: ************
password: ************
host: 170.2.14.131

This is my database.yml configuration for development environment.

Now when i am trying to connect through my application it's using
application server IP instead of remote databse IP.

Please suggest.

--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Colin Law at Mar 20, 2012 at 9:43 am

    On 20 March 2012 07:44, Dharmdip Rathod wrote:
    HiAll,

    Here is strange problem.

    Application is on cloud server. Database server is on another instance
    and application hosted on different instance.

    databse server ip : 170.2.14.131
    application server ip : 170.2.14.137

    development:
    adapter: mysql
    database: database_name
    username: ************
    password: ************
    host: 170.2.14.131

    This is my database.yml configuration for development environment.

    Now when i am  trying to connect through my application it's using
    application server IP instead of remote databse IP.
    Have you restarted the server since you changed database.yml?
    Are you running in development mode on the server?
    You could try putting an error in your database.yml to make sure it is
    using it. Put invalid username in for example.

    Colin
    Please suggest.

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.


    --
    gplus.to/clanlaw

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Dharmdip Rathod at Mar 21, 2012 at 10:52 am
    Overcome issue by setting Mysql privileges , thanks for all support.

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Dharmdip Rathod at Mar 22, 2012 at 2:10 pm
    HiAll,

    Here is strange problem.

    Application is on cloud server. Database server is on another instance
    and application hosted on different instance.

    databse server ip : xxx.xxx.xxx.xxx
    application server ip : yyy.yyy.yyy.yyy

    development:
    adapter: mysql
    database: database_name
    username: ************
    password: ************
    host: xxx.xxx.xxx.xxx

    This is my database.yml configuration for development environment.

    Now when i am trying to connect through my application it's using
    application server IP yyy.yyy.yyy.yyy instead of remote databse IP
    xxx.xxx.xxx.xxx.

    Please suggest.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedMar 20, '12 at 7:44a
activeMar 22, '12 at 2:10p
posts4
users3
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2021 Grokbase