Hi Guys:
I'm new to Rails , I just installed it today, and tried to deploy an app
on the localhost, when i run the rails server
i got it like the screen-shot, there's no error message, WEbrick does
not start , it automatically "quits", tried many times, what probable
causes could there be , and how to solve it?
Many Thanks.
Rails version 3.2.1
Ruby 1.9.3

Attachments:
http://www.ruby-forum.com/attachment/7100/prob_rails.jpg


--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Luis Lavena at Feb 25, 2012 at 4:27 pm

    On Feb 25, 12:14 pm, zhou qing wrote:
    Hi Guys:
    I'm new to Rails , I just installed it today, and tried to deploy an app
    on the localhost, when i run the rails server
    i got it like the screen-shot, there's no error message, WEbrick does
    not start , it automatically "quits", tried many times, what probable
    causes could there be , and how to solve it?
    Many Thanks.
    Rails version 3.2.1
    Ruby 1.9.3

    Attachments:http://www.ruby-forum.com/attachment/7100/prob_rails.jpg
    Looking at the screenshot it seems you created an application in a
    path with spaces (Documents and Settings)

    Please avoid spaces in the path. Please create another application in
    a directory without spaces.

    If you installed RailsInstaller, you can create your application
    inside C:\Sites directory.

    Hope that helps.

    --
    Luis Lavena

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Nikolay at Feb 25, 2012 at 7:30 pm
    Yes, and stop programming rails under Windows =)
    https://www.virtualbox.org/ with Linux is the best choice.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Zhou qing at Feb 26, 2012 at 3:15 am
    Thank you for your reply, the 'space' isn't the cause of it, run on the
    root folder of the disk, same.check the new screen-shot.

    Attachments:
    http://www.ruby-forum.com/attachment/7104/prob_rails2.jpg


    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Luis Lavena at Feb 26, 2012 at 4:46 pm

    On Feb 26, 12:15 am, zhou qing wrote:
    Thank you for your reply, the 'space' isn't the cause of it, run on the
    root folder of the disk, same.check the new screen-shot.
    What is the result of:

    ruby script\rails server

    Also, do you have any Firewall or something that could be blocking?

    We need more information about your environment:

    gem env

    For some reason webrick is not starting properly, so there must be
    something in your setup that is producing that.

    Can you start a console instead?

    ruby script\rails console

    --
    Luis Lavena

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Nishant Jain at Oct 26, 2012 at 1:16 pm
    Can someone solve this error:
    /usr/local/lib/ruby/gems/1.8/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle:
    dlopen(/usr/local/lib/ruby/gems/1.8/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle,
    9): no suitable image found. Did find: (LoadError)
    /usr/local/lib/ruby/gems/1.8/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle:
    mach-o, but wrong architecture -
    /usr/local/lib/ruby/gems/1.8/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle
    from /usr/local/lib/ruby/gems/1.8/gems/mysql2-0.3.11/lib/mysql2.rb:9
    from
    /usr/local/lib/ruby/gems/1.8/gems/bundler-1.2.1/lib/bundler/runtime.rb:68:in
    `require'
    from
    /usr/local/lib/ruby/gems/1.8/gems/bundler-1.2.1/lib/bundler/runtime.rb:68:in
    `require'
    from
    /usr/local/lib/ruby/gems/1.8/gems/bundler-1.2.1/lib/bundler/runtime.rb:66:in
    `each'
    from
    /usr/local/lib/ruby/gems/1.8/gems/bundler-1.2.1/lib/bundler/runtime.rb:66:in
    `require'
    from
    /usr/local/lib/ruby/gems/1.8/gems/bundler-1.2.1/lib/bundler/runtime.rb:55:in
    `each'
    from
    /usr/local/lib/ruby/gems/1.8/gems/bundler-1.2.1/lib/bundler/runtime.rb:55:in
    `require'
    from /usr/local/lib/ruby/gems/1.8/gems/bundler-1.2.1/lib/bundler.rb:128:in
    `require'
    from /Users/njain15/Sites/simple_cms/config/application.rb:7
    from
    /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/commands.rb:53:in
    `require'
    from
    /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/commands.rb:53
    from
    /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/commands.rb:50:in
    `tap'
    from
    /usr/local/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/commands.rb:50
    from script/rails:6:in `require'
    from script/rails:6


    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msg/rubyonrails-talk/-/heKithMw098J.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedFeb 25, '12 at 3:14p
activeOct 26, '12 at 1:16p
posts6
users4
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase