Hello,

I'm having a very annoying problem.

I'm using Delayed Delta with thinking_sphinx and it has worked in the
past on this same environment and suddenly months later without touching
it, I restarted these processes and Delayed_delta has decided to
continue to shut down.

I have googled like crazy and find nothing. Can anyone make sense of
this and help me figure out what I need to do to get this working again?

Thank you in advance.


Below is the ridiculous out put I get when I start the delayed_delta:
=====================================================
# Logfile created on Wed Feb 08 12:33:11 -0800 2012 by logger.rb
*** below you find the most recent exception thrown, this will be likely
(but not certainly) the exception that made the application exit
abnormally ***
#<LoadError: no such file to load -- fast_xs>
*** below you find all exception objects found in memory, some of them
may have been thrown in your application, others may just be in memory
because they are standard exceptions ***
#<NoMemoryError: failed to allocate memory>
#<SystemStackError: stack level too deep>
#<fatal: exception reentered>
#<ActiveRecord::AdapterNotSpecified: development database is not
configured>
#<Errno::EACCES: Permission denied -
/path/to/releases/20120208194704/log/development.log>
#<LoadError: no such file to load -- fast_xs>
I, [2012-02-08T12:33:38.035071 #10229] INFO -- : *** below you find the
most recent exception thrown, this will be likely (but not certainly)
the exception that made the application exit abnormally ***
E, [2012-02-08T12:33:38.035188 #10229] ERROR -- : You have already
activated daemons 1.1.5, but your Gemfile requires daemons 1.1.0.
Consider using bundle exec. (Gem::LoadError)
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bundler-1.0.12/lib/bundler/runtime.rb:31:in
`setup'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bundler-1.0.12/lib/bundler/spec_set.rb:12:in
`each'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bundler-1.0.12/lib/bundler/spec_set.rb:12:in
`each'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bundler-1.0.12/lib/bundler/runtime.rb:17:in
`setup'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bundler-1.0.12/lib/bundler.rb:107:in
`setup'
/path/to/releases/20120208194704/config/boot.rb:8
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
/path/to/releases/20120208194704/config/application.rb:1
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
./config/environment.rb:2
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
script/delayed_delta:16
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:249:in
`call'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:249:in
`start_proc'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/daemonize.rb:200:in
`call'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/daemonize.rb:200:in
`call_as_daemon'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:253:in
`start_proc'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:293:in
`start'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/controller.rb:83:in
`run'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons.rb:195:in
`run_proc'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/cmdline.rb:109:in
`call'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/cmdline.rb:109:in
`catch_exceptions'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons.rb:194:in
`run_proc'
script/delayed_delta:14
I, [2012-02-08T12:33:38.035249 #10229] INFO -- : *** below you find all
exception objects found in memory, some of them may have been thrown in
your application, others may just be in memory because they are standard
exceptions ***
E, [2012-02-08T12:33:38.035471 #10229] ERROR -- : failed to allocate
memory (NoMemoryError)

E, [2012-02-08T12:33:38.035536 #10229] ERROR -- : stack level too deep
(SystemStackError)

E, [2012-02-08T12:33:38.035588 #10229] ERROR -- : exception reentered
(fatal)

E, [2012-02-08T12:33:38.037973 #10229] ERROR -- : no such file to load
-- bundler (LoadError)
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
/path/to/releases/20120208194704/config/boot.rb:7
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
/path/to/releases/20120208194704/config/application.rb:1
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
./config/environment.rb:2
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
script/delayed_delta:16
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:249:in
`call'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:249:in
`start_proc'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/daemonize.rb:200:in
`call'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/daemonize.rb:200:in
`call_as_daemon'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:253:in
`start_proc'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:293:in
`start'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/controller.rb:83:in
`run'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons.rb:195:in
`run_proc'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/cmdline.rb:109:in
`call'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/cmdline.rb:109:in
`catch_exceptions'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons.rb:194:in
`run_proc'
script/delayed_delta:14
E, [2012-02-08T12:33:38.038287 #10229] ERROR -- : can't find gem bundler
(1.0.12) (Gem::GemNotFoundException)
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems.rb:323:in
`bin_path'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bundler-1.0.12/lib/bundler/runtime.rb:130:in
`setup_environment'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bundler-1.0.12/lib/bundler/runtime.rb:13:in
`setup'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bundler-1.0.12/lib/bundler.rb:107:in
`setup'
/path/to/releases/20120208194704/config/boot.rb:8
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
/path/to/releases/20120208194704/config/application.rb:1
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
./config/environment.rb:2
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
script/delayed_delta:16
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:249:in
`call'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:249:in
`start_proc'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/daemonize.rb:200:in
`call'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/daemonize.rb:200:in
`call_as_daemon'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:253:in
`start_proc'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:293:in
`start'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/controller.rb:83:in
`run'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons.rb:195:in
`run_proc'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/cmdline.rb:109:in
`call'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/cmdline.rb:109:in
`catch_exceptions'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons.rb:194:in
`run_proc'
script/delayed_delta:14
E, [2012-02-08T12:33:38.048948 #10229] ERROR -- : You have already
activated daemons 1.1.5, but your Gemfile requires daemons 1.1.0.
Consider using bundle exec. (Gem::LoadError)
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bundler-1.0.12/lib/bundler/runtime.rb:31:in
`setup'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bundler-1.0.12/lib/bundler/spec_set.rb:12:in
`each'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bundler-1.0.12/lib/bundler/spec_set.rb:12:in
`each'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bundler-1.0.12/lib/bundler/runtime.rb:17:in
`setup'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/bundler-1.0.12/lib/bundler.rb:107:in
`setup'
/path/to/releases/20120208194704/config/boot.rb:8
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
/path/to/releases/20120208194704/config/application.rb:1
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
./config/environment.rb:2
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
script/delayed_delta:16
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:249:in
`call'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:249:in
`start_proc'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/daemonize.rb:200:in
`call'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/daemonize.rb:200:in
`call_as_daemon'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:253:in
`start_proc'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/application.rb:293:in
`start'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/controller.rb:83:in
`run'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons.rb:195:in
`run_proc'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/cmdline.rb:109:in
`call'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons/cmdline.rb:109:in
`catch_exceptions'
/opt/ruby-enterprise-1.8.7-2010.02/lib/ruby/gems/1.8/gems/daemons-1.1.5/lib/daemons.rb:194:in
`run_proc'
script/delayed_delta:14
*** below you find the most recent exception thrown, this will be likely
(but not certainly) the exception that made the application exit
abnormally ***
#<LoadError: no such file to load -- fast_xs>
*** below you find all exception objects found in memory, some of them
may have been thrown in your application, others may just be in memory
because they are standard exceptions ***
#<NoMemoryError: failed to allocate memory>
#<SystemStackError: stack level too deep>
#<fatal: exception reentered>
#<ActiveRecord::AdapterNotSpecified: development database is not
configured>
#<Errno::EACCES: Permission denied -
/path/to/releases/20120208194704/log/development.log>
#<LoadError: no such file to load -- fast_xs>
=====================================================

--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedFeb 8, '12 at 8:41p
activeFeb 8, '12 at 8:41p
posts1
users1
websiterubyonrails.org
irc#RubyOnRails

1 user in discussion

Keith Raymond: 1 post

People

Translate

site design / logo © 2022 Grokbase