Hi,
I am a new guy in Ruby on rails.I have installed ruby1.9.2p180, rails
3.2.1, gem 1.8.15,mysql,apache 2.0 and JetBrains RubyMine 3.1.1 .
Whenever, I am creating the application through he command prompt by
"rails new Blog" then "Blog" application is creating successfully and
start the server under "Blog" by "rails server". But whenever, I am
creating the project through the RubyMine IDE, lets say "Apt" and trying
to switch on the server, getting the following issue:


C:/ruby/lib/ruby/gems/1.9.1/gems/mysql2-0.3.11-x86-mingw32/lib/mysql2/mysql2.rb:
2:in `require': Incorrect MySQL client library version! This gem was
compiled fo
r 6.0.0 but the client library is 5.0.89. (RuntimeError)
from
C:/ruby/lib/ruby/gems/1.9.1/gems/mysql2-0.3.11-x86-mingw32/lib/mysq
l2/mysql2.rb:2:in `<top (required)>'
from
C:/ruby/lib/ruby/gems/1.9.1/gems/mysql2-0.3.11-x86-mingw32/lib/mysq
l2.rb:9:in `require'
from
C:/ruby/lib/ruby/gems/1.9.1/gems/mysql2-0.3.11-x86-mingw32/lib/mysq
l2.rb:9:in `<top (required)>'
from
C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runtime
.rb:68:in `require'
from
C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runtime
.rb:68:in `block (2 levels) in require'
from
C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runtime
.rb:66:in `each'
from
C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runtime
.rb:66:in `block in require'
from
C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runtime
.rb:55:in `each'
from
C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runtime
.rb:55:in `require'
from
C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler.rb:122:
in `require'
from C:/ruby/rubygem/Apt/config/application.rb:13:in `<top
(required)>'
from
C:/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.1/lib/rails/commands.
rb:53:in `require'
from
C:/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.1/lib/rails/commands.
rb:53:in `block in <top (required)>'
from
C:/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.1/lib/rails/commands.
rb:50:in `tap'
from
C:/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.1/lib/rails/commands.
rb:50:in `<top (required)>'
from script/rails:6:in `require'
from script/rails:6:in `<main>'

How can I solve this issue?

--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Prince Joseph at Feb 6, 2012 at 6:51 am
    It seems you have changed your MySQL version. You can try reinstalling
    mysql2 gem using:

    gem uninstall mysql2
    gem install mysql2

    On Mon, Feb 6, 2012 at 12:10 PM, Srimanta Chakraborty
    wrote:
    Hi,
    I am a new guy in Ruby on rails.I have installed ruby1.9.2p180, rails
    3.2.1, gem 1.8.15,mysql,apache 2.0 and JetBrains RubyMine 3.1.1 .
    Whenever, I am creating the application through he command prompt by
    "rails new Blog" then "Blog" application is creating successfully and
    start the server under "Blog" by "rails server". But whenever, I am
    creating the project through the RubyMine IDE, lets say "Apt" and trying
    to switch on the server, getting the following issue:



    C:/ruby/lib/ruby/gems/1.9.1/gems/mysql2-0.3.11-x86-mingw32/lib/mysql2/mysql2.rb:
    2:in `require': Incorrect MySQL client library version! This gem was
    compiled fo
    r 6.0.0 but the client library is 5.0.89. (RuntimeError)
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/mysql2-0.3.11-x86-mingw32/lib/mysq
    l2/mysql2.rb:2:in `<top (required)>'
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/mysql2-0.3.11-x86-mingw32/lib/mysq
    l2.rb:9:in `require'
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/mysql2-0.3.11-x86-mingw32/lib/mysq
    l2.rb:9:in `<top (required)>'
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runtime
    .rb:68:in `require'
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runtime
    .rb:68:in `block (2 levels) in require'
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runtime
    .rb:66:in `each'
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runtime
    .rb:66:in `block in require'
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runtime
    .rb:55:in `each'
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler/runtime
    .rb:55:in `require'
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler.rb:122:
    in `require'
    from C:/ruby/rubygem/Apt/config/application.rb:13:in `<top
    (required)>'
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.1/lib/rails/commands.
    rb:53:in `require'
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.1/lib/rails/commands.
    rb:53:in `block in <top (required)>'
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.1/lib/rails/commands.
    rb:50:in `tap'
    from
    C:/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.1/lib/rails/commands.
    rb:50:in `<top (required)>'
    from script/rails:6:in `require'
    from script/rails:6:in `<main>'

    How can I solve this issue?

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.

    --
    Thanks,
    Prince

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Srimanta Chakraborty at Feb 6, 2012 at 7:22 am

    Prince J. wrote in post #1044258:
    It seems you have changed your MySQL version. You can try reinstalling
    mysql2 gem using:

    gem uninstall mysql2
    gem install mysql2

    On Mon, Feb 6, 2012 at 12:10 PM, Srimanta Chakraborty
    wrote:
    from
    .rb:66:in `each'
    C:/ruby/lib/ruby/gems/1.9.1/gems/bundler-1.0.21/lib/bundler.rb:122:
    C:/ruby/lib/ruby/gems/1.9.1/gems/railties-3.2.1/lib/rails/commands.
    Posted via http://www.ruby-forum.com/.
    --
    Thanks,
    Prince
    Hi Prince,
    I uninstall mysql2 and install again. After creating new project
    through RubyMine IDE, one message is showing like "Some of the required
    gems are not
    attached:coffee-rails(~>3.2.1),jquery-rails,mysql2,sass-rails(~>3.2.3),uglifier(>=1.0.3)"
    Also "Attach gems" link is there. shall I click on that? By the way,
    after re-installing mysql2, I am getting the same issue again.

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedFeb 6, '12 at 6:41a
activeFeb 6, '12 at 7:22a
posts3
users2
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase